EasyMOD alpha3 v0.0.10a released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:08 pm

-=ET=- wrote: New release for my French translation! :D
Downloaded ;) Thanks!

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:15 pm

GPHemsley wrote: @Nuttzy: Do you have any code written for the following?
1) Copying *.ext
2) Copying *.*
3) Performing SQL

I thought I might try to start on come of that if you didn't. ;)
Heh, I think you may underestimate the these things a little. There's a reason they are not included in this version ;) It's possible that you could do the copying stuff, but you have to do it for ALL write/move methods. This is fairly tricky with FTP. But I already know how I want to do it, and its not that bad.

As for SQL.... no offense, but you don't have a prayer. You need to create and modify tables (can't be done with phpBB DBAL) for ALL databases supported. I already have this written anyway, just want to do some tests.

Even if you did do those other things, it's not like I would release a new version of EM until I'm ready anyway. I'd much rather see you fix that PASV problem you're having :mrgreen:

However, I have a feature in mind that I may throw out to the public to see how well they do. I'll let you know when I know ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:20 pm

Selven wrote: Testing selected write method
Testing FTP access...
1) Logged in successfully
FTP ERROR: could not cd to d:/inetpub/webs/zaioncom/public/forum/admin/mods/easymod
I was going to say that you probably have the FTP path wrong. But when I go to your site now it says that you did get EM installed. So looks like you got it figured out ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:23 pm

moriturimax wrote: I give up..
Wow! You are a dangerous man armed with chmod :lol: I suggest you...

1) delete all the EM files and directories
2) make sure your board is running properly
3) make sure everything is 744 access
4) load up a fresh download of EM
5) try again

...except for the initial error, all the errors you got where caused by your chmoding. The initial error will probably be solved if you get everything chmoded correctly.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
espenhh
Registered User
Posts: 215
Joined: Sun Mar 17, 2002 8:27 pm
Location: Norway
Contact:

Post by espenhh » Tue Aug 19, 2003 1:30 pm

Just to inform you, I have updated the norwegian translation and sent it to nuttzy (some weeks ago)...
Until he updates the post about the languages, you can download it here:
http://www.serqevx.com/espenhh/download ... wegian.zip

If there are any norwegians using EasyMOD, I would be glad if you tested it out, and reported to me if you find any spelling-mistakes... (via PM!!! ;))
ALT du trenger til phpBB - på Norsk!
Besøk phpbb.no:
Image

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:33 pm

FYI, a couple things that EM needs...

1) EM should determine if the user has the proper write access for FTP, throw an error if it doesn't, and explain what the user needs to do. I could have EM automatically chmod the files for them... but that could be crossing a line.

2) I need to put in the debug info whether or not they really have FTP debug mode on

3) Occasionally there are these wierd things with php functions not working like I would expect. I should list the PHP version in the debug info.

4) People need to be told on the first page that they don't need all those permissions set to OK!!!!

5) EM should do a little detective work for people that are entering the wrong paths for FTP.

6) Obviously there needs to be a better way for resolving the localhost issue (a text box where a host name can be entered).

7) Automatically enter FTP debug mode if an error is encountered.

I think if I had those things then life would be a bit easier for everyone. I'll probably throw most of them into the next release or make a 0.0.10b just to include these. All these things deal with installer debugging, so if you got 10a installed, then there's no reason to worry about installing 10b. We'll see.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:39 pm

William R wrote: This what happens when i do the default settings...
Hrmmm... do you have FTP debug mode on? I can't tell but I think you do. One thing I notice is that you have SmartFTP open. I don't think you can use the EM FTP ability if you already have an FTP connection established. I'm not sure. But I don't think you can have 2 connections on port 21. I have never seen that error with fsockopen before.
Other settings error...
Yes, safe mode is enabled on your web server so you will not be able to use the server write method.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:40 pm

espenhh wrote: Just to inform you, I have updated the norwegian translation and sent it to nuttzy (some weeks ago)...
Yeah, I'm slow :lol: Thanks for letting people know ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:44 pm

codevip.net wrote: nuttzy please help me. my post is on page 27 and 28
Ok, I've looked into things. It appears that there is some bug in EM so that the FTP debug info stops displaying after step 2. I will fix this and when I'm ready, I'll send you a PM informing you of where you can download the fix to display FTP info. Probably won't be until tonight though.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Akai
Registered User
Posts: 3
Joined: Sat Aug 16, 2003 6:40 am
Contact:

Post by Akai » Tue Aug 19, 2003 1:45 pm

Nuttzy99 wrote: 5. As per Step II of Attach:
  1. Copy the contents of amind/mods/attach_mod/root/install to install (in phpbb root)
  2. Run mod_table_inst.php through your web browser


...
Nuttzy99 wrote: 5. As per Step II of Attach:
  1. Copy the contents of admin/mods/attach_mod/root/install to install (in phpbb root)
  2. Run mod_table_inst.php through your web browser


just in case anyone takes the instructions extremely literally

easymod, good :) Thanks

User avatar
William R
Registered User
Posts: 291
Joined: Fri Jun 21, 2002 9:32 am
Location: Melbourne, Australia
Contact:

Post by William R » Tue Aug 19, 2003 1:51 pm

Step 2 (of 5): EasyMOD is now confirming your file access settings.

Testing selected write method
Testing FTP access...
Trying to localhost:21 ...
Error : Cannot connect to remote host "localhost:21"
Error : fsockopen() ()
FTP ERROR: could not connect to localhost


Did everything "Default"...And closed SmartFTP. Same error

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 1:55 pm

Akai wrote: just in case anyone takes the instructions extremely literally
Hahaha! Thanks, I'll fix that now ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 2:03 pm

William R wrote: Did everything "Default"...And closed SmartFTP. Same error
Hrmmmm... I really don't have a clue right now. Could have something to do with your version of PHP? Is it pretty old? Is it very new? I dunno.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue Aug 19, 2003 2:04 pm

NOTE: If I have not answered your question then I have forgotten about you. Ask again.

Otherwise I'm considering myself all caught up!

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
William R
Registered User
Posts: 291
Joined: Fri Jun 21, 2002 9:32 am
Location: Melbourne, Australia
Contact:

Post by William R » Tue Aug 19, 2003 2:04 pm

Its new, But ahh well. Dont worry about it, Just going to have to forget about this great mod then :cry:

Locked

Return to “[2.0.x] MOD Writers Discussion”