EasyMod alpha2 0.0.7 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
costco
Registered User
Posts: 38
Joined: Mon Nov 04, 2002 9:28 pm
Location: South Bend
Contact:

Post by costco » Wed Nov 13, 2002 6:24 pm

First off, thanks so much for this mod! I'm sure you're going to make alot of people happier!

I get this error, but haven't been able to figure out why:

Code: Select all

Information
Database type     :: msaccess
phpBB version     :: 2.0.3
EasyMod version   :: 0.0.7

Processing files
Parsing: includes/constants.php - NOTE: this file is not being altered in any way
Finding: ?>

Notice: Undefined offset: 0 in c:\inetpub\wwwroot\tncamp\phpbb2\admin\mods\EasyMod\admin_mod_functions.php on line 483
Insert before:
// EASYMOD-start
define('EASYMOD_TABLE', $table_prefix.'easymod');
// EASYMOD-end

Parsing: language/lang_english/lang_admin.php - NOTE: this file is not being altered in any way

Warning: fopen("../../../language/lang_french/lang_admin.php", "r") - No such file or directory in c:\inetpub\wwwroot\tncamp\phpbb2\admin\mods\EasyMod\admin_mod_functions.php on line 134

language/lang_english/lang_admin.php: Cannot open file for reading.
Current working dir: c:\inetpub\wwwroot\tncamp\phpbb2\admin\mods\EasyMod
I'm running windows xp as the server... any suggestions?

DoubleDoom
Registered User
Posts: 844
Joined: Wed Jun 26, 2002 6:48 pm

Post by DoubleDoom » Thu Nov 14, 2002 4:18 pm

Dvanes wrote: I tried to install Easymod 0.0.7 on a lycos board, but all I see is this:
Information
Database type :: mysql
phpBB version :: 2.0.2
EasyMod version :: 0.0.7

Processing files
Parsing: includes/constants.php - NOTE: this file is not being altered in any way

includes/constants.php: Cannot open file for writing.


I chmodded everything in ftp, so I don't get it... Does anybody know how to solve this?


I'm getting exactly the same problem and both servers i use (from different providers) are in safe mode. Looks like others with servers in safe mod are having problems too.

Lightwave
Registered User
Posts: 9
Joined: Thu Oct 10, 2002 6:34 am
Contact:

Post by Lightwave » Fri Nov 15, 2002 10:41 pm

DoubleDoom wrote:
Dvanes wrote:I tried to install Easymod 0.0.7 on a lycos board, but all I see is this:
Information
Database type :: mysql
phpBB version :: 2.0.2
EasyMod version :: 0.0.7

Processing files
Parsing: includes/constants.php - NOTE: this file is not being altered in any way

includes/constants.php: Cannot open file for writing.


I chmodded everything in ftp, so I don't get it... Does anybody know how to solve this?


I'm getting exactly the same problem and both servers i use (from different providers) are in safe mode. Looks like others with servers in safe mod are having problems too.


The main thing to check is to make sure that you made the EasyMod directory 777 (drwxrwxrwx)

When EasyMod runs... it will try and create a 'processed', and 'backups' directory inside of the directory the mod your installing is in.

It will also need to beable to write a few files... post_process.sh post_process.bat

the 'includes/constants.php' thing is saying that it's trying to update that file and save the updated version to EasyMod/processed/ but it doesnt have access to do so.

For more information... you could write a quick page which contains:
<? phpinfo();
?>

and write down/post the safe_mode settings...

lucaslim
Registered User
Posts: 3
Joined: Sat Nov 16, 2002 7:04 am

Post by lucaslim » Sun Nov 17, 2002 5:31 pm

Hi, do i need shell to execute the file /public_html/admin/mods/EasyMod/post_process.sh ?
I'm not sure how to do it, could someone help?
My hosting cannot enable shell

Lucas Lim

Lightwave
Registered User
Posts: 9
Joined: Thu Oct 10, 2002 6:34 am
Contact:

Post by Lightwave » Mon Nov 18, 2002 11:12 pm

No you COULD do it by hand...

Copy the ORIGINAL version of every file in the processed directory to the ./backups directory

cp $phpbbroot/directoy/file $phpbbroot/admin/mods/modname/backups/directory/file

Copy every file in the processed directory to it's respective location.

cp $phpbbroot/admin/mods/modname/processed/directory/file $phpbbroot/directory/file

Just open up the file and read it... It should be fairly obvious as to what it's doing.

(Granted since your doing this through FTP, copy/cp means downloading the file and uploading it back to the right location.

Haravikk
Registered User
Posts: 261
Joined: Sat Nov 02, 2002 4:42 pm

Post by Haravikk » Tue Nov 19, 2002 3:15 pm

I get the following error when I try to install:

Code: Select all

Finding: name="addbbcode18"
includes/constants.php: Could not find:
name="addbbcode18"
I looked in constants.php and there is no "addbbcode18" anywhere.

netclectic
Former Team Member
Posts: 4439
Joined: Wed Mar 13, 2002 3:08 pm
Location: Omnipresent
Contact:

Post by netclectic » Tue Nov 19, 2002 3:22 pm

Did you try searching for an answer to your question before you posted? I'm sure this problem has been asked and answered here before. IIRC, it's to do with having extra bbcode mods installed.
Defend the game:
Image

Haravikk
Registered User
Posts: 261
Joined: Sat Nov 02, 2002 4:42 pm

Post by Haravikk » Tue Nov 19, 2002 4:12 pm

I don't have anything installed though. It's a brand new phpBB board with a few extra styles.

fishbox
Registered User
Posts: 4
Joined: Sun Nov 24, 2002 3:02 am
Location: USA
Contact:

Post by fishbox » Tue Nov 26, 2002 3:12 am

Hi,
I think I have everything for easymod installed correctly, but when I click the "Install mod" button in the admin panel I received this message
"General Error
Couldn't obtain EasyMod information".
It seems not to be communicating with the mySQL database.
Any ideas?
Thanks.
nick

chap
Registered User
Posts: 31
Joined: Thu Jun 27, 2002 12:50 am
Contact:

Post by chap » Tue Nov 26, 2002 5:58 am

Hello!

I'm getting these errors:

Code: Select all

Processing files

Parsing: includes/constants.php - NOTE: this file is not being altered in any way
Warning: Unable to access ./processed/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 195

Warning: Unable to access ./backups/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 203

Warning: Unable to access ./backups/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 205

Warning: chmod failed: No such file or directory in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 205

Warning: Unable to access ./processed/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 57

Warning: Unable to access ./backups/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 62

Warning: Unable to access ./backups/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/mods/ EasyMod/admin_mod_functions.php on line 63

Warning: chmod failed: No such file or directory in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 63

Warning: Unable to access ./processed/includes/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 57

Warning: Unable to access ./backups/includes/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 62

Warning: Unable to access ./backups/includes/ in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 63

Warning: chmod failed: No such file or directory in /usr/local/psa/home/vhosts/chapfreelancer.com/httpdocs/main/phpbb/admin/ mods/EasyMod/admin_mod_functions.php on line 63

Warning: fopen("./processed/includes/constants.php.txt", "w") - No such file or directory in /usr/local/psa/home/vhosts/ chapfreelancer.com/httpdocs/main/phpbb/admin/mods/EasyMod/admin_mod_functions.php on line 287

includes/constants.php: Cannot open file for writing.
I assumed I did not chmod it properly, but all the files and folders have been individually chomod'ed 777. I think that my host does not allow writes by http. If that's the case, what can I do? THanks!

CHap

Dvanes
Registered User
Posts: 32
Joined: Thu Jun 06, 2002 9:56 am

Post by Dvanes » Tue Nov 26, 2002 12:00 pm

Lightwave wrote:
DoubleDoom wrote:
Dvanes wrote:I tried to install Easymod 0.0.7 on a lycos board, but all I see is this:
Information
Database type :: mysql
phpBB version :: 2.0.2
EasyMod version :: 0.0.7

Processing files
Parsing: includes/constants.php - NOTE: this file is not being altered in any way

includes/constants.php: Cannot open file for writing.


I chmodded everything in ftp, so I don't get it... Does anybody know how to solve this?


I'm getting exactly the same problem and both servers i use (from different providers) are in safe mode. Looks like others with servers in safe mod are having problems too.


The main thing to check is to make sure that you made the EasyMod directory 777 (drwxrwxrwx)

When EasyMod runs... it will try and create a 'processed', and 'backups' directory inside of the directory the mod your installing is in.

It will also need to beable to write a few files... post_process.sh post_process.bat

the 'includes/constants.php' thing is saying that it's trying to update that file and save the updated version to EasyMod/processed/ but it doesnt have access to do so.

For more information... you could write a quick page which contains:
<? phpinfo();
?>

and write down/post the safe_mode settings...


Okay, I've made a file called phpinfo.php. Have a look over here, and tell me what's wrong.
http://members.lycos.nl/dianevanes/forum/phpinfo.php

netclectic
Former Team Member
Posts: 4439
Joined: Wed Mar 13, 2002 3:08 pm
Location: Omnipresent
Contact:

Post by netclectic » Tue Nov 26, 2002 12:55 pm

Safe mode is most definitly on, which is most likely your main problem.

The easiest way to get it to work would be to find another host ;) One which offers full PHP instead of php4u.
Defend the game:
Image

filemaniac
Registered User
Posts: 7
Joined: Sat Oct 26, 2002 8:14 pm

Post by filemaniac » Wed Nov 27, 2002 2:56 pm

Haravikk wrote: I get the following error when I try to install:

Code: Select all

Finding: name="addbbcode18"
includes/constants.php: Could not find:
name="addbbcode18"
I looked in constants.php and there is no "addbbcode18" anywhere.


I'm getting the same error:

Code: Select all

Finding: name="addbbcode18"
includes/constants.php: Could not find:
name="addbbcode18"
Now here's the thing. I was trying to install this on a new 2.0.3 install. However, the same mod worked fine when I installed it on a 2.0.2 board patched to 2.0.3, off the same host. Perhaps there were changes that weren't accounted for when 2.0.3 was released?

filemaniac
Registered User
Posts: 7
Joined: Sat Oct 26, 2002 8:14 pm

Post by filemaniac » Wed Nov 27, 2002 3:25 pm

Interestingly enough, Alpha 2 0.0.6 works OK.

*scratches head*

Weird.

Ryan2318
Registered User
Posts: 25
Joined: Sun Oct 27, 2002 3:58 am
Contact:

Post by Ryan2318 » Wed Nov 27, 2002 8:44 pm

ok i ran the thing and since i can't do it via shell access I just copied the files from proccessed and overwrote the files that were already on the server. (i did convert the txt files to the proper php and tpl files btw. I mean when i got them they were ex. php.txt so i had to open notepad and save them as .php (or .tpl for the templates))

anyway i go into the admin cp and i don't see anything new for easymod. When I looked at the code before uploading all the files I saw there should be something on the sidebar to install new mods...

anyone know anything??

Locked

Return to “[2.0.x] MOD Writers Discussion”