Page 17 of 30

Posted: Mon Jan 20, 2003 6:48 am
by thinkfire
my bad, forgot to make it recursive

Posted: Mon Jan 20, 2003 7:07 am
by thinkfire
ok I got it to install and everything

I found admin_mod_install.php and patched it as you said

I could not find the other two files though....did something go wrong with the installation? I found those files with plus a .txt extension

this is what I get when I try to process a mod

The requested URL /forums/forums/admin/admin_mod_install.php was not found on this server.

problem is this file is at /forums/admin/admin_mod_install.php NOT /forums/forums/admin/admin_mod_install.php

I dont know enough about coding yet to fix this myself, seems like it would be an easy fix though

Posted: Mon Jan 20, 2003 7:26 am
by thinkfire
alright alright alright....I figured it out....all working smoothly for 2.0.4 now


you might want to specify in your post that those two tpl files are in the /templates/{templatename} directory

Posted: Mon Jan 20, 2003 7:28 am
by thinkfire
lol now I got a new problem, and I know for sure this one is out of my reach

I clicked on the left/right mod and clicked process

I clicked on perform db alteration

and get this...

bbcode.php : Could not find [$patterns[5] =$replacements[5] =]

if you perform a DB operation on the flags one, then you get this

usercp_register.php : Could not find [$location = htmlspecialchars($userdata['user_from']);]

Posted: Mon Jan 20, 2003 8:04 am
by netclectic
That's because the mods included with easymod have not been updated for 2.0.4 yet. Go find a 2.0.4 compatible mod and it should work ok.

Posted: Tue Jan 28, 2003 3:53 pm
by Paul Saulnier
juliekate wrote: Thanks. I'll give it a whirl :)

edit

I just installed this - getting a slew of these

Code: Select all

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site82/web/ours/board/admin/mods/EasyMod/easymod_install_0-0-7.php on line 160
It's performing the install, no errors on anything else and I see the link...there's about 30-40 of these errors above calling different lines.

In a previous release (I searched) Nuttzy says this would be fixed in a future release - that was back in May.

Here are the snips of code:

Code: Select all

 line 160
function wrapper_find( $read_list, $write_list, $find_array, $search_array)
{
	echo "<b>Finding:</b> " ;
	$stmp = '' ;
	for ( $i=0; $i<count($search_array); $i++)
	{
		$stmp .= $search_array[$i] . "<br>" ;
		echo htmlspecialchars($search_array[$i]) . "<br>" ;
	}

	if (!perform_find( &$read_list, &$write_list, &$find_array, &$search_array))
	{
		echo "includes/constants.php: Could not find:<br>" . $stmp . "\n" ;
		exit ;
	}
}

Code: Select all

 line 181-187
if ( $where == 'before')
	{
		write_files( &$write_list, $insert_string) ;
		write_find_array( &$find_array, &$write_list) ;
	}
	else if ( $where == 'after')
	{
		write_find_array( &$find_array, &$write_list) ;
		write_files( &$write_list, $insert_string) ;
	}
	$insert = array() ;
}
[edit again] It seems it is giving this error on almost every instance of &$write_list in the PHP.


I am having this same problem. I don't have the ability to edit the php.ini file. Is there a version of EasyMod with this problem solved?

Posted: Tue Jan 28, 2003 4:46 pm
by morpheus2matrix
which version of EasyMod are you running ?

Posted: Tue Jan 28, 2003 4:52 pm
by Paul Saulnier
I am running the latest. .7 I beleive. I just downloaded it yesterday.

Posted: Tue Jan 28, 2003 5:09 pm
by morpheus2matrix
and which version of phpBB ?

Posted: Tue Jan 28, 2003 5:15 pm
by Paul Saulnier
Also the latest, with some mods installed.

HOWEVER, I beleive this problem is with the php.ini file, or EasyMOD itself based on the error message. I think the coding needs to be updated or something.

Posted: Tue Jan 28, 2003 5:17 pm
by morpheus2matrix
yes, i think also that the EasyMod need to be update : a lot of members seems to have problems to install it on phpBB 2.0.4

Posted: Fri Jan 31, 2003 12:31 am
by Novice_Gamer
Information
Database type :: mysql
phpBB version :: 2.0.3
EasyMod version :: 0.0.7

Processing files
Parsing: includes/constants.php - NOTE: this file is not being altered in any way
Finding: ?>
Insert before:
// EASYMOD-start
define('EASYMOD_TABLE', $table_prefix.'easymod');
// EASYMOD-end

Parsing: language/lang_english/lang_admin.php - NOTE: this file is not being altered in any way

language/lang_english/lang_admin.php: Cannot open file for reading.
Current working dir: /home/sites/www.noviceguild.com/web/forum/admin/mods/EasyMod
:evil: :evil: :evil:
chmod 777 -grr it aint working

Posted: Fri Jan 31, 2003 7:38 am
by Noghri_ViR
Hey Nuttzy99, is the chmod security hole still there? (yea I didn't want to go through all the pages :( )

Posted: Fri Jan 31, 2003 5:39 pm
by morpheus2matrix
@ Novice_Gamer : have you the file language/lang_english/lang_admin.php upload onto your ftp server ?

Posted: Fri Jan 31, 2003 8:18 pm
by Bozzy
I got the following error:
Finding: name="addbbcode18"
includes/constants.php: Could not find:
name="addbbcode18"


I have am using 2.0.3, and have not installed any bbcode mods. What's causing this?