EasyMod alpha2 0.0.7 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Fri Jan 31, 2003 8:36 pm

:?

strange thing : it try to search, in constants.php, a part of code which is in posting_body.tpl


I don't know how to solve this (you're not the first which have this problem :? )

Maybe we need to wait for the the version 0.0.8
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Novice_Gamer
Registered User
Posts: 101
Joined: Wed Oct 16, 2002 8:38 am
Location: noviceguild.com
Contact:

Post by Novice_Gamer » Fri Jan 31, 2003 11:35 pm

yea the file is on there english is da default/only language
can i have my ava privl back?
My Site ~Elite Gamer Guild ~

User avatar
Bozzy
Registered User
Posts: 110
Joined: Thu Aug 01, 2002 8:03 pm
Location: Columbia, MD
Contact:

Post by Bozzy » Fri Jan 31, 2003 11:37 pm

I got it installed by manually editing the codes it wanted in...give me a coke, lol

NetMapel
Registered User
Posts: 58
Joined: Tue Dec 25, 2001 11:19 pm
Contact:

Post by NetMapel » Sat Feb 01, 2003 3:38 am

Yup yup, keep us updated on when the Beta version will be out, because I'd download ASAP :D
Tremble before the power of Gaming Goddess !

PERFEQ Network - UNDER CONSTRUCTION
PERFEQ forums - UP FOR POSTING !

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Mon Feb 03, 2003 8:56 pm

FYI, I hope to release a 2.0.4 compatiable version very soon. It will not include any improvements over version 0.0.7 though. Once I get all my MODs 2.0.4 compatiable and slightly improved, then I will be returning to work on EM ;)

I have not worked on this project in a loooooong time! I had taken a several month break from anything phpbb related and was also sidetracked by creating CatDB for the new MODs DB. I still consider EasyMOD to be my pride and joy :D

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Mon Feb 03, 2003 9:48 pm

Thanks for the fix! Works like a charm and saved me a lot of time ;) Unfortunately both the included MODs need work before releasing them for 2.0.4. So I will make a note on the first post of this thread to pointing to this fix. Once I get Country Flags and Left/Right updated then I will do a new release of EM.

Thanks!!
-Nuttzy :cool:
netclectic wrote: Ok, i've been trying to get easymod to work on 2.0.4 and here's what i had to do to make it work...

in admin_mod_install.php
find
'L_COMPLETE' => $lang['EM_Complete'],

before, add
'S_ACTION' => append_sid('admin_mod_install.' . $phpEx),


in mod_index_body.tpl
find
admin_mod_install.php

replace with
{S_ACTION}


in mod_sql_body.tpl
find
admin_mod_install.php

replace with
{S_ACTION}
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Qallain
Registered User
Posts: 5
Joined: Mon Jan 13, 2003 10:53 pm

Post by Qallain » Thu Feb 13, 2003 9:31 am

Hi, I saw this error earlier, but didn't see an answer to it, so please forgive me if it does exist here, but I went through the install of the Easy Mod, and the script went fine. But when I go into my admin panel, and click on the link to Install Mod, I get
General Error
Couldn't obtain EasyMod information


Am I missing something in the install? Or do I need to put mods to install in a certain place for this to go?

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sat Feb 15, 2003 9:16 am

Well i have finally got to download EasyMod, but now i have got a problem!!!

I have uploaded it like i am meant to and well i am getting this error!!!

Code: Select all

Instructions
Allow EasyMod installer to complete. 
Scroll to the bottom of the page to verify installation was completed successfully 
Follow the instructions at the bottom of this page to fully complete installation 


Information
Database type     :: mysql
phpBB version     :: 2.0.4
EasyMod version   :: 0.0.7

Processing files

Warning: fopen("./post_process.bat", "w") - Permission denied in /home/htdocs/hosted/starwars/starwars.uklinux.net/admin/mods/EasyMod/admin_mod_functions.php on line 347
ABORT: Could not open post_process files for reset and writing. 

Please help!!
Linda

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sat Feb 15, 2003 9:25 am

I have done the following as well, but i can still not get it to work!!

Nuttzy99 wrote: Thanks for the fix! Works like a charm and saved me a lot of time ;) Unfortunately both the included MODs need work before releasing them for 2.0.4. So I will make a note on the first post of this thread to pointing to this fix. Once I get Country Flags and Left/Right updated then I will do a new release of EM.

Thanks!!
-Nuttzy :cool:
netclectic wrote:Ok, i've been trying to get easymod to work on 2.0.4 and here's what i had to do to make it work...

in admin_mod_install.php
find
'L_COMPLETE' => $lang['EM_Complete'],

before, add
'S_ACTION' => append_sid('admin_mod_install.' . $phpEx),


in mod_index_body.tpl
find
admin_mod_install.php

replace with
{S_ACTION}


in mod_sql_body.tpl
find
admin_mod_install.php

replace with
{S_ACTION}



And i check the code for admin_mod_functions.php at around line 347 and this is what i have, is it right

Code: Select all

function open_command_file( $install_path)
{
	// windoze
	if (!$fwin = fopen ( $install_path . '/post_process.bat', 'w'))
	{
		return false ;
	}
	fclose( $fwin) ;

	// unix
	if (!$funix = fopen ( $install_path . '/post_process.sh', 'w'))
	{
		return false ;
	}
	fclose( $funix) ;
	chmod(  $install_path . '/post_process.sh', 0777) ;

	return true ;
}
Linda

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Feb 15, 2003 2:57 pm

There is no need to be posting the same problem across multiple threads. As for the problem...
The instructions wrote: 2) For Unix users, from admin you must <SECURITY HOLE>chmod -R 777 mods</SECURITY HOLE>. This will give full read/write/execute to all directories and files in the mods folder and subfolders.


...the -R does all subdirectories and I would suggest that you make sure all directories under "mods" are 777.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sat Feb 15, 2003 7:45 pm

This might sound stupid, but i do not understand what you mean by that!!! Please explain in lamans terms!!!!
Linda

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Sat Feb 15, 2003 10:44 pm

Luciouslinda wrote: This might sound stupid, but i do not understand what you mean by that!!! Please explain in lamans terms!!!!


chmod in 777 the file post_process.bat

edit : see here for more informations : http://www.phpbb.com/kb/article.php?article_id=22
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Feb 15, 2003 11:13 pm

Thanks m2m!! You are always very helpful ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sun Feb 16, 2003 8:32 am

This might sound silly to any of you lot, but the post_process.bat file, Hmmmm i can not seem to find that anywhere! It is not in the mods folder that i downloaded off of nuttzy.

Anyone help please!!
Linda

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Mon Feb 17, 2003 11:27 am

Nuttzy99 wrote: Thanks m2m!! You are always very helpful ;)


no problem :wink:

Luciouslinda wrote: This might sound silly to any of you lot, but the post_process.bat file, Hmmmm i can not seem to find that anywhere! It is not in the mods folder that i downloaded off of nuttzy.

Anyone help please!!


this file should be into your easyMod directory, with all the others files
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Locked

Return to “[2.0.x] MOD Writers Discussion”