[ABD]X users viewing forums

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

[ABD]X users viewing forums

Post by tommekemc » Tue Jun 24, 2008 4:16 pm

Modification Name: X users viewing forums
Author: tommeke_mc
Requirements: phpbb 3.0.1 or higher

Modification Description: Displays the number of users online in a forum on index.php
Modification Version: 0.1.2

Features:
  • lists the amount of users browsing one forum on index.php and viewforum.php
  • don't show if less then X users browse the forum (default to 0, controlled in ACP)
  • show usernames instead of how many people online.
  • show the mod to guests and bots or not (ACP)
  • don't show hidden users
  • hide bots in the username list and amount of users(ACP).
To do features:
  • Change the text color (ACP)
  • enable/disable (ACP)
Known bugs:
  • bug with SEO mod (doesn't show people when they're reading a topic) SOLLUTION
  • After installing the above mod, I got the following errors onthe top of the page..

    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3824: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3826: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3827: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3828: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
    Solve this in one of the following ways, if it doesn't work, try the next one:
    • because you saved your file in an incorrect way, it's ascii without BOM, if I recall correctly. Sometimes pages display 3 weird signs at the top left of the pages, this means you saved it with BOM. Open it in your online editor (if you have one) or download a programme that can save files without BOM.
    • You added a space/text before the "<?" or after the "?>", remove these spaces/text and everything will work again.
  • Report any bugs.
Screenshots: Click for full view Image

Demo URL: http://www.worldgaming.be/forum
Demo Username: tester
Demo Password: testing

Demo Notice: The account is only for testing, since guests can't see these things.
You're unable to post or read any messages.
If you want to be able to do more, please register.

Modification Download: here

Modification notice: Make sure you place the variables in the right place when you're using a costum theme.
if nothing is shown (no error and you don't notice any difference), everything is done correctly except for your style.

IMPORTANT NOTICE:
I'm stopping support for this mod untill the phpbb devs have added this feature:

http://www.phpbb.com/bugs/phpbb3/ticket ... t_id=50645

It's not good to make people add a whole bunch of code in their style, it messes up everything.
but the devs won't take action, they just say: 'not supported'...

For the automod: I haven't tested my mod yet with automod, I finished a V 0.1.3, it will work with minimal adeptions in a later release of phpbb, once they solved this issue.
Last edited by Sam on Sun May 23, 2010 10:28 am, edited 49 times in total.
Reason: Marked mod as abandoned, if the original poster wish to continue this, please PM any MOD team member to have it unlocked.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

enesbil
Registered User
Posts: 17
Joined: Wed Jun 04, 2008 8:37 pm

Re: [ALPHA]X users viewing forums

Post by enesbil » Tue Jun 24, 2008 5:40 pm

wow great idea. can't wait for that

wiseman1161980
Registered User
Posts: 111
Joined: Wed Oct 04, 2006 5:58 am
Location: Missouri, USA
Contact:

Re: [ALPHA]X users viewing forums

Post by wiseman1161980 » Wed Jun 25, 2008 12:44 am

Glad to see your gonna have a go at it. Best of Luck.

danielnguyen
Registered User
Posts: 287
Joined: Thu Jan 24, 2008 11:44 am
Location: Vietnam
Contact:

Re: [ALPHA]X users viewing forums

Post by danielnguyen » Wed Jun 25, 2008 5:34 am

You should make it shows on SubForums!
And if no one view forum, it will not show on index!
This is a great mod!
Thanks and I can wait more! :)
My forum, for just teen only with many happy things
Cộng Đồng Teen Online - Cộng Đồng Teen Việt - Teen Việt Nam
Hội Ngộ - Giao Lưu - Học Hỏi - Giải Trí - Kết Bạn
http://www.congdongteenonline.net

User avatar
alecrust
Registered User
Posts: 348
Joined: Thu Mar 27, 2008 11:24 am
Location: London, UK
Contact:

Re: [ALPHA]X users viewing forums

Post by alecrust » Wed Jun 25, 2008 7:15 am

Yeah, what would be very good is if it didn't show unless there were people viewing it.

tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [ALPHA]X users viewing forums

Post by tommekemc » Wed Jun 25, 2008 7:22 am

I'll need a ACP module for that, I have never created an ACP module, so if there are any devs with some experience, let me know :D
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

User avatar
alecrust
Registered User
Posts: 348
Joined: Thu Mar 27, 2008 11:24 am
Location: London, UK
Contact:

Re: [ALPHA]X users viewing forums

Post by alecrust » Wed Jun 25, 2008 7:59 am

I think it's a vital part of the MOD. You don't want to just show a visitor that there are no users viewing each forum :p

tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [ALPHA]X users viewing forums

Post by tommekemc » Wed Jun 25, 2008 8:16 am

that isn't hard to make, a simple line of code.
the hard part is to make this availeble in the ACP :p
because I've never messed around in the ACP :D
so I'm kind of checking how I have to make it...
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

User avatar
alecrust
Registered User
Posts: 348
Joined: Thu Mar 27, 2008 11:24 am
Location: London, UK
Contact:

Re: [ALPHA]X users viewing forums

Post by alecrust » Wed Jun 25, 2008 9:06 am

Oh so it can be turned on/off? I doubt there would be anyone that would want it to say "0 user viewing forum".

tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [ALPHA]X users viewing forums

Post by tommekemc » Wed Jun 25, 2008 9:43 am

I'dd like to give the user as many options as possible ;)
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

User avatar
^[GS]^
Registered User
Posts: 274
Joined: Sun Aug 06, 2006 10:59 pm
Location: Argentina
Contact:

Re: [ALPHA]X users viewing forums

Post by ^[GS]^ » Thu Jun 26, 2008 3:53 am

Really Nice ^^

sangho
Registered User
Posts: 4
Joined: Thu Jun 26, 2008 5:13 am

Re: [ALPHA]X users viewing forums

Post by sangho » Thu Jun 26, 2008 10:50 am

is this work on 3.0.1 and what does
I might need a little help with the ACP thing, not realy good at that :p
mean?

User avatar
alecrust
Registered User
Posts: 348
Joined: Thu Mar 27, 2008 11:24 am
Location: London, UK
Contact:

Re: [ALPHA]X users viewing forums

Post by alecrust » Thu Jun 26, 2008 11:25 am

Yes it works on 3.0.1 and he means he could do with some ACP help!

marian0810
Former Team Member
Posts: 3011
Joined: Mon May 21, 2007 9:17 pm
Location: The Netherlands
Name: Marian
Contact:

Re: [ALPHA]X users viewing forums

Post by marian0810 » Thu Jun 26, 2008 11:34 am

Could you make it so that it doesn't just show the number of viewers but the actual usernames?
You and me, time and space. You watch us run!

tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [ALPHA]X users viewing forums

Post by tommekemc » Thu Jun 26, 2008 4:10 pm

Could you make it so that it doesn't just show the number of viewers but the actual usernames?
added in the to do list ;)
Yes it works on 3.0.1 and he means he could do with some ACP help!
correct, but I'm getting into the ACP thing.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...

Locked

Return to “[3.0.x] Abandoned MODs”