[ABD]X users viewing forums

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

foxxy111 wrote:
tommekemc wrote:thanx to the help of PiroMaster, I found 2 bugs in the subforum system, solved both.
patching them into the installer.

EDIT:
V0.0.9 is online and ready for use!
please report any bugs.
Hi tommekemc,
we still have the same BUG :cry:
subforums did not counted in the main page :!:
well, they are counted, but the subforum users are displayed reading the main forum.
PiroMaster wrote:Mhhh... it is counted since this version for me now.
Have you cleaned the cache and refreshed your templates?
thnx a ton for helping and testing ^^
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

srr for the double post, but I just released v 0.1.0
in this release I fixed a bug that showed maximum 1 guest online and I updated the mysql fetching.
Please report any bugs!!!
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [BETA]X users viewing forums

Post by autinhyeu »

Wow, i have install this MOD in last month (version 0.0.2 :D)
today, i will reinstall this MOD with version 0.1.0 ;)
thx author
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible
User avatar
Sunka
Registered User
Posts: 566
Joined: Wed Mar 26, 2008 2:48 pm
Location: Croatia, Zvoneca

Re: [BETA]X users viewing forums

Post by Sunka »

Same error for me...Installed v0.1.0
When my subforum have more subforum, users do not show on index page
subforums did not counted in the main page
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [BETA]X users viewing forums

Post by madtay »

Nice mod thanks :)
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

Sunka wrote:Same error for me...Installed v0.1.0
When my subforum have more subforum, users do not show on index page
subforums did not counted in the main page
that's phpbb, it just counts 1 subforum it seems...
I'm still trying to come up with a way to count everything.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [BETA]X users viewing forums

Post by madtay »

is there any solution to sub-forum problem yet?

Just to explain the problem i experience:

If i have sub-forums set up in a particular forum... when someone views the main forum (not the sub-forums) they do not show up on the index page either?

example:

Forum 1
---Sub-Forum 1
---Sub-Forum 2

When i view Forum 1 i do not show on the index page. But if i view sub-forums i show on index page.


thanks for great work on this mod so far :D
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

that's strange, I'll explain my code:
first I look if a forum has got subforums, if it has I insert this code:

Code: Select all

if($viewers_array[$forum_viewers_digit]['session_forum_id']==$row['forum_id'] || $viewers_array[$forum_viewers_digit]['session_forum_id']==$subforum_id){
this one looks if the user is in the forum of in a subforum (1 deep because of the phpbb structure, I'm looking for a way to work around this) or in the forum itself.

I would not know why the users in the main forum aren't counted.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [BETA]X users viewing forums

Post by madtay »

ok thanks, am i the only one who experience this issue then? :?
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

I do not know, I'll have another look at it (I'll try to do that this weekend if I can find some time)
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [BETA]X users viewing forums

Post by madtay »

ok thanks :)

I tested a little bit more and found that if i only have:

Forum 1
---Sub-Forum 1

users viewing Forum 1 show up on idex then.. so its only if there is more than 1 sub-forum in the main forum this issue occurs..
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

I'll search for more clues :)
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
User avatar
MrMontana
Registered User
Posts: 86
Joined: Wed Sep 03, 2008 7:14 am

Re: [BETA]X users viewing forums

Post by MrMontana »

The only thing i dont understand is... why you need to show writing (viewing : 0) next to every forum.
I thought this mod show word (viewing : x) ONLY IF at least 1 person viewing that forum, so anotherwords, there is no point of showing (viewing : 0) if no1 viewing it.

Check this out...
Thats an example where the forum doesnt show (Viewing:x) UNLESS somebody does viewing the forum :

Image
madtay
Registered User
Posts: 328
Joined: Tue Jun 27, 2006 10:27 pm
Contact:

Re: [BETA]X users viewing forums

Post by madtay »

you can change setting in admin control panel if do not want to show (0 viewing) ;)
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

madtay wrote:you can change setting in admin control panel if do not want to show (0 viewing) ;)
indeed^^
I added the module to your ACP :)
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
Locked

Return to “[3.0.x] Abandoned MODs”