[ABD]X users viewing forums

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA]X users viewing forums

Post by Stitch625 »

Great mod. Just installed it. Haven't noticed any bugs yet but I did notice something in the template instructions. You need to do this part twice:
Find
Tip:This may be a partial find and not the whole line.

Code:Select All
<a class="forumlink" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a>
Add after
Tip:Add these lines on a new blank line after the preceding line(s) to find.

Code:Select All
<!-- IF S_USER_LOGGED_IN --><!-- IF not S_IS_BOT --><!-- IF forumrow.FORUM_VIEWERS_SHOW --> <b>(<!-- IF forumrow.FORUM_VIEWERS_NUMBERS_SHOW -->{forumrow.FORUM_VIEWERS} viewing<!-- ENDIF --><!-- IF forumrow.FORUM_VIEWERS_BOTH_SHOW --> : <!-- ENDIF --><!-- IF forumrow.FORUM_VIEWERS_NAMES_SHOW -->{forumrow.FORUM_VIEWERS_WHO}<!-- IF forumrow.FORUM_VIEWERS_GUESTS_VIEWING --> and {forumrow.FORUM_VIEWERS_GUESTS} guest<!-- IF forumrow.FORUM_VIEWERS_GUESTS_PLURAL -->s<!-- ENDIF --><!-- ENDIF --><!-- ENDIF -->)</b><!-- ENDIF --><!-- ENDIF --><!-- ENDIF -->
If you don't do this twice then the (X viewing) won't show up on every forum.

Very nice mod :D
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

you skipped the comment:
Open: styles/subsilver2/template/forumlist_body.html
Comments
the 2nd one!
Find
Tip:This may be a partial find and not the whole line.
it's the 2nd one that needs the code ;)
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
satandream
Registered User
Posts: 383
Joined: Thu Mar 06, 2008 12:47 pm

Re: [BETA]X users viewing forums

Post by satandream »

I dont see this work for me,i do think i did the edits on the files to edit.Did i do something wrong?

Users browsing this forum: baxter, Lindsay*, moalmoe and 0 guests but it doesnt show on index and its no subforums on that forum

EDIT:i didnt see the line second <a class="forumlink" href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a> ;)

Now its working
Last edited by satandream on Mon Jun 30, 2008 3:54 pm, edited 2 times in total.
User avatar
alecrust
Registered User
Posts: 348
Joined: Thu Mar 27, 2008 11:24 am
Location: London, UK
Contact:

Re: [BETA]X users viewing forums

Post by alecrust »

When will there be a new release?
sharathu7
Registered User
Posts: 173
Joined: Fri Jan 11, 2008 1:22 pm

Re: [BETA]X users viewing forums

Post by sharathu7 »

thanks but getting error saying...

please help.... :(

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 's.session_forum_id' in 'field list' [1054]

SQL

SELECT s.session_forum_id, s.session_user_id, u.group_id, u.username, u.user_colour FROM (phpbb_sessions s) LEFT JOIN phpbb_users u ON (u.user_id = s.session_user_id) WHERE s.session_time > 1214826031 AND s.session_forum_id != 0

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_display.php
LINE: 124
CALL: dbal_mysqli->sql_query()

FILE: index.php
LINE: 35
CALL: display_forums()
using phpbb3.0.0 with mysql and phpmyadmin
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA]X users viewing forums

Post by Stitch625 »

Oop's my bad. I didn't notice the comment. So I only need to apply the code to the second find?

Also I have noticed that if I am logged out as a guest I can't see the (X viewing). Aren't guests supposed to be able to see it?

Thanks
User avatar
ChriZathens
Registered User
Posts: 1477
Joined: Tue Apr 18, 2006 9:11 pm
Location: Athens, Greece
Name: Chris

Re: [BETA]X users viewing forums

Post by ChriZathens »

Nice job !
Works great ... ;)
My mods in MODDB:
Add Homepage link in header - Change user activity post limit - Post number in viewtopic
If you need support click on the support tab there and post your question.
Do not PM me - chances of viewing my PMs are way thinner than viewing the support question in the customization DB...
satandream
Registered User
Posts: 383
Joined: Thu Mar 06, 2008 12:47 pm

Re: [BETA]X users viewing forums

Post by satandream »

I cant get the users on each forum though,i see in who is online wich forum they are in but its doesnt show on index.I have set it to show usernames
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

sharathu7 wrote:thanks but getting error saying...

please help.... :(

Code: Select all

General Error
SQL ERROR [ mysqli ]

Unknown column 's.session_forum_id' in 'field list' [1054]

SQL

SELECT s.session_forum_id, s.session_user_id, u.group_id, u.username, u.user_colour FROM (phpbb_sessions s) LEFT JOIN phpbb_users u ON (u.user_id = s.session_user_id) WHERE s.session_time > 1214826031 AND s.session_forum_id != 0

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/functions_display.php
LINE: 124
CALL: dbal_mysqli->sql_query()

FILE: index.php
LINE: 35
CALL: display_forums()
using phpbb3.0.0 with mysql and phpmyadmin
try to purge the cache, if it doesn't work, you should update...
I cant get the users on each forum though,i see in who is online wich forum they are in but its doesnt show on index.I have set it to show usernames
that's strange, have you done your edits correctly?
does anything at all display?
Oop's my bad. I didn't notice the comment. So I only need to apply the code to the second find?

Also I have noticed that if I am logged out as a guest I can't see the (X viewing). Aren't guests supposed to be able to see it?

Thanks
check your ACP ;)
you can turn it on and off for guests.
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA]X users viewing forums

Post by Stitch625 »

Where in the ACP do you turn this mod on for guests? In the .mods module all I see is
Shows usernames only. Shows amount of users only. Shows usernames and the amount of users.
satandream
Registered User
Posts: 383
Joined: Thu Mar 06, 2008 12:47 pm

Re: [BETA]X users viewing forums

Post by satandream »

I think its some problems with my other mods i have installed,so say a friend of mine from denmark which is pretty good in php
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

Stitch625 wrote:Where in the ACP do you turn this mod on for guests? In the .mods module all I see is
Shows usernames only. Shows amount of users only. Shows usernames and the amount of users.
have you updated to version 0.0.2?
satandream wrote:I think its some problems with my other mods i have installed,so say a friend of mine from denmark which is pretty good in php
well, that's possible, but I do not think this affects the database fetching...
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA]X users viewing forums

Post by Stitch625 »

Ok I did the update instructions, purged the cache but it's still not showing for guests. I have the option to show to guest but it's still not showing.
tommekemc
Registered User
Posts: 457
Joined: Wed May 14, 2008 6:36 pm
Location: Belgium
Contact:

Re: [BETA]X users viewing forums

Post by tommekemc »

have you refreshed your template?
my sig
my projects

images deleted because of the 6kb (wtf?) rule...
User avatar
Stitch625
Registered User
Posts: 683
Joined: Wed Jun 20, 2007 3:38 pm
Location: Michigan
Contact:

Re: [BETA]X users viewing forums

Post by Stitch625 »

tommekemc wrote:have you refreshed your template?
Yes I have. ;)
Locked

Return to “[3.0.x] Abandoned MODs”