[ABD] 4S-BB-Control - v.1.0.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

~~~~~~~~~~~~~~~~~~~~
Release v.0.9.0

Image
~~~~~~~~~~~~~~~~~~~
> see first post 4 details
Current Mods | Mod Base | php(BB) programming | No help via PM

evina
Registered User
Posts: 110
Joined: Mon Nov 10, 2008 2:06 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by evina »

Dang, I never realized how complicated this was until now.

I think I may wait until some other users can confirm that it works well.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

4 shure this is not a little thingie, bcs. of the features ;)

Info: Only for phpbb 3.0.5 +
Current Mods | Mod Base | php(BB) programming | No help via PM

usenet2you
Registered User
Posts: 407
Joined: Sat Mar 22, 2008 7:31 pm
Location: The Netherlands

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by usenet2you »

Gonna try this very soon! =D

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

Fix [#1] for v.0.9.0

open

search.php

find

Code: Select all

                // 4seven 
                $forum_id = ($row['forum_id'] = request_var('f', 0)); 
                include($phpbb_root_path . 'includes/functions_hide_content.' . $phpEx);
                $row['post_text'] = preg_replace($search_pattern_hc, $pattern_replacement_hc, $target_source_hc);
                // 4seven   
replace with

Code: Select all

                // 4seven 
                $forum_id = ($row['forum_id'] = request_var('f', 0)); 
                include($phpbb_root_path . 'includes/functions_hide_content.' . $phpEx);
                if (isset($search_pattern_hc)){
                $row['post_text'] = preg_replace($search_pattern_hc, $pattern_replacement_hc, $target_source_hc);}
                else{ 
                $row['post_text'] = censor_text($row['post_text']);}
                // 4seven   
Current Mods | Mod Base | php(BB) programming | No help via PM

evina
Registered User
Posts: 110
Joined: Mon Nov 10, 2008 2:06 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by evina »

4_seven wrote:Fix [#1] for v.0.9.0

open

search.php

find

Code: Select all

                // 4seven 
                $forum_id = ($row['forum_id'] = request_var('f', 0)); 
                include($phpbb_root_path . 'includes/functions_hide_content.' . $phpEx);
                $row['post_text'] = preg_replace($search_pattern_hc, $pattern_replacement_hc, $target_source_hc);
                // 4seven    
replace with

Code: Select all

                // 4seven 
                $forum_id = ($row['forum_id'] = request_var('f', 0)); 
                include($phpbb_root_path . 'includes/functions_hide_content.' . $phpEx);
                if (isset($search_pattern_hc)){
                $row['post_text'] = preg_replace($search_pattern_hc, $pattern_replacement_hc, $target_source_hc);}
                else{ 
                $row['post_text'] = censor_text($row['post_text']);}
                // 4seven    
What is this fix for? Is it to fix a bug?

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

no, it's a fix to prevent an empty variable, if user have no restriction in search-mode on localhost. on live board it doesn't appear.
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

short notice:
after 2 weeks of testing no problems appear..
at this time @ 3 own live-boards..
Current Mods | Mod Base | php(BB) programming | No help via PM

usenet2you
Registered User
Posts: 407
Joined: Sat Mar 22, 2008 7:31 pm
Location: The Netherlands

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by usenet2you »

Nicee!! gonna try this tonight or tommorow! :D

usenet2you
Registered User
Posts: 407
Joined: Sat Mar 22, 2008 7:31 pm
Location: The Netherlands

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by usenet2you »

How can I block [youtube] from signature????? I did this;

Image

How do I need to set this thing up there? [youtube] must be usable in posting area, but I want if we use the [youtube] bbcode in signatures, it will give us a error. ;)

User avatar
DoYouSpeakWak
Registered User
Posts: 2310
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Contact:

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by DoYouSpeakWak »

This is really looking good. Thx for the last fix
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid services. 10+ years of experience with phpBB3 and as System Administrator.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

usenet2you wrote:How can I block [youtube] from signature????? I did this;

How do I need to set this thing up there? [youtube] must be usable in posting area, but I want if we use the [youtube] bbcode in signatures, it will give us a error. ;)
this is the right setting
http://www.loaditup.de/files/371692.jpg

to see this result
http://www.loaditup.de/files/371694.jpg
How do I need to set this thing up there? [youtube] must be usable in posting area
at this time i see a little hurry-up error: if you restrict ea. youtube only 4 signatures, the button in normal posting area doesnt appear (what is not right), but you can post it there (what is right). this effects field 3 - 16
- fix came this evening ;)
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

Fix [#2] for v.0.9.0

download latest version from download-site (see first post)

open *.zip

extract

Code: Select all

root/incudes/functions_hide_content_buttons.php
overwrite existing file

Code: Select all

includes/functions_hide_content_buttons.php
Current Mods | Mod Base | php(BB) programming | No help via PM

usenet2you
Registered User
Posts: 407
Joined: Sat Mar 22, 2008 7:31 pm
Location: The Netherlands

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by usenet2you »

replaced that file, took your settings but still it isnt working..

http://img19.imageshack.us/img19/8383/godver.png

Did the correct edits.. hmmz

gonna try it on a clean phpbb installation.

edit;

installed with autoMOD, did DIY instructions etc etc., on field 1 restrict youtube but wont work.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] 4S-BB-Control - v.0.9.0

Post by 4_seven »

you don't enter a group, for whom its allowed.
but (of course) you don't must enter a group. i've test it. ;)

other thing is, you must enter the bbcode as given.
if the Youtube is first letter uppercase, you must it enter as shown in info-menu

at this time with automod the install only 95% success, but in the future automod will supported.
if you have installed with automod, do all edits in the classic way..

on my test- and live-boards it works 100%

very important: clear all board- and browser-caches after install.

maybe you give me testwise guest admin-account, so i can check it...
or can another confirm this issue :?:
Current Mods | Mod Base | php(BB) programming | No help via PM

Locked

Return to “[3.0.x] Abandoned MODs”