[ABD] Buttons menu MOD 2.3.0 + subsilver2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

I got it working on my test forum. Went to copy the code for my live forum and it doesnt show up properly... any ideas? i feel like ive double checked everything.

live forum
http://www.battleproject.com/forum/

test forum
http://www.battleproject.com/testforum/

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by Jessica »

Trying refreshing styles on your live board
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

Tried muliple times :(

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by Jessica »

Post your test board's overall_header.html and your live board's. Maybe I can find what's wrong...(can't guarantee it though)
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

My code is 100% the same between my test forum header and my live forum. once my test forums header was the way i wanted it... i literally just copied and pasted the complete code it into my live forums header file.

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
<head>

<meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
<meta http-equiv="content-style-type" content="text/css" />
<meta http-equiv="content-language" content="{S_USER_LANG}" />
<meta http-equiv="imagetoolbar" content="no" />
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="keywords" content="" />
<meta name="description" content="" />
{META}
<title>{SITENAME} &bull; <!-- IF S_IN_MCP -->{L_MCP} &bull; <!-- ELSEIF S_IN_UCP -->{L_UCP} &bull; <!-- ENDIF -->{PAGE_TITLE}</title>

<!-- IF S_ENABLE_FEEDS -->
	<!-- IF S_ENABLE_FEEDS_OVERALL --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {SITENAME}" href="{U_FEED}" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_NEWS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_NEWS}" href="{U_FEED}?mode=news" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUMS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_ALL_FORUMS}" href="{U_FEED}?mode=forums" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_NEW}" href="{U_FEED}?mode=topics" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPICS_ACTIVE --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FEED_TOPICS_ACTIVE}" href="{U_FEED}?mode=topics_active" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_FORUM and S_FORUM_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_FORUM} - {FORUM_NAME}" href="{U_FEED}?f={S_FORUM_ID}" /><!-- ENDIF -->
	<!-- IF S_ENABLE_FEEDS_TOPIC and S_TOPIC_ID --><link rel="alternate" type="application/atom+xml" title="{L_FEED} - {L_TOPIC} - {TOPIC_TITLE}" href="{U_FEED}?f={S_FORUM_ID}&t={S_TOPIC_ID}" /><!-- ENDIF -->
<!-- ENDIF -->

<!--
	phpBB style name: prosilver Special Edition
	Based on style:   prosilver (this is the default phpBB3 style)
	Original author:  Tom Beddard ( http://www.subblue.com/ )
	Modified by:      phpBB Styles Team     
-->

<script type="text/javascript">
// <![CDATA[
	var jump_page = '{LA_JUMP_PAGE}:';
	var on_page = '{ON_PAGE}';
	var per_page = '{PER_PAGE}';
	var base_url = '{A_BASE_URL}';
	var style_cookie = 'phpBBstyle';
	var style_cookie_settings = '{A_COOKIE_SETTINGS}';
	var onload_functions = new Array();
	var onunload_functions = new Array();

	<!-- IF S_USER_PM_POPUP and S_NEW_PM -->
		var url = '{UA_POPUP_PM}';
		window.open(url.replace(/&/g, '&'), '_phpbbprivmsg', 'height=225,resizable=yes,scrollbars=yes, width=400');
	<!-- ENDIF -->

	/**
	* Find a member
	*/
	function find_username(url)
	{
		popup(url, 760, 570, '_usersearch');
		return false;
	}

	/**
	* New function for handling multiple calls to window.onload and window.unload by pentapenguin
	*/
	window.onload = function()
	{
		for (var i = 0; i < onload_functions.length; i++)
		{
			eval(onload_functions[i]);
		}
	};

	window.onunload = function()
	{
		for (var i = 0; i < onunload_functions.length; i++)
		{
			eval(onunload_functions[i]);
		}
	};

// ]]>
</script>
<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/styleswitcher.js"></script>
<script type="text/javascript" src="{T_SUPER_TEMPLATE_PATH}/forum_fn.js"></script>

<link href="{T_THEME_PATH}/print.css" rel="stylesheet" type="text/css" media="print" title="printonly" />
<link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />

<link href="{T_THEME_PATH}/normal.css" rel="stylesheet" type="text/css" title="A" />
<link href="{T_THEME_PATH}/medium.css" rel="alternate stylesheet" type="text/css" title="A+" />
<link href="{T_THEME_PATH}/large.css" rel="alternate stylesheet" type="text/css" title="A++" />

<!-- IF S_CONTENT_DIRECTION eq 'rtl' -->
	<link href="{T_THEME_PATH}/bidi.css" rel="stylesheet" type="text/css" media="screen, projection" />
<!-- ENDIF -->



<style type="text/css">
  #menu ul li a {
  	color: #{S_MENU_FONT_COLOR};
  }
  #menu ul li a:hover {    
    background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_bg_hover.gif') repeat-x;
    color: #{S_MENU_FONT_COLOR_HOVER};
    text-decoration: {S_MENU_DECORATION};  	
  }
  #menu ul ul li {
    background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_subbg.gif') repeat-x;
  }
  #menu ul ul li a:hover {    
    background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_subbg_hover.gif') repeat-x;
  }
</style>


<!-- INCLUDE mods/reimg_content.html -->
</head>

<body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">

<div id="wrap">
    <div class="border-left">
    <div class="border-right">
    <div class="border-top">
    <div class="border-top-left">
    <div class="border-top-right">
        <div class="inside" style="direction: {S_CONTENT_DIRECTION};">
        	<a id="top" name="top" accesskey="t"></a>
        	<div id="page-header">
        		<div class="headerbar">
        			<div class="inner"><span class="corners-top"><span></span></span>
        
        			    <div style="height: 190px;">
<div id="site-description">

        				<p class="skiplink"><a href="#start_here">{L_SKIP}</a></p>
        			</div>
        

    </div>

        


    <!-- IF .buttons -->
      <span class="corners-bottom" style="height:0px;"><span style="display: none;"></span></span></div>
    </div>
    <div id="menu" style="clear:both;margin-top:-3px;background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_bg.gif') repeat-x;">
    	<div class="inner">
    	<span class="menu_corner-left" style="background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_corner.gif') no-repeat;"></span>
    	<span class="menu_corner-right" style="background: url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_corner_right.gif') no-repeat;"></span>
    <!-- IF S_DISPLAY_SEARCH and S_MENU_SEARCH -->
    	<div id="top-search" style="<!-- IF S_MENU_ALIGN == 'right' -->float: left;<!-- ELSE -->float: right;<!-- ENDIF -->background: transparent url('{T_THEME_PATH}/images/menu/{S_MENU_COLOR}/menu_search.gif') no-repeat scroll 0 0;">
    		<form action="{U_SEARCH}" method="post" id="search">
    		<fieldset>
    			<input name="keywords" id="keywords" type="text" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="menu_search" value="<!-- IF SEARCH_WORDS-->{SEARCH_WORDS}<!-- ELSE -->{L_SEARCH_MINI}<!-- ENDIF -->" onclick="if(this.value=='{LA_SEARCH_MINI}')this.value='';" onblur="if(this.value=='')this.value='{LA_SEARCH_MINI}';" /> 
    			{S_SEARCH_HIDDEN_FIELDS}
    		</fieldset>
    		</form>
    	</div>
    <!-- ENDIF -->
    	<ul>
    	<!-- BEGIN buttons -->
    		<li style="float:{S_MENU_ALIGN};"<!-- IF .buttons.sub --> onmouseover="getElementsByTagName('ul')[0].style.display = 'block';" onmouseout="getElementsByTagName('ul')[0].style.display = 'none';"<!-- ENDIF -->>
          <a href="{buttons.URL}" title="{buttons.NAME}"<!-- IF buttons.EXTERNAL --> target="_blank"<!-- ENDIF --> style="font-weight:{S_MENU_WEIGHT};text-transform:{S_MENU_TEXT_TRANSFORM};">{buttons.NAME}</a>
          <!-- IF .buttons.sub -->
            <ul>
              <!-- BEGIN sub --><li><a href="{sub.URL}" title="{sub.NAME}"<!-- IF sub.EXTERNAL --> target="_blank"<!-- ENDIF --> style="font-weight:{S_MENU_WEIGHT};text-transform:{S_MENU_TEXT_TRANSFORM};">{sub.NAME}</a></li><!-- END sub -->
          	</ul>
        	<!-- ENDIF -->
        </li>
      <!-- END buttons -->
    	</ul>
    <!-- ENDIF -->







        			<span class="corners-bottom"><span></span></span></div>
        		</div>
        
        		<div class="navbar">
        			<div class="inner"><span class="corners-top"><span></span></span>
        
        			<ul class="linklist navlinks">
        				<li class="icon-home"><a href="{U_INDEX}" accesskey="h">{L_INDEX}</a> <!-- BEGIN navlinks --> <strong>&#8249;</strong> <a href="{navlinks.U_VIEW_FORUM}">{navlinks.FORUM_NAME}</a><!-- END navlinks --></li>
        
        				<li class="rightside"><a href="#" onclick="fontsizeup(); return false;" onkeypress="return fontsizeup(event);" class="fontsize" title="{L_CHANGE_FONT_SIZE}">{L_CHANGE_FONT_SIZE}</a></li>
        
        				<!-- IF U_EMAIL_TOPIC --><li class="rightside"><a href="{U_EMAIL_TOPIC}" title="{L_EMAIL_TOPIC}" class="sendemail">{L_EMAIL_TOPIC}</a></li><!-- ENDIF -->
        				<!-- IF U_EMAIL_PM --><li class="rightside"><a href="{U_EMAIL_PM}" title="{L_EMAIL_PM}" class="sendemail">{L_EMAIL_PM}</a></li><!-- ENDIF -->
        				<!-- IF U_PRINT_TOPIC --><li class="rightside"><a href="{U_PRINT_TOPIC}" title="{L_PRINT_TOPIC}" accesskey="p" class="print">{L_PRINT_TOPIC}</a></li><!-- ENDIF -->
        				<!-- IF U_PRINT_PM --><li class="rightside"><a href="{U_PRINT_PM}" title="{L_PRINT_PM}" accesskey="p" class="print">{L_PRINT_PM}</a></li><!-- ENDIF -->
        			</ul>
        
        			<!-- IF not S_IS_BOT and S_USER_LOGGED_IN -->
        			<ul class="linklist leftside">
        				<li class="icon-ucp">
							<a href="{U_PROFILE}" title="{L_PROFILE}" accesskey="e">{L_PROFILE}</a>
								<!-- IF S_DISPLAY_PM --> (<a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a>)<!-- ENDIF -->
							<!-- IF S_DISPLAY_SEARCH --> &bull;
							<a href="{U_SEARCH_SELF}">{L_SEARCH_SELF}</a>
							<!-- ENDIF -->
        					<!-- IF U_RESTORE_PERMISSIONS --> &bull;
        					<a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a>
        					<!-- ENDIF -->
        				</li>
        			</ul>
        			<!-- ENDIF -->
        
        			<ul class="linklist rightside">
<!-- IF S_DISPLAY_SEARCH --><li class="icon-search"><a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}">{L_SEARCH}</a></li><!-- ENDIF -->
        				<li class="icon-faq"><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
				<!-- IF .buttons and S_MENU_SEARCH --><li class="icon-search"><a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}">{L_SEARCH}</a></li><!-- ENDIF -->
        				<!-- IF not S_IS_BOT -->
        					<!-- IF S_DISPLAY_MEMBERLIST --><li class="icon-members"><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->
							<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED and not (S_SHOW_COPPA or S_REGISTRATION) --><li class="icon-register"><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
							<li class="icon-logout"><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>
        				<!-- ENDIF -->
        			</ul>
        
        			<span class="corners-bottom"><span></span></span></div>
        		</div>
        
        	</div>
        
        	<a name="start_here"></a>
        	<div id="page-body">
        		
				<!-- IF S_BOARD_DISABLED and S_USER_LOGGED_IN and (U_MCP or U_ACP) -->
				<div id="information" class="rules">
        			<div class="inner"><span class="corners-top"><span></span></span>
        				<strong>{L_INFORMATION}:</strong> {L_BOARD_DISABLED}
        			<span class="corners-bottom"><span></span></span></div>
        		</div>
        		<!-- ENDIF -->

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

Anyone? Wahh.

This is stopping me from making my website go live. I am using wordpress with wp-united and i plan on having the header have all the links to all the pages

vipaka
Registered User
Posts: 491
Joined: Sun Aug 28, 2011 7:25 pm
Contact:

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by vipaka »

To me it looks like you haven't assigned a background color for the theme (subsilver). You can do this from the ACP->Mods->Button Mod, just assign Subsilver to a specific color of button menu mod and it should show properly.

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

The theme is prosilver se. Not subsilver, i have the subsilver theme disabled.

i have the grey color selected for prosilver se.

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

I got it working. Somehow I missed uploading the .css file.

SwT-CarbonzZ
Registered User
Posts: 575
Joined: Tue Oct 12, 2010 7:17 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SwT-CarbonzZ »

EDIT: Solved myself

dnasman
Registered User
Posts: 1
Joined: Fri Feb 15, 2013 3:47 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by dnasman »

I installed this mod on my forum with subsilver2 style using automods . It works great, but i have a problem with the variable in button name. variable in button link works fine.
Button name
You can use plain text or language variable such as {L_PRIVATE_MESSAGES}
It says it can be used for language variable, but whenever i add a variable into it, nothing will show.
I'm sure it bugs, or am i missing something?

Please help me :cry:

Thnx

SnaggleToof
Registered User
Posts: 41
Joined: Sun Feb 03, 2013 6:13 am

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by SnaggleToof »

Im having a small problem with the mod. If i try switching positions of a button in the .MODS panel, they wont move (if i click, move up or move down... nothing happens)

User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by Jessica »

SnaggleToof wrote:Im having a small problem with the mod. If i try switching positions of a button in the .MODS panel, they wont move (if i click, move up or move down... nothing happens)
Yeah..I already reported this issue, but it hasn't been addressed at all :/
Jessica wrote:I think there's a bug with moving the buttons. I tried to move a button above another, but it's not budging. It's remaining in the same spot.....it moved before and then it suddenly stopped working (it was a new button I just created, was moving it up..)

EDIT: okay now it moves up. But there's definitely a problem because I had to click the up button several times

Also, when you go into a button that's a parent button, there's no way to return to the whole menu index. Can the menu at the top be clickable please?

Ex:
Menu » Forum

^
Not clickable, can't return to "Menu"
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
pilot35
Registered User
Posts: 48
Joined: Sat Jan 19, 2013 1:21 pm
Location: In the cockpit

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by pilot35 »

Hi there! The mod is going really fine for me. But I still have a question. How do I make the buttons active when at certain pages, like in this site? Thanks.

User avatar
Kamahl19
Registered User
Posts: 1598
Joined: Tue Nov 06, 2007 3:33 pm
Location: Slovakia
Name: Martin
Contact:

Re: [RC] Buttons menu MOD 2.3.0 + subsilver2

Post by Kamahl19 »

Hi,

I am sorry this MOD does not do that.

Locked

Return to “[3.0.x] Abandoned MODs”