[ABD] TinyMCE integration

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Thu Apr 16, 2009 6:34 am

yuukoweb wrote:Garak,
You're mod is really great and i already made it working, but can i ask if whenever i try to post the advance tiny mce editor will be used.
I mean this one
http://tinymce.moxiecode.com/examples/full.php

And whenever i try to make spaces between paragraphs, it ignores it and don't show the spaces.
It's not possible to get full advanced editor working, just because the editor must be bound to bbcode. So, for example, if bbcode doesn't provide an "hr" tag, it's impossible to get an "hr" tag in this editor.
About spaces, I think it's a matter of HTML: you can put any number of spaces, only one space is displayed.

yuukoweb
Registered User
Posts: 31
Joined: Thu Apr 09, 2009 10:13 am

Re: [DEV] TinyMCE integration

Post by yuukoweb » Thu Apr 16, 2009 9:44 am

Ok don't worry about that i already edited the buttons that will show ^^.
Anyways i have another question, whenever i try to use the "link" of tinyMCE and posted the work with the "link", it is not linked. It shows [url = "blablabla"]My text{/url] .
What do you think is the problem?

Edit: Ok i solved that problem.

But my problem now is the smilies..... I can post images using the image button in the tiny mce but when i tried to add the smilies it doesn't showed up. It just show [img]URLofSmilies[/img], i called the plugin correctly in the editor_plugin.js.

Dragonsoul7
Registered User
Posts: 52
Joined: Mon Jan 05, 2009 12:06 pm

Re: [DEV] TinyMCE integration

Post by Dragonsoul7 » Mon Apr 20, 2009 4:39 pm

It works nice until the posting, when I post there are a bunch of problems. If i don't ad any space between two smiles it just displays the code of the smile, when I paste a text from word its displayd how it should but in the post is this:

Code: Select all

<!--[if gte mso 9]><xml>
<w:WordDocument>
<w:View>Normal</w:View>
<w:HyphenationZone>21</w:HyphenationZone>
<w:PunctuationKerning />
<w:ValidateAgainstSchemas />....
mso-pagination:widow-orphan;
mso-hansi-theme-font:minor-latin;}
</style>
<![endif]-->
Is the problem in the coding in editor_plugin.js

And can we expect this integrate in the new version of phpbb ?

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] TinyMCE integration

Post by Galaxy21 » Fri Jun 05, 2009 5:17 pm

Hey Garak, are you still working on this? Are you going to create a phpBB dialekt for TinyMCE or is this it?

User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Sat Jun 06, 2009 8:06 am

Galaxy21 wrote:Hey Garak, are you still working on this? Are you going to create a phpBB dialekt for TinyMCE or is this it?
I'm not actively working on any phpBB project now, but I would like to keep all stuff up to date.
I don't see a need for a specific dialect. Do you?

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] TinyMCE integration

Post by Galaxy21 » Tue Jun 09, 2009 12:06 am

I did some testing again and also created a phpBB dialect (which is not necessary, but I felt like doing it ;))
However, I also ran into some problems - especially with lists. Single lists work fine, but multiple (cascade) lists create problems. Something like this doesn't work properly:
  1. Main Item
    1. Sub Item A
    2. Sub Item B
  2. Secondary Item
    1. Sub Item C
    2. Sun Item D
...which looks like this in BBCode:

Code: Select all

[list=I][*]Main Item[list=1][*]Sub Item A
[*]Sub Item B[/list]
[*]Secondary Item
[list=1][*]Sub Item C
[*]Sun Item D[/list][/list]
For some reason TinyMCE always creates an extra (empty) list item at the beginning and then has problems with some extra <li> tags. It's kinda weird and until now I was unable to figure out what the problem is.

I added some lines to support the roman list type. Within the // HTML -> BBCode in phpBB dialect function:

Code: Select all

rep(/<ol style="list-style-type: upper-roman;">(.*?)<\/ol>/gi,"[list=I]\n$1[/list]");
And withing the // BBCode -> HTML from phpBB dialect function:

Code: Select all

rep(/\[list=I\](.*?)\[\/list\]/gi, "<ol style=\"list-style-type: upper-roman;\"><li>$1</li></ol>");
If you have the time, could you have a look at that problem? Thank you.

IOMena
Registered User
Posts: 1
Joined: Mon Jun 08, 2009 9:50 pm

Re: [DEV] TinyMCE integration

Post by IOMena » Tue Jun 09, 2009 2:34 am

It's not working for me too. hmm :(

User avatar
Neuropass
Registered User
Posts: 1154
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [DEV] TinyMCE integration

Post by Neuropass » Wed Aug 26, 2009 1:41 pm

Please guy a bit of help. How do you integrate the smiles and bbcode? otherwise this mod is useless...

User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Wed Aug 26, 2009 1:51 pm

Neuropass wrote:Please guy a bit of help. How do you integrate the smiles and bbcode? otherwise this mod is useless...
I don't understand your question.
Can you explain?

User avatar
Neuropass
Registered User
Posts: 1154
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [DEV] TinyMCE integration

Post by Neuropass » Thu Aug 27, 2009 2:13 am

this is the problem. all my old bbcodes smiles and font color etc are still there and they are not working.


http://tinypic.com/r/s1i4bt/3

How do i fix it?

User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Thu Aug 27, 2009 7:05 am

Neuropass wrote:this is the problem. all my old bbcodes smiles and font color etc are still there and they are not working.


http://tinypic.com/r/s1i4bt/3

How do i fix it?
As stated in the last point of main message: "The support for bbcode is limited to standard. If you use custom bbcodes, you must adapt js code in plugin"

User avatar
Neuropass
Registered User
Posts: 1154
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [DEV] TinyMCE integration

Post by Neuropass » Thu Aug 27, 2009 10:38 am

that's not really helping much. could you provide an example of the edit that you need to do please?

But what about the smiles , colors and bbcode that i still have there? how should i remove them?

User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Thu Aug 27, 2009 2:47 pm

Neuropass wrote:that's not really helping much. could you provide an example of the edit that you need to do please?

But what about the smiles , colors and bbcode that i still have there? how should i remove them?
See main message, point 3. You must edit editor_plugin.js file, adding appropriate lines. It's no so difficult, if you understand javascript (not advanced javascript is required and code is commented).
Example: to add emoticons, copy and adapt lines like these ones:

Code: Select all

rep(/<img.*?src=\"images\/smilies\/icon_e_biggrin\.gif\".*?\/>/gi,":-D");

rep(/:D/gi, "<img src=\"./images/smilies/icon_e_biggrin.gif\" />");
Do the same for colors and bbcodes.

User avatar
Neuropass
Registered User
Posts: 1154
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [DEV] TinyMCE integration

Post by Neuropass » Thu Aug 27, 2009 9:05 pm

ok thanks i got that. but the problem is that not even the standard bbcode or smilies are showing.

as you can see in the picture in the editor there are only the fonts etc, but no bbcode or smilies.

The smilies that you see are not working and by the way that's my old posting body layout.


i'm using subsilver 2 based theme. Please help me to get it right.

User avatar
garak
Registered User
Posts: 57
Joined: Wed Jul 23, 2008 12:48 pm
Location: Rome, Italy
Name: Massimiliano Arione
Contact:

Re: [DEV] TinyMCE integration

Post by garak » Fri Aug 28, 2009 7:11 am

Neuropass wrote:ok thanks i got that. but the problem is that not even the standard bbcode or smilies are showing.

as you can see in the picture in the editor there are only the fonts etc, but no bbcode or smilies.

The smilies that you see are not working and by the way that's my old posting body layout.


i'm using subsilver 2 based theme. Please help me to get it right.
You have 2 options:
1 - get back to standard prosilver theme
2 - look into differences between standard prosilver theme and your theme, then adapt javascript code in point 5 (the one related to tinyMCE). It's just a matter of DOM.

Locked

Return to “[3.0.x] Abandoned MODs”

Who is online

Users browsing this forum: No registered users and 7 guests

cron