Page 2 of 3

Re: [RC] Basic Forum Icon Legend

Posted: Tue Aug 25, 2009 9:29 pm
by gsxr750
Thanks for the mod, loving it! :D Searched all over these forums for this.

Re: [RC] Basic Forum Icon Legend

Posted: Tue Sep 29, 2009 3:22 pm
by gjustinj
Hey,

If I want to add the following items to it, how can I do that?

1. New Hot Topic Post
2. No New Hot Topic Post
3. Stickie
4. Announcement

I tried to do this how I thought it would work, but it didn't. On the main page it shows no Image, but on all the other pages, it worked.. I purged both the cache, and style/template refresh. Still not working. Any help on this please?

Just to add, here is the site malfunctioning: www.grimarena.com/community

Here is my posts_legend_index.php

Code: Select all

	<div class="icon_legend"><h3>Icon Legend</h3></div>
	<table width="100%" cellspacing="0">
	<tr>
		<td align="{S_CONTENT_FLOW_BEGIN}" valign="top">
		<table cellspacing="3" cellpadding="0" border="0">
		<tr>
<td style="text-align: center;">{FOLDER_NEW_IMG}</td>
			<td class="gensmall">{L_NEW_POSTS}</td>
			<td>&nbsp;&nbsp;</td>
			<td style="text-align: center;">{FOLDER_IMG}</td>
			<td class="gensmall">{L_NO_NEW_POSTS}</td>
			<td>&nbsp;&nbsp;</td>
			<td style="text-align: center;">{FOLDER_ANNOUNCE_IMG}</td>
			<td class="gensmall">{L_ICON_ANNOUNCEMENT}</td>
		</tr>
		<tr>
			<td style="text-align: center;">{FOLDER_HOT_NEW_IMG}</td>
			<td class="gensmall">{L_NEW_POSTS_HOT}</td>
			<td>&nbsp;&nbsp;</td>
			<td style="text-align: center;">{FOLDER_HOT_IMG}</td>
			<td class="gensmall">{L_NO_NEW_POSTS_HOT}</td>
			<td>&nbsp;&nbsp;</td>
			<td style="text-align: center;">{FOLDER_STICKY_IMG}</td>
			<td class="gensmall">{L_ICON_STICKY}</td>
		</tr>
		<tr>
			<td style="text-align: center;">{FOLDER_LOCKED_NEW_IMG}</td>
			<td class="gensmall">{L_NEW_POSTS_LOCKED}</td>
			<td>&nbsp;&nbsp;</td>
			<td style="text-align: center;">{FOLDER_LOCKED_IMG}</td>
			<td class="gensmall">{L_NO_NEW_POSTS_LOCKED}</td>	



		</tr>
		</table>
		</td>
		<td align="{S_CONTENT_FLOW_END}"></td>
	</tr>
	</table>

Re: [RC] Basic Forum Icon Legend

Posted: Tue Sep 29, 2009 8:36 pm
by Spider M. Mann
It looks to me like you missed a file in your installation of the mod. The file you have posted is the posts_legend.html file, not the posts_legend_index.html as you have indicated. There are two files for the template folder.

At this point I would ask you to carefully re-read the install.xml file to make sure the installation is correct, and then if you are still running into problems, we'll go from there.

Re: [RC] Basic Forum Icon Legend

Posted: Tue Sep 29, 2009 9:15 pm
by Petesat
Thanks, easy mod and does what it says..

Pete

Re: [RC] Basic Forum Icon Legend

Posted: Tue Sep 29, 2009 9:18 pm
by gjustinj
Spider M. Mann wrote:It looks to me like you missed a file in your installation of the mod. The file you have posted is the posts_legend.html file, not the posts_legend_index.html as you have indicated. There are two files for the template folder.

At this point I would ask you to carefully re-read the install.xml file to make sure the installation is correct, and then if you are still running into problems, we'll go from there.
Actually I think I'm just blonde (and I am!)..

I just realized that on the board index, only 3 types of icons work anyhow... New, Old and Locked - which I have working, I just couldn't add anymore - but there is no need to. Cus I have the others loading fine on the Topic Index pages.

Btw, I posted that file on purpose, I have both of them in place. One works for Topics, and the other works for Index. I just was trying to use all the ones in the "Topics" on the Index, and it wasn't working - and obviously it shouldn't.

Ignore me today. Sorry for the confusion.

Re: [RC] Basic Forum Icon Legend

Posted: Tue Sep 29, 2009 9:23 pm
by Spider M. Mann
OK. Glad you got it sorted out. Let me know if you have any more questions.

Re: [RC] Basic Forum Icon Legend

Posted: Wed Oct 21, 2009 6:12 am
by VSE
Hi. I made a tiny tweak to this Mod to make it more like the original forum design...

This tweak will realign the Forum Permissions and bring back their title on the view topics page.

Before:
Image

After:
Image

Changes:

Open posts_legend.html

Find and Delete:

Code: Select all

<div class="icon_legend"><h3>Icon Legend</h3></div>
Find:

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="top">
Replace with:

Code: Select all

<td align="{S_CONTENT_FLOW_BEGIN}" valign="top"><h3>Icon Legend</h3>
Find:

Code: Select all

<td align="{S_CONTENT_FLOW_END}"><span class="gensmall"><!-- BEGIN rules -->{rules.RULE}<br /><!-- END rules --></span></td>
Replace with:

Code: Select all

<td align="{S_CONTENT_FLOW_END}" valign="top"><h3>{L_FORUM_PERMISSIONS}</h3><span class="gensmall"><!-- BEGIN rules -->{rules.RULE}<br /><!-- END rules --></span></td>

Re: [RC] Basic Forum Icon Legend

Posted: Sat Jan 30, 2010 4:33 am
by denisesballs
Love this mod. So simple, I can't for the life of me understand why this is not included as a default option. Just installed a new 3.0.6 board and the mod installed perfectly with Automod. I like VSE's suggestions above, but don't feel like breaking the Automod removability or editing the XML. Would be nice to make his changes in your code. Thanks again!

Re: [RC] Basic Forum Icon Legend

Posted: Mon Feb 01, 2010 9:19 pm
by K2
Just installed this mod today w/ VSE's tweaks. Nice job. Takes me back to my phpBB2 days :P

Re: [RC] Basic Forum Icon Legend

Posted: Tue Feb 02, 2010 5:58 pm
by VSE
denisesballs wrote:Love this mod. So simple, I can't for the life of me understand why this is not included as a default option. Just installed a new 3.0.6 board and the mod installed perfectly with Automod. I like VSE's suggestions above, but don't feel like breaking the Automod removability or editing the XML. Would be nice to make his changes in your code. Thanks again!
My tweaks should not affect Automod (for uninstalling) as you are changing the custom file that comes with this mod, not any of the core phpBB files. Besides, when Automod uninstalls, it does not remove custom files - it only reverts edits done to phpBB core files.

Re: [RC] Basic Forum Icon Legend

Posted: Tue Feb 02, 2010 6:20 pm
by denisesballs
VSE wrote:
denisesballs wrote:Love this mod. So simple, I can't for the life of me understand why this is not included as a default option. Just installed a new 3.0.6 board and the mod installed perfectly with Automod. I like VSE's suggestions above, but don't feel like breaking the Automod removability or editing the XML. Would be nice to make his changes in your code. Thanks again!
My tweaks should not affect Automod (for uninstalling) as you are changing the custom file that comes with this mod, not any of the core phpBB files. Besides, when Automod uninstalls, it does not remove custom files - it only reverts edits done to phpBB core files.
Ah, thanks for the clarification. I didn't actually look at it, I was just assuming. Think I will try it out later, thanks!

Re: [RC] Basic Forum Icon Legend

Posted: Thu Apr 08, 2010 9:31 pm
by JobKnockey
I think that this is the MOD I installed, although I cannot be sure.

Anyhow, I changed the HEX colours and shadow effects on my installation of phpbb in colours.css and common.css and suddenly half of the icons on the front page of my phpbb3 forum have disappeared. Strangely, when viewing sub-forums, the problem does not occur! I can see them all fine.

Any ideas?

I am using a heavily modified version of the revolution theme, http://www.ioimi.com.

Thanks for your help.

Re: [RC] Basic Forum Icon Legend

Posted: Thu May 13, 2010 7:24 pm
by rumensoft
Hi guys, can you help me, to change for BlueStrike :)

Edit: I did it! sorry for off topic

Re: [RC] Basic Forum Icon Legend

Posted: Sat May 22, 2010 7:20 pm
by John728
Thanks for the mod. I'm modifying it to include some more icons. Does anyone have the variable names for the icons with stars and the rest of the sticky icons? As of right now I'm just linking to the images in /styles/prosilver/imageset/ but it seems like putting the variables in would be better.

Re: [RC] Basic Forum Icon Legend

Posted: Sat May 22, 2010 8:25 pm
by zake black
Nice one thanks.

Can you tell me how to add the mine icons.. i.e. those the given logged in user has posted in.

Cheers

Andy