[ABD] Custom Title Mod 3.0.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

neo4u wrote:Are you saying that if I remove the old versuion and install this one I will not have this problem?

What database tables would I have to drop?
I dont have the old version anymore. You would have to reverse the install.xml instructions
neo4u
Registered User
Posts: 162
Joined: Sun May 25, 2008 2:25 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by neo4u »

I have the files i edited backed up so all I need to know is how i reverse this:

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

neo4u wrote:I have the files i edited backed up so all I need to know is how i reverse this:

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
You can leave them as they are
neo4u
Registered User
Posts: 162
Joined: Sun May 25, 2008 2:25 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by neo4u »

Thank's done the reverse and installed this seems to work perfectly ;)
WDPD
Registered User
Posts: 6
Joined: Thu Apr 02, 2009 6:38 am

Re: [Beta] Custom Title Mod 3.0.0

Post by WDPD »

Hi. I just installed with AutoMOD, following the instructions to the letter.

When I go to "permissions", I don't see any custom title options in any of the tabs.

I've uninstalled and re-installed twice now. I've added the custom title module and enabled it. I see "custom title settings" along the left-hand side in the ACP. But when I click the "permissions" button along the top, then groups > (select usergroup) > advanced, there are no options to enable custom titles.

Thanks in advance for your help here! I'd, of course, be happy to try whatever you told me to - that's how troubleshooting works :D
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

WDPD wrote:Hi. I just installed with AutoMOD, following the instructions to the letter.

When I go to "permissions", I don't see any custom title options in any of the tabs.

I've uninstalled and re-installed twice now. I've added the custom title module and enabled it. I see "custom title settings" along the left-hand side in the ACP. But when I click the "permissions" button along the top, then groups > (select usergroup) > advanced, there are no options to enable custom titles.

Thanks in advance for your help here! I'd, of course, be happy to try whatever you told me to - that's how troubleshooting works :D
Please ensure the following has been done

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
WDPD
Registered User
Posts: 6
Joined: Thu Apr 02, 2009 6:38 am

Re: [Beta] Custom Title Mod 3.0.0

Post by WDPD »

andy2295 wrote:
WDPD wrote:Hi. I just installed with AutoMOD, following the instructions to the letter.

When I go to "permissions", I don't see any custom title options in any of the tabs.

I've uninstalled and re-installed twice now. I've added the custom title module and enabled it. I see "custom title settings" along the left-hand side in the ACP. But when I click the "permissions" button along the top, then groups > (select usergroup) > advanced, there are no options to enable custom titles.

Thanks in advance for your help here! I'd, of course, be happy to try whatever you told me to - that's how troubleshooting works :D
Please ensure the following has been done

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
Does the AutoMOD script not take care of this?
Forgive my total stupidity :oops:
How would I be able to verify that this step had been done? (I know it has to do with SQL, but I have next to no clue about that - eager to learn, though! :D )
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

Use phpmyadmin and try to do the following first sql query from above post

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);

If it tells you it is a "duplicate entry" then you are assured that all of the queries from above are in the database
Trash-Master
Registered User
Posts: 20
Joined: Tue Nov 25, 2008 6:21 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by Trash-Master »

What is about the portal issue, I asked for a few sites before? ;)

Best Regards,
Trash-Master
phpBB Version: 3.0.4
Style: Prosilver, Prosilver SE
User avatar
PrattP
Registered User
Posts: 147
Joined: Sun Oct 21, 2007 6:26 am
Contact:

Re: [Beta] Custom Title Mod 3.0.0

Post by PrattP »

I've re-installed this, and it's all working perfectly. I originally had your problem WDPD, so maybe this applies to you too.

3 possible problems with your own personal installation:

Insert the original database entries, but also insert the same entry with a '1' prefix. eg.

This:

Code: Select all

INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
But also this;

Code: Select all

INSERT INTO phpbb_1acl_options (auth_option, is_global) VALUES ('u_title_edit', 1);
INSERT INTO phpbb_1acl_options (auth_option, is_global) VALUES ('u_title_ignore_reqs', 1);

INSERT INTO phpbb_1config (config_name, config_value) VALUES ('custom_title_days', 30);
INSERT INTO phpbb_1config (config_name, config_value) VALUES ('custom_title_posts', 10);
INSERT INTO phpbb_1config (config_name, config_value) VALUES ('custom_title_mode', 0);
INSERT INTO phpbb_1config (config_name, config_value) VALUES ('custom_title_maxlength', 45);

ALTER TABLE phpbb_1users ADD COLUMN user_custom_title VARCHAR(255) NOT NULL DEFAULT '' AFTER user_rank;
That's assuming those tables exist, and in my case they do, and helped fix my above problem.

2. Check edits incredibly carefully, as little mistakes can ruin the lot. Especially files with the same name etc.

3. Remember, as we all know, the 'Find' may be only the partial line. In this mod, there a few partial finds.



I think this mod really has no other issues. Gotta be ready for validation, yeah? :P

Thanks again for this andy, working brilliantly! :D
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

Yes i think i can tidy up a few bits and get it ready for validation now
User avatar
PrattP
Registered User
Posts: 147
Joined: Sun Oct 21, 2007 6:26 am
Contact:

Re: [Beta] Custom Title Mod 3.0.0

Post by PrattP »

Unfortunately, I've struck a hitch with this mod, when it comes to permissions.

So basically, my permissions are fine, and certain user groups are allowed to ignore the limits I have set on custom titles.

But that's the problem - these users, even after me editing their own permissions individually, still can't ignore the post requirements.

See, tracing the permission in fact tells me it should be working:

Image

But when I look back to the users permissions, even when I have changed them individually, I get this:

Image

That being the problem, and even not showing the changes I have made. The only way to allow them to be able to change it is to lower the Custom title settings, which I don't want to do, as then everyone can have a custom title. How can I fix this?

And myself, being an admin, can somehow ignore it, but groups and individual I choose and change can't, even though one part of permissions says they can, and anothers won't change and says they can't. :/
User avatar
PrattP
Registered User
Posts: 147
Joined: Sun Oct 21, 2007 6:26 am
Contact:

Re: [Beta] Custom Title Mod 3.0.0

Post by PrattP »

Help anyone? :)
andy2295
Registered User
Posts: 519
Joined: Tue Mar 25, 2008 4:36 pm

Re: [Beta] Custom Title Mod 3.0.0

Post by andy2295 »

PrattP wrote:Help anyone? :)
It is being looked at but struggling to repeat your problem on our test sites
User avatar
PrattP
Registered User
Posts: 147
Joined: Sun Oct 21, 2007 6:26 am
Contact:

Re: [Beta] Custom Title Mod 3.0.0

Post by PrattP »

Hmm ok thanks, but would you know what possible files may be causing the problem? Because I can check over those edits.
Locked

Return to “[3.0.x] Abandoned MODs”