[ABD] PhpBB3 Knowledge Base

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
ProtoGT
Registered User
Posts: 141
Joined: Thu May 21, 2009 6:34 pm

Re: [RC] PhpBB3 Knowledge Base

Post by ProtoGT » Wed Nov 11, 2009 9:27 am

I open the install.xml and the print in tiny..

Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris » Wed Nov 11, 2009 12:52 pm

ProtoGT wrote:I open the install.xml and the print in tiny..
Erm I don't understand what you are trying to say, please clarify.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.

Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris » Wed Nov 11, 2009 1:35 pm

tyabut wrote:Ah so you are saying that when I add a category and post an article in it, underneath each category on the category listing page where it says "Latest Articles" it should be the latest articles in all categories and not that specific category?

It just seems silly to have an article listed in another category's Latest Articles if the article isn't actually in that category.
This bug has now been fixed.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.

ProtoGT
Registered User
Posts: 141
Joined: Thu May 21, 2009 6:34 pm

Re: [RC] PhpBB3 Knowledge Base

Post by ProtoGT » Wed Nov 11, 2009 4:53 pm

Imladris wrote:
ProtoGT wrote:I open the install.xml and the print in tiny..
Erm I don't understand what you are trying to say, please clarify.
Heres a screenshot. IE8
Image
Last edited by ProtoGT on Wed Nov 11, 2009 11:42 pm, edited 1 time in total.

azzurri
Registered User
Posts: 909
Joined: Fri Jul 21, 2006 7:48 pm

Re: [RC] PhpBB3 Knowledge Base

Post by azzurri » Wed Nov 11, 2009 8:14 pm

azzurri wrote:There is a bug with the posting_body scrollbar when using IE. The scrollbar keeps shooting upwards making it impossible to write an article.
Most people still use IE and it's impossible to write an article with this bug. I advise you to fix it if you would have a real RC.

poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] PhpBB3 Knowledge Base

Post by poppertom69 » Wed Nov 11, 2009 8:35 pm

azzurri wrote:
azzurri wrote:There is a bug with the posting_body scrollbar when using IE. The scrollbar keeps shooting upwards making it impossible to write an article.
Most people still use IE and it's impossible to write an article with this bug. I advise you to fix it if you would have a real RC.
I cannot reproduce this bug!!
Do one thing everyday, that scares you!

azzurri
Registered User
Posts: 909
Joined: Fri Jul 21, 2006 7:48 pm

Re: [RC] PhpBB3 Knowledge Base

Post by azzurri » Wed Nov 11, 2009 9:58 pm

Really? And you are writing a lot of text until the scrollbar is showing? I am using IE7.

DJ Skitzo
Registered User
Posts: 596
Joined: Sun Aug 12, 2007 7:25 pm

Re: [RC] PhpBB3 Knowledge Base

Post by DJ Skitzo » Wed Nov 11, 2009 10:32 pm

azzurri wrote:Really? And you are writing a lot of text until the scrollbar is showing? I am using IE7.
Try updating your browser, you should be using IE8 as 7 is out of date.

ProtoGT
Registered User
Posts: 141
Joined: Thu May 21, 2009 6:34 pm

Re: [RC] PhpBB3 Knowledge Base

Post by ProtoGT » Wed Nov 11, 2009 10:39 pm

Got it installed after opening the XML in firefox. Looks like a great system, this will be replacing the tutorial section of my site. Thanks!

Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris » Wed Nov 11, 2009 11:12 pm

DJ Skitzo wrote:
azzurri wrote:Really? And you are writing a lot of text until the scrollbar is showing? I am using IE7.
Try updating your browser, you should be using IE8 as 7 is out of date.
Yes he should, but we want this mod to work on IE7 aswell as IE8... unfortunately I only have a mac and I'm not able to bugtest it in IE7... besides we need someone with IE knowledge to help us out here... I need more specific info as well.. is it only on the post/edit article page? What exactly happens? What version of KB? Does IE tell you of any Javascript errors on the page?
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.

ProtoGT
Registered User
Posts: 141
Joined: Thu May 21, 2009 6:34 pm

Re: [RC] PhpBB3 Knowledge Base

Post by ProtoGT » Wed Nov 11, 2009 11:25 pm

The MCP options, edit, delete, and report icons aren't visible on my forum.

Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris » Thu Nov 12, 2009 11:11 am

ProtoGT wrote:The MCP options, edit, delete, and report icons aren't visible on my forum.
Are you sure you have set moderator permissions in ACP under Permissions -> Global Moderator permissions -> Pick group -> Knowledge Base tab? I cannot reproduce the bug.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.

azzurri
Registered User
Posts: 909
Joined: Fri Jul 21, 2006 7:48 pm

Re: [RC] PhpBB3 Knowledge Base

Post by azzurri » Thu Nov 12, 2009 7:22 pm

Imladris wrote:
DJ Skitzo wrote:
azzurri wrote:Really? And you are writing a lot of text until the scrollbar is showing? I am using IE7.
Try updating your browser, you should be using IE8 as 7 is out of date.
Yes he should, but we want this mod to work on IE7 aswell as IE8... unfortunately I only have a mac and I'm not able to bugtest it in IE7... besides we need someone with IE knowledge to help us out here... I need more specific info as well.. is it only on the post/edit article page? What exactly happens? What version of KB? Does IE tell you of any Javascript errors on the page?
I believe a lot of people still use IE7 so it would be a good idea to make it work with this browser. Of course I could update to IE8 but the fact is that I dislike IE8 (I downgraded back to IE7) and don't want to use it if I really don't have to. So far I found no reason to update to IE8.

ProtoGT
Registered User
Posts: 141
Joined: Thu May 21, 2009 6:34 pm

Re: [RC] PhpBB3 Knowledge Base

Post by ProtoGT » Thu Nov 12, 2009 8:47 pm

Imladris wrote:
ProtoGT wrote:The MCP options, edit, delete, and report icons aren't visible on my forum.
Are you sure you have set moderator permissions in ACP under Permissions -> Global Moderator permissions -> Pick group -> Knowledge Base tab? I cannot reproduce the bug.
That's the only part I missed. May want to add it into the install.xml

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [RC] PhpBB3 Knowledge Base

Post by MydnyteSyn » Fri Nov 13, 2009 7:11 pm

I really like this mod, but I've run into just a couple of issues (with the newest release candidate). I've included screenshots.

First, I am getting an SQL error while I was trying to delete a couple of test articles. The error reads:
SQL ERROR [ mysqli ]

Out of range value adjusted for column 'cat_articles' at row 1 [1264]

SQL

UPDATE phpbb_article_cats SET cat_articles = cat_articles - 1 WHERE cat_id = 1

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/functions_kb.php
LINE: 1276
CALL: dbal_mysqli->sql_query()

FILE: includes/kb.php
LINE: 1755
CALL: article_delete()

FILE: includes/kb.php
LINE: 105
CALL: knowledge_base->article_posting()

FILE: kb.php
LINE: 111
CALL: knowledge_base->knowledge_base()
Though the error does come up whenever deleting an article, the article does delete.

Next: While setting the group permissions, I noticed that this mod has funkified the headings of the other areas in which group permissions can be set. View this Screenshot to see what it's done.

Post Bot Plugin: After an article has been submitted and the post bot plugin posts the announcement in the forum it's suppose to, the board index does not show that there is a new post. Screenshot of board index.

Article Deletion: After removing an article from the knowledge base, the latest articles still shows the titles of the deleted articles. Screenshot

Though there are two articles in the knowledge base, the KB index page does not indicate there are any articles at all. Screenshot

And finally, while adding a new article, a new SQL error has cropped up.
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE user_id = 2' at line 1 [1064]

SQL

UPDATE phpbb_users SET user_lastpost_time = 1258139066, user_posts = user_posts + 1, user_words = user_words + WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 2424
CALL: dbal_mysqli->sql_query()

FILE: includes/kb_plugins/kb_forum_bot.php
LINE: 253
CALL: submit_post()

FILE: includes/functions_plugins_kb.php
LINE: 796
CALL: post_new_article()

FILE: includes/functions_kb.php
LINE: 594
CALL: on_posting()

FILE: includes/kb.php
LINE: 2148
CALL: article_submit()

FILE: includes/kb.php
LINE: 105
CALL: knowledge_base->article_posting()
I do have a feeling that the Word Count mod is the culprit contributing to the SQL errors, though I am not sure.

And -- If I access the Mod CP from the board index, I see the tab to moderate the KB. I was wondering, though, if the link to the Mod CP is also suppose to be accessible from the KB index page as well? Screenshot

Also, there is a file missing:
General Error
template->_tpl_load_file(): File ./styles/fae_forest/template/kb/mcp_kb_kb_main.html does not exist or is empty
Though I am not using prosilver, I have checked the styles/prosilver/kb/ folder in the download and the mcp_kb_kb_main.html file isn't in there.

Locked

Return to “[3.0.x] Abandoned MODs”