[ABD] PhpBB3 Knowledge Base

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Nekstati
Registered User
Posts: 25
Joined: Tue Mar 17, 2009 11:08 pm

Re: [RC] PhpBB3 Knowledge Base

Post by Nekstati »

I just have installed KB manually on another clean forum. Nothing changes.

Urednik, KB works for me also, but PHP notices are displayed when DEBUG_EXTRA turned on. This is not fatal, but unpleasant.



UPD. I tried to make some edits to remove that PHP_notices. I'm not sure this is correct, but it works.

Code: Select all

----- includes\functions_plugins_kb.php
----- line 105
   global $template, $phpbb_root_path, $phpEx, $config;
----- replace
   global $template, $phpbb_root_path, $phpEx, $config, $user;
----- line155
   global $cache, $db, $phpbb_root_path, $phpEx, $table_prefix;
----- replace
   global $cache, $db, $phpbb_root_path, $phpEx, $table_prefix, $config;
      
      
------ includes\functions_kb.php
------ line 2046
      'KB_PAGE_NUMBER'   => on_page($article_count, $show_num, $ra),
------ replace
      'KB_PAGE_NUMBER'   => on_page($article_count, $show_num, $ra_start),
      
      
----- includes\kb.php
----- line 292
               $exists_check = explode(':', $exists);
----- replace
               $exists_check = explode(':', $exists[$n]);
      

----- language\en\mods\info_acp_kb.php
----- add
   'ACL_TYPE_U_KB_'               => 'Knowledge Base Permissions',
----- to remove { ACL_TYPE } on "Knowledge Base Roles" page
UPD2.

Code: Select all

----- includes\functions_kb.php
----- line 2024
		if($shown < $show_num && $shown >= ra_start)
----- replace
		if($shown < $show_num && $shown >= $ra_start)
Last edited by Nekstati on Mon Jan 25, 2010 7:42 pm, edited 2 times in total.
User avatar
urednik
Registered User
Posts: 105
Joined: Tue Jan 30, 2007 12:13 pm

Re: [RC] PhpBB3 Knowledge Base

Post by urednik »

Yes, and I have problems with registration, system shut me out with no reason...

I will wait to next version ...
bradpounder
Registered User
Posts: 1
Joined: Sun Jan 24, 2010 6:59 pm

Re: [RC] PhpBB3 Knowledge Base

Post by bradpounder »

I've just done a fresh install and I've gone over everything and as far as I can see everything is how it should be but i Keep getting the following errors:
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4199: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4201: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4202: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4203: Cannot modify header information - headers already sent by (output started at /language/en/common.php:1)
I've checked the obvious in the likes of overall_header, common.php and such but havent been able to find anything?

Any help would be appreciated.
User avatar
kopacko
Registered User
Posts: 254
Joined: Mon Feb 17, 2003 1:39 am

Re: [RC] PhpBB3 Knowledge Base

Post by kopacko »

Still getting the following error when deleting an article:

Code: Select all

SQL ERROR [ mysql4 ]

Out of range value for column 'cat_articles' at row 1 [1264]

SQL

UPDATE phpbb_article_cats SET cat_articles = cat_articles - 1 WHERE cat_id = 3

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/functions_kb.php
LINE: 1292
CALL: dbal_mysql->sql_query()

FILE: includes/kb.php
LINE: 1785
CALL: article_delete()

FILE: includes/kb.php
LINE: 105
CALL: knowledge_base->article_posting()

FILE: kb.php
LINE: 80
CALL: knowledge_base->knowledge_base()
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

I am aware of all your bug reports and I will look into them as soon as I have time to do it. Sorry for the waiting time but I'm rather busy these days.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

@Nekstati
Okay for all those guys who have reported notices, most of them should be gone by now in the SVN.

@vonhazey, @kopacko
I still need more info on the 'not updating article count' cases, as I cannot recreate those locally. Do they occur when you post without having to await approval, or only when you have to await approval. Also are we talking about articles that were created before the update to 1.0.0? Or freshly created articles? The article you are deleting, has it been approved?

@flcl_naota
Installation problems sounds really odd, even though I doubt Automod is the problem, try removing it and reinstall it manually.

@bradpounder
It seems you have made a mistake when editing language/en/common.php. You have probably added a linebreak at the very top of the file, try and see if this is correct, then remove it and reupload that file.

I am really sorry about the state of this update guys, it was rushed too much obviously. We'll try and be fast, yet still efficient with the next one. And we will release RC's of it before releasing it. Also we may push the versions one number, so that the next release will be the first stable version of KB, without adding any features.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: [RC] PhpBB3 Knowledge Base

Post by vonhazey »

Imladris wrote:@vonhazey, @kopacko
I still need more info on the 'not updating article count' cases, as I cannot recreate those locally. Do they occur when you post without having to await approval, or only when you have to await approval. Also are we talking about articles that were created before the update to 1.0.0? Or freshly created articles? The article you are deleting, has it been approved?
When I updated, i posted a new article yet it did not show up on the main page, it did ont have to be aproved or anything, I have not re-tried as im running the more stable 1.0.0
Image
User avatar
kopacko
Registered User
Posts: 254
Joined: Mon Feb 17, 2003 1:39 am

Re: [RC] PhpBB3 Knowledge Base

Post by kopacko »

My issue is resolved. I turned off the Forum Bot plugin. It seems to be the root of many of my KB issues.
sitwi
Registered User
Posts: 83
Joined: Fri Jul 21, 2006 10:53 am
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by sitwi »

Can I just thank Imladris; the work that has gone into this MOD surpasses just about any that I've seen. The video tutorials were above and beyond the call of duty!

I'm sure you'll iron out any remaining issues. Top, top work!
User avatar
kopacko
Registered User
Posts: 254
Joined: Mon Feb 17, 2003 1:39 am

Re: [RC] PhpBB3 Knowledge Base

Post by kopacko »

sitwi wrote:Can I just thank Imladris; the work that has gone into this MOD surpasses just about any that I've seen. The video tutorials were above and beyond the call of duty!

I'm sure you'll iron out any remaining issues. Top, top work!
+2
The-Lord
Registered User
Posts: 103
Joined: Thu Jan 31, 2008 12:13 pm

Re: [RC] PhpBB3 Knowledge Base

Post by The-Lord »

After updating the icons are not visible for the social bookmarkings.
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

The problems with icons and mysql errors over negative values have been fixed in the SVN now. Waiting for more bugs to occur before going 1.0.2. 8-)
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: [RC] PhpBB3 Knowledge Base

Post by vonhazey »

kopacko wrote:My issue is resolved. I turned off the Forum Bot plugin. It seems to be the root of many of my KB issues.
My issues also seemed to appear after I turned on the forum bot plugin........
Image
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

vonhazey wrote:
kopacko wrote:My issue is resolved. I turned off the Forum Bot plugin. It seems to be the root of many of my KB issues.
My issues also seemed to appear after I turned on the forum bot plugin........
Could you please describe the exact issue, and the action you do to summon the bug... then I'll try to debug it tomorrow.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
vonhazey
Registered User
Posts: 89
Joined: Wed Dec 02, 2009 2:43 pm

Re: [RC] PhpBB3 Knowledge Base

Post by vonhazey »

As I recall I updated to the new version and then activated the bot, then thats when the problems occured, when I posted a new article on the KB Categories page it does not show the latest article it still says No information regarding latest articles. and the article count still says zero and in the article stats plugin it says zero as well. if I de-activated the bot, they started to display again.
Image
Locked

Return to “[3.0.x] Abandoned MODs”