[ABD] PhpBB3 Knowledge Base

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

It all seems well now. other than permissions.. im sure i have set them right.. this is like the 6th time I have tested with this so you'd think i'd have it down to a master by now lol

Anyway.. adding categories but despite stats saying that their are 5 categorys none are displayed..

The Knowledge Base has no categories.??

cheers
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

Any hints on this?

could a fluffed/missed edit cause this issue? I have gone though and certain all is correct....

cheers

Andy
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

Sorry for the long delay, something must have crashed your permission settings... though I can't figure out what exactly does this. Please remove ALL traces of the KB from your board, then retry the installation.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

Imladris wrote:Sorry for the long delay, something must have crashed your permission settings... though I can't figure out what exactly does this. Please remove ALL traces of the KB from your board, then retry the installation.
Its only on a test board.. I delete it off and build a fresh one.. :) cheers
artikkk
Registered User
Posts: 379
Joined: Sun Jan 04, 2009 1:37 pm
Location: Roma

Re: [RC] PhpBB3 Knowledge Base

Post by artikkk »

How do i add number of user's articles in viewtopic?
sorry for my bad english
sorry for my bad english :S
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] PhpBB3 Knowledge Base

Post by poppertom69 »

This will be included in next release, just keeps slipping my mind
Do one thing everyday, that scares you!
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

poppertom69 wrote:This will be included in next release, just keeps slipping my mind
If I'm not wrong it is already in the 1.0.2 waiting to be validated in the MODDB... so it is getting there don't worry.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] PhpBB3 Knowledge Base

Post by poppertom69 »

Imladris - read the latest post on our forum
Do one thing everyday, that scares you!
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

Morning all,

Took the chance this morning to build a new test.. install went far better this time.. just having a small issue with permissions.. although it may be an image thing.. I have no option to delete articles..... but have just noticed that the add new article is text rather than image.. so could be that the X image is not being loaded??

Any ideas?

Edit: its not permission, the images are not displaying for add, comment, edit and delete?? imageset was refreshed twice?
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] PhpBB3 Knowledge Base

Post by poppertom69 »

did you use download or svn trunk code?
Do one thing everyday, that scares you!
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

poppertom69 wrote:did you use download or svn trunk code?
download..

Also seeing a couple of other template issues.. when adding comments template formating is way off.. it causes the article background and comment background to stretch off causing massive scroll areas?
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

zake black wrote:
poppertom69 wrote:did you use download or svn trunk code?
download..

Also seeing a couple of other template issues.. when adding comments template formating is way off.. it causes the article background and comment background to stretch off causing massive scroll areas?
Please supply screenshot or link to forum :)

And you did refresh your imageset after installing? Please check if the images are present in your imageset.
Last edited by Imladris on Tue Jun 15, 2010 10:15 am, edited 1 time in total.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
poppertom69
Registered User
Posts: 383
Joined: Wed Jun 06, 2007 7:44 am
Location: Bucks, UK
Name: Tom Martin

Re: [RC] PhpBB3 Knowledge Base

Post by poppertom69 »

did you follow the modx file correctly for the images. You need to refresh the theme as well and the templates.

Also could you post an image of this template problem.
Do one thing everyday, that scares you!
User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by zake black »

poppertom69 wrote:did you follow the modx file correctly for the images. You need to refresh the theme as well and the templates.

Also could you post an image of this template problem.
Looking further i have lost the imageset from the main forum also??

screenshot attached..

I have placed also samples of missing images. but you can also see the issue with the template.. this only happen on those articles that have been commented on

Image

imageset/theme/template all refreshed. cache purged..

Cheers :)
Imladris
Registered User
Posts: 190
Joined: Sat Oct 22, 2005 2:53 pm
Location: Copenhagen, Denmark
Name: Andreas Nexmann
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Imladris »

PhpBB3 KB Mod 1.0.2 has been released
Version 1.0.2 of the mod has been released, and is available for download here.

[21st June 2300 GMT+1] Our site might be down from a couple of hours as I'm updating the kb mod on our site. Meanwhile you can find a download mirror on Google Code.

Author notes:
The final version of 1.0.2 is out! Hopefully we have rid it from a lot of problems, and it should be very stable now. It also includes one large new feature, a subsilver2 template! The subsilver2 template isn't bugfree yet, but I hope you will enjoy it. I also updated the rating stars to look more neat and included new buttons, many thanks to Jesper Møller from phpBB2.dk.
  • Issues fixed:
  • Fixed small language bug
  • Fixed XHTML validation errors
  • Added username change support
  • Added user deletion support
  • Fixed article description not showing on view article
  • Fixed comments pagination
  • Added user articles on viewtopic
  • Fixed several cosmetic things
  • Added subsilver2
This version has been submitted to the moddb and is awaiting validation, enjoy :mrgreen:

IMPORTANT PLEASE READ
If you downloaded the files before this edit there is a bug in it, causing a PHP notice to appear when posting a new article. To fix it do the following:
Open: includes/kb.php
Find:

Code: Select all

$data['edit_type'] = check_edit_type($data, $edit_data, $update_message); 
Replace with:

Code: Select all

$data['edit_type'] = ($this->mode == 'edit') ? check_edit_type($data, $edit_data, $update_message) : array(); 
Last edited by Imladris on Tue Jun 22, 2010 5:49 pm, edited 1 time in total.
Best regards,
Andreas Nexmann aka. Imladris, Danish Phpbb Forum admin.
Locked

Return to “[3.0.x] Abandoned MODs”