[ABD] PhpBB3 Knowledge Base

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
licensinglinks
Registered User
Posts: 132
Joined: Tue Aug 12, 2008 7:32 pm
Location: United Kingdom

Re: [RC] PhpBB3 Knowledge Base

Post by licensinglinks »

Hi folks:

I posted some support questions over at http://kb.softphp.dk. Unfortunately I haven't had any replies yet. I don't think my questions are too difficult to answer - really easy stuff actually (probably)... can anyone help here? Here are my 3 support queries:

Change "LIVE FEED" text to just "FEED"
Change text appearance on categories
Can I move "This article has been viewed xx times" ?

Any help gratefully appreciated :)

User avatar
NowTech
Registered User
Posts: 36
Joined: Wed May 26, 2010 10:32 am
Location: New York City
Contact:

Latest Articles Block on my Portal

Post by NowTech »

How do I add the Latest Articles Block on my Portal.

I'm using: easyPortal 1.0.0
"There's no such thing as a stupid question, but they're the easiest to answer!" :mrgreen:

plasmino
Registered User
Posts: 261
Joined: Sat Jul 25, 2009 11:12 am

Re: [RC] PhpBB3 Knowledge Base

Post by plasmino »

:o I have errore in acp log error

Code: Select all

Google [Bot]       66.249.66.172      oggi, 20:22      Un errore generale ha avuto luogo: Errore Generale
» SQL ERROR [ mysql4 ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 379
CALL: dbal->sql_error()

FILE: includes/kb.php
LINE: 3635
CALL: dbal->sql_in_set()

FILE: includes/kb.php
LINE: 124
CALL: knowledge_base->view_tag()

FILE: kb.php
LINE: 80
CALL: knowledge_base->knowledge_base()

FILE: includes/kb_plugins/seo.php
LINE: 21
CALL: include('kb.php')
Error is only with google bot :o

User avatar
kevinaf
Registered User
Posts: 171
Joined: Tue Aug 12, 2008 9:45 am

Re: [RC] PhpBB3 Knowledge Base

Post by kevinaf »

Hello guy's,

I have a question about a acp module from a mod.
I would like to have itt so that a moderator kan access en control a module comming from the mod "phpbb knowledge base" in the acp of from te mcp panel.

But he may not been seen in the member group admin and see notthing else in the acp then only that tab (knowledge) and nothing more then that.

Is itt possible to do, and if how then?

See also: http://www.phpbb.com/community/viewtopi ... &t=2107655

User avatar
licensinglinks
Registered User
Posts: 132
Joined: Tue Aug 12, 2008 7:32 pm
Location: United Kingdom

Enable search engine optimization

Post by licensinglinks »

Hi,

I am trying to enable search engine optimization for my Knowledge Base.

The ACP says I must modify my .htaccess.

I note that there's lots of .htaccess files within my forum directories (16 of the buggers). Which one should I edit? Is it the one on the top-level directory. What about all the others?

Also how should I edit the file? The .htaccess on my top level directory reads like this:

Code: Select all

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#<IfModule mod_rewrite.c>
#RewriteEngine on
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#</IfModule>

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
RewriteEngine on

Rewriterule ^(.+)/(.+)/a([0-9]*).html					./includes/kb_plugins/seo.php?a=$3&%{QUERY_STRING} [L]
Rewriterule ^(.+)/(.+)/c([0-9]*).html					./includes/kb_plugins/seo.php?c=$3&%{QUERY_STRING} [L]
Rewriterule ^tag/(.+)/									./includes/kb_plugins/seo.php?t=$1&%{QUERY_STRING} [L]
Above it tells me to "Uncomment the statement below" to achieve what I want. Unfortunately I have no idea what statement it's refering to and what "uncommenting" actually means!

Any thoughts? :)

User avatar
urednik
Registered User
Posts: 105
Joined: Tue Jan 30, 2007 12:13 pm

Re: [RC] PhpBB3 Knowledge Base

Post by urednik »

Hello,

Is there anyone, who made modification th23 Autolinks ( http://www.phpbb.com/community/viewtopic.php?t=1103315) and KB mod to work together ?

panhead
Registered User
Posts: 688
Joined: Sat Dec 20, 2003 8:17 pm

Re: [RC] PhpBB3 Knowledge Base

Post by panhead »

Is this mod still not validated?

User avatar
licensinglinks
Registered User
Posts: 132
Joined: Tue Aug 12, 2008 7:32 pm
Location: United Kingdom

Re: [RC] PhpBB3 Knowledge Base

Post by licensinglinks »

Enable search engine optimization doesn't work:

If I enable it my knowledge base just stops working! All I get is "page not found" when I click on an article.

Is there a fix for this?

User avatar
licensinglinks
Registered User
Posts: 132
Joined: Tue Aug 12, 2008 7:32 pm
Location: United Kingdom

Re: [RC] PhpBB3 Knowledge Base

Post by licensinglinks »

licensinglinks wrote:Enable search engine optimization doesn't work:

If I enable it my knowledge base just stops working! All I get is "page not found" when I click on an article.

Is there a fix for this?
can anyone help at all please?? :(

User avatar
Neo
Registered User
Posts: 113
Joined: Tue Jul 07, 2009 5:02 am
Location: Holland
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by Neo »

Waiting for the mod to be validated!

Looks great keep up the good work! ;)

User avatar
kevinaf
Registered User
Posts: 171
Joined: Tue Aug 12, 2008 9:45 am

Re: [RC] PhpBB3 Knowledge Base

Post by kevinaf »

FDCP_NEO (NL) wrote:Waiting for the mod to be validated!

Looks great keep up the good work! ;)
Think so.

Is there a way to sort the articles by alphabetical order instead off order off pleacement?

User avatar
urednik
Registered User
Posts: 105
Joined: Tue Jan 30, 2007 12:13 pm

Re: [RC] PhpBB3 Knowledge Base

Post by urednik »

urednik wrote:Hello,

Is there anyone, who made modification th23 Autolinks ( http://www.phpbb.com/community/viewtopic.php?t=1103315) and KB mod to work together ?
I make progress with modification of file "includes/kb.php".
find:

Code: Select all

// Parse the message and subject
		$message = censor_text($article_data['article_text']);
Paste after:

Code: Select all

// th23 start - autolinks
	if ($config['th23_autolinks'] && $config['th23_autolinks_posts'] && ($config['th23_autolinks_forum'] == 1 || ($config['th23_autolinks_forum'] == 2 && strpos($config['th23_autolinks_forum_ids'], '-' . $forum_id . '-') !== false) || ($config['th23_autolinks_forum'] == 3 && strpos($config['th23_autolinks_forum_ids'], '-' . $forum_id . '-') === false)))
	{
		$message = th23_autolinks($message, $row['bbcode_uid']);		
	}
	// th23 end - autolinks
The only thing is, that after that there is confusion of th23 Autolinks and URL function of BBCode.
If word from autolinks is in link of URL, then there is mess.

Any suggestion ?

User avatar
therat
Registered User
Posts: 285
Joined: Sun Apr 07, 2002 6:06 pm
Contact:

Re: [RC] PhpBB3 Knowledge Base

Post by therat »

I have the bot set to post a topic when a new entry is made which works when I post the article. If someone else creates the article then once I have approved it the bot doesn't post anything.

Is there a way to get the bot to post after the submission has been approved.

User avatar
licensinglinks
Registered User
Posts: 132
Joined: Tue Aug 12, 2008 7:32 pm
Location: United Kingdom

Re: [RC] PhpBB3 Knowledge Base

Post by licensinglinks »

licensinglinks wrote:Enable search engine optimization doesn't work:

If I enable it my knowledge base just stops working! All I get is "page not found" when I click on an article.

Is there a fix for this?
Anyone??? Search engines aren't picking up on anything in my knowledge base

User avatar
urednik
Registered User
Posts: 105
Joined: Tue Jan 30, 2007 12:13 pm

Re: [RC] PhpBB3 Knowledge Base

Post by urednik »

licensinglinks wrote:
licensinglinks wrote:Enable search engine optimization doesn't work:

If I enable it my knowledge base just stops working! All I get is "page not found" when I click on an article.

Is there a fix for this?
Anyone??? Search engines aren't picking up on anything in my knowledge base
In my site it works - but KB search.
PHPBB search - not

Check:
- permissions
- installation ( Enable search engine optimization for the Knowledge Base, only for category, tag and article pages. It uses the Apache rewrite module, so please make sure you have edited your .htaccess )

Locked

Return to “[3.0.x] Abandoned MODs”