[ABD] Subforum Display Options 0.1.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

[ABD] Subforum Display Options 0.1.0

Post by Galaxy21 » Tue Jun 16, 2009 1:47 pm

Modification Name: Subforum Display Options
Author: Galaxy 21

Modification Description:: This mod allows you to choose how subforums are shown on your board. You can choose from default layout (all in a row), 2 cloumn layout or have each subforum shown on a new line (ACP Options).
Modification Version: 0.1.0

Screenshots:
prosilver
Image
Image
Image

SubSilver2
Image
Image
Image

Modification Download: http://www.galaxy21.net/phpbbmods/subfo ... _0.1.0.zip

Note: This mod should work with most prosilver based styles and with subsilver2 based styles, but I can only support prosilver and subsilver2. And of course it produces W3C compliant code. ;)
Last edited by Galaxy21 on Mon Nov 02, 2009 5:36 pm, edited 5 times in total.

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [BETA] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 1:55 pm

Very nice MOD ;)
Thanks!!!
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 3:30 pm

I had install this MOD, but it don't work :(
My board: http://www.autinhyeu.com/forum/
I had purge the cache, refresh template & theme :)
And 1 issue again: i try change

Code: Select all

Display of subforums:
from Default to 2 columns side by side but it's not changed
Best regards!!!
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by Galaxy21 » Tue Jun 16, 2009 3:38 pm

Very "colorful" board :)

First of all: After you've installed the mod, if everything went ok, you shouldn't see any change. Because the default setting keeps everything as it is.

Then, this is mainly a template mod with ACP option. Since you have a different template, the problem may lies there.
Is this a prosilver based style you use? The CSS for your style needs the 2 classes "column1" and "column2" for the 2 column layout to work. You should check your CSS files accordingly. Compare it with the original prosilver CSS.

Also, just to test function, test the "Each in new row" option.

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 3:46 pm

My styles designed base on Subsilver2 :)
I had try change value from "Default" to "Each in new row", but it don't changed :(. It's mean: options always stick at Default value...

Edit: i have go to phpMyadmin to change value config to "Each in new row", it's work with this option :|
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by Galaxy21 » Tue Jun 16, 2009 3:51 pm

For the subsilver2 style there are different instructions included. Check the contrib directory included in the package.
Also, 2 column layout only works for prosilver. That means, subsilver2 has only 2 options: default and new line.
autinhyeu wrote:I had try change value from "Default" to "Each in new row", but it don't changed :(. It's mean: options always stick at Default value...
You changed it in ACP and it keeps sticking at "default"?
Did you run the SQL?

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 3:59 pm

Galaxy21 wrote:For the subsilver2 style there are different instructions included. Check the contrib directory included in the package.
Also, 2 column layout only works for prosilver. That means, subsilver2 has only 2 options: default and new line.
Okie ;)
I will try work with styles based on Subsilver2...
Galaxy21 wrote:You changed it in ACP and it keeps sticking at "default"?
Yes, that right!!! :(
Galaxy21 wrote:Did you run the SQL?
Sure :oops:
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by Galaxy21 » Tue Jun 16, 2009 4:19 pm

autinhyeu wrote:
Galaxy21 wrote:Did you run the SQL?
Sure :oops:
Does this mean, you forgot that? ;)

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 4:41 pm

No :)
I found a problem in install file... this step:

Find:

Code: Select all

		<input type=\"text\" name=\"config[$key]\" id=\"$key\" value=\"$value\" maxlength=\"30\" />";
	}
Add after:

Code: Select all

	/**
	* Subforum Display Options
	*/
	function subforum_display_options($value, $key = '')
	{
		$radio_ary = array(SUBFORUM_DISPLAY_DEFAULT => 'DEFAULT', SUBFORUM_DISPLAY_CLOUMN => 'COLUMN', SUBFORUM_DISPLAY_NEWROW => 'NEWROW');

		return h_radio('config[subalbum_display]', $radio_ary, $value, $key);
	}
In the code add after, must be:
return h_radio('config[subforum_display]', $radio_ary, $value, $key);
instead:
return h_radio('config[subalbum_display]', $radio_ary, $value, $key);
Best regards!!!
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by Galaxy21 » Tue Jun 16, 2009 4:51 pm

Ooops... you are right. There is a problem there. :)
I fixed that on my test board but forgot to change it in the install file... :oops:

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [DEV] Subforum Display Options 0.0.1

Post by autinhyeu » Tue Jun 16, 2009 4:58 pm

Please try to this MOD work perfect with styles subsilver2 based...
Thanks!!!
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [DEV] Subforum Display Options 0.0.2

Post by Galaxy21 » Tue Jun 16, 2009 5:05 pm

I've fixed the little bug and updated the installer package.

Thanks for finding it, autinhyeu.

User avatar
Galaxy21
Registered User
Posts: 111
Joined: Mon Aug 13, 2007 12:03 am
Location: Dresden, Deutschland
Contact:

Re: [BETA] Subforum Display Options 0.1.0

Post by Galaxy21 » Thu Jun 18, 2009 9:41 pm

Updated 0.1.0 now with full subSilver2 support.

If you wich to update from 0.0.2 do as follows:

OPEN
styles/subsilver2/template/forumlist_body.html

FIND:

Code: Select all

					<p class="forumdesc"><strong>{forumrow.L_SUBFORUM_STR}</strong> 
					<!-- IF forumrow.S_SUBFORUM_DISPLAY === '2' --><br />
						<!-- BEGIN subforum -->
							<a href="{forumrow.subforum.U_SUBFORUM}" class="subforum <!-- IF forumrow.subforum.S_UNREAD is odd -->unread<!-- ELSE -->read<!-- ENDIF -->">{forumrow.subforum.SUBFORUM_NAME}</a><br />
						<!-- END subforum --></p>
					<!-- ELSE -->
						{forumrow.SUBFORUMS}</p>
					<!-- ENDIF -->
REPLACE WITH:

Code: Select all

					<p class="forumdesc"><strong>{forumrow.L_SUBFORUM_STR}</strong> 
					<!-- IF forumrow.S_SUBFORUM_DISPLAY === '1' --></p>
						<table width="100%" cellpadding="0" cellspacing="0">
						<!-- BEGIN subforum -->
							<!-- IF forumrow.subforum.S_ROW_COUNT is odd --><td width="50%"><!-- ELSE --><tr valign="top"><td width="50%"><!-- ENDIF --><a href="{forumrow.subforum.U_SUBFORUM}" class="subforum <!-- IF forumrow.subforum.S_UNREAD is odd -->unread<!-- ELSE -->read<!-- ENDIF -->">{forumrow.subforum.SUBFORUM_NAME}</a><!-- IF forumrow.subforum.S_ROW_COUNT is odd --></td></tr><!-- ELSE --></td><!-- ENDIF -->
						<!-- END subforum -->
						<!-- IF forumrow.subforum.S_ROW_COUNT is even --><td>&nbsp;</td></tr><!-- ENDIF -->
						</table>
					<!-- ELSEIF forumrow.S_SUBFORUM_DISPLAY === '2' --><br />
						<!-- BEGIN subforum -->
							&bull;&nbsp;<a href="{forumrow.subforum.U_SUBFORUM}" class="subforum <!-- IF forumrow.subforum.S_UNREAD is odd -->unread<!-- ELSE -->read<!-- ENDIF -->">{forumrow.subforum.SUBFORUM_NAME}</a><br />
						<!-- END subforum --></p>
					<!-- ELSE -->
						{forumrow.SUBFORUMS}</p>
					<!-- ENDIF -->

autinhyeu
Registered User
Posts: 685
Joined: Mon Apr 14, 2008 6:34 am
Location: Vietnamese
Contact:

Re: [BETA] Subforum Display Options 0.1.0

Post by autinhyeu » Fri Jun 19, 2009 8:59 am

Thanks for update ;)
Working great for me ^^
phpBB Community in Vietnamese: http://www.phpbbvn.com

Sorry, my English language is fine impossible

User avatar
Ahri89
Registered User
Posts: 516
Joined: Sat Apr 07, 2007 2:53 pm
Location: Spain
Contact:

Re: [BETA] Subforum Display Options 0.1.0

Post by Ahri89 » Sat Jul 04, 2009 5:17 am

Nice mod!! Thanks :D
MODs translated to Spanish: ACP Add User MOD, ACP Announcement Centre, Advertisement Management, Custom Profile Fields, Update Reminder, Flood time setting per forum, MOD Version Check, Posting template, Prune Log, Simple Trash Bin, TinyPic Plugin, User Reminder, View Profile, View your topics, and more...

Sorry for my bad english xD

Locked

Return to “[3.0.x] Abandoned MODs”