[ABD] Facebook Connect 0.3.4

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
lestat70
Registered User
Posts: 8
Joined: Sun Jul 26, 2009 5:45 pm

Re: [BETA] Facebook Connect

Post by lestat70 » Sun Jul 26, 2009 7:53 pm

Made is simple just added

Code: Select all

SetEnv PHP_VER 5
in the htaccess

thx :D

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect

Post by DeViAnThans3 » Sun Jul 26, 2009 7:54 pm

Is the MOD working properly now? :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

lestat70
Registered User
Posts: 8
Joined: Sun Jul 26, 2009 5:45 pm

Re: [BETA] Facebook Connect

Post by lestat70 » Sun Jul 26, 2009 7:58 pm

DeViAnThans3 wrote:Is the MOD working properly now? :)
no :roll: i have this error

Code: Select all

[phpBB Debug] PHP Notice: in file /fbconnect.php on line 102: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 105: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 107: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 268: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3248)

User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [BETA] Facebook Connect

Post by zake black » Sun Jul 26, 2009 8:01 pm

Hi, thanks again for the advice.

Just want to double check my understanding if thats ok..

line 110

Code: Select all

$sql_ary['user_website'] = (trim($user->data['user_website']) == "") ? $uinfo[0]['profile_url'] : $user->data['user_website'];
The social network buttons sql for facebook looks like this

Code: Select all

ALTER TABLE phpbb_users ADD user_facebook VARCHAR(255) CHARACTER SET utf8 COLLATE utf8_bin NOT NULL DEFAULT '';
I assume i change line 110 to the following?

Code: Select all

$sql_ary['user_facebook'] = (trim($user->data['user_facebook']) == "") ? $uinfo[0]['profile_url'] : $user->data['user_facebook'];
I may be way off? but from my understanding thats all thats required?

I will test this when i upgrade to the new version. i have another issue or fault. but i think thats another edit that i did wrong which is why the profile pic is not working but will look at that in more detial first :)

Cheers

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect

Post by DeViAnThans3 » Sun Jul 26, 2009 8:04 pm

lestat70 wrote:
DeViAnThans3 wrote:Is the MOD working properly now? :)
no :roll: i have this error

Code: Select all

[phpBB Debug] PHP Notice: in file /fbconnect.php on line 102: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 105: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 107: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 268: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3248)
It seems your error reporting level is pretty high..
Please try this, open /fbconnect.php
FIND

Code: Select all

ini_set('display_errors',1);
error_reporting(E_ALL);
REPLACE, WITH

Code: Select all

ini_set('display_errors',0);
Does this fix the issues? Can you log in using facebook, while all data is imported sufficiently?
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

lestat70
Registered User
Posts: 8
Joined: Sun Jul 26, 2009 5:45 pm

Re: [BETA] Facebook Connect

Post by lestat70 » Sun Jul 26, 2009 8:11 pm

not always even error :?

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect

Post by DeViAnThans3 » Sun Jul 26, 2009 8:18 pm

what error does it cause? :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

lestat70
Registered User
Posts: 8
Joined: Sun Jul 26, 2009 5:45 pm

Re: [BETA] Facebook Connect

Post by lestat70 » Sun Jul 26, 2009 8:19 pm

DeViAnThans3 wrote:what error does it cause? :)

Code: Select all

[phpBB Debug] PHP Notice: in file /fbconnect.php on line 102: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 105: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 107: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 268: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3248)
Here are the adress see ;)

http://www.kalliegraphique.fr/index.php
Last edited by lestat70 on Sun Jul 26, 2009 8:37 pm, edited 1 time in total.

User avatar
Matthew69
Registered User
Posts: 170
Joined: Sat Jul 28, 2007 4:37 pm
Contact:

Re: [BETA] Facebook Connect

Post by Matthew69 » Sun Jul 26, 2009 8:21 pm

Sadly enough I am still getting the avatar error.

I turned off the data pulling, and tried it. I got all the way through, but the login button refreshes like it would if I were logged into facebook, but just takes me to the home page, not logged in or anything.
Image

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect

Post by DeViAnThans3 » Sun Jul 26, 2009 8:46 pm

lestat70 wrote:
DeViAnThans3 wrote:what error does it cause? :)

Code: Select all

[phpBB Debug] PHP Notice: in file /fbconnect.php on line 102: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 105: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 107: Uninitialized string offset: 0
[phpBB Debug] PHP Notice: in file /fbconnect.php on line 268: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3248)
Here are the adress see ;)

http://www.kalliegraphique.fr/index.php
Actually, I just successfully registered at your site ... :? ??
And without seeing these errors ... when does the error occur?
Matthew69 wrote:Sadly enough I am still getting the avatar error.

I turned off the data pulling, and tried it. I got all the way through, but the login button refreshes like it would if I were logged into facebook, but just takes me to the home page, not logged in or anything.
I'm nut sure where to seek the error .. however, did you upload all included files? Including the xd_receiver.htm file? Did you set the connect URL right in the Facebook Application settings?
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

lestat70
Registered User
Posts: 8
Joined: Sun Jul 26, 2009 5:45 pm

Re: [BETA] Facebook Connect

Post by lestat70 » Sun Jul 26, 2009 8:51 pm

DeViAnThans3 wrote: Actually, I just successfully registered at your site ... :? ??
And without seeing these errors ... when does the error occur?
a saving but good if it works is cool thanks for all :D

User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [BETA] Facebook Connect

Post by zake black » Sun Jul 26, 2009 8:58 pm

lestat70 wrote:
DeViAnThans3 wrote: Actually, I just successfully registered at your site ... :? ??
And without seeing these errors ... when does the error occur?
a saving but good if it works is cool thanks for all :D
I thought i'd give a second opinion...

But fails for me also. but its only a language thing as my facebook profile is english
General Error
Language file ./language/en/mods/fbconnect.php couldn't be opened.

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect

Post by DeViAnThans3 » Sun Jul 26, 2009 9:02 pm

lestat70 wrote:
DeViAnThans3 wrote: Actually, I just successfully registered at your site ... :? ??
And without seeing these errors ... when does the error occur?
a saving but good if it works is cool thanks for all :D
Hey, if an error occurs, it, in my opinion, doesn't work, but as long as I can't reproduce the error, it is very hard to fix it .. ;)
If the problem still arises with you, you may want to provide me with more info so I can try to find a fix for it.

As a proof that I did registered succesfully, please check the profile of "hansvdp" at your forum. That's me .. everything seemed to work just fine, and I can also log in without problems, so at least it *seems* to work for new accounts :)
zake black wrote:
lestat70 wrote:
DeViAnThans3 wrote: Actually, I just successfully registered at your site ... :? ??
And without seeing these errors ... when does the error occur?
a saving but good if it works is cool thanks for all :D
I thought i'd give a second opinion...

But fails for me also. but its only a language thing as my facebook profile is english
General Error
Language file ./language/en/mods/fbconnect.php couldn't be opened.
Please check if you have uploaded the root/language/en/mods/fbconnect.php file to the language/en/mods/ folder ... it seems this didn't happen properly .. :) Let me know!
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

User avatar
zake black
Registered User
Posts: 694
Joined: Fri Jan 23, 2009 8:34 am
Location: Milton Keynes (UK)
Contact:

Re: [BETA] Facebook Connect

Post by zake black » Sun Jul 26, 2009 9:06 pm

Please check if you have uploaded the root/language/en/mods/fbconnect.php file to the language/en/mods/ folder ... it seems this didn't happen properly .. :) Let me know!
sorry i should have made that clear.. thats not my test board..

I was offering a 2nd test on "lestat70" board as you had signed up no problem, was just trying to assist :)

User avatar
adzyboy
Registered User
Posts: 215
Joined: Fri Jun 20, 2003 8:50 pm
Location: Burnley, England
Contact:

Re: [BETA] Facebook Connect

Post by adzyboy » Sun Jul 26, 2009 9:11 pm

Just curious, I've noticed in the fbconnect.php this line:

Code: Select all

        // custom profile fields, let's say there are none!
        $cp_data = array();
I take it this is for adding information to custom profile fields? If so, how would we go about doing it. I have Facebook as a CPF, and want to have "profile_url" in there.
I've also added "activities" and "website" to the info retrieved from facebook, added activities to interests ($uinfo[0]['interests'] . ' ' . $uinfo[0]['activities']) and obviously put website in the website field.

I don't have anything set in my fb profile for address, city etc.. but I do have my location in my hometown field, wondered if you might want to add that somehow.

Oh, and the avatar problem seems to be fine when linking to my account, I'll try my brothers (the one I got the error on) in the morning. Oh oh, the friends thing works too. Got my brother on my facebook, so when both mine and his fb are linked to accounts on the forum we're listed as friends on the forum :)

Sorry if I'm blagging on here, I'm kinda tired and trying to do all this at the same time heh

Locked

Return to “[3.0.x] Abandoned MODs”