[ABD] Facebook Connect 0.3.4

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
egranto
Registered User
Posts: 10
Joined: Wed Dec 07, 2005 5:25 pm
Location: Costa Rica
Contact:

Re: [BETA] Facebook Connect 0.3.0

Post by egranto »

Hi part of the changes on the overall header are this ones

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd" xmlns:fb="http://www.facebook.com/2008/fbml">
until i know xmlns are define on the html tag

i belive the correct one is

Code: Select all

<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
when i check in firefox nothing change but in safari and chrome my font was bigger actually on the portal page

also i notice that the MODx is forgeting something

Copy: root/styles/prosilver/template/fbconnect_body.html
To: styles/prosilver/template/fbconnect_body.html

is the last one

ucp_fbconnect_fbsettings.html is missing on the MODx i had to uploaded manually

Great mod

also i'll like to know how to sync the informantion i want the same value of the fb_id on my users table user_facebook in order to the social network links works for the users who reg or are using facebook
User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.0

Post by DeViAnThans3 »

edfungus wrote:
1) I have 5.2
2) I believe safe mode is on, and the send function is disabled

would safe mode be the reason? and like what other things should i find out about? :|
Probably safe mode may cause this problem indeed, when checking php.net, it says that all stream functions have limited functionality (mainly the owner UID has to be the same as the script when working with stream functions), and I guess this may cause the first error. All other errors you received are caused because the Facebook PHP library isn't functioning properly - which probably is caused by the safe mode restriction.
egranto wrote:Hi part of the changes on the overall header are this ones

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd" xmlns:fb="http://www.facebook.com/2008/fbml">
until i know xmlns are define on the html tag

i belive the correct one is

Code: Select all

<html xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://www.facebook.com/2008/fbml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
when i check in firefox nothing change but in safari and chrome my font was bigger actually on the portal page

also i notice that the MODx is forgeting something

Copy: root/styles/prosilver/template/fbconnect_body.html
To: styles/prosilver/template/fbconnect_body.html

is the last one

ucp_fbconnect_fbsettings.html is missing on the MODx i had to uploaded manually

Great mod

also i'll like to know how to sync the informantion i want the same value of the fb_id on my users table user_facebook in order to the social network links works for the users who reg or are using facebook
I'm just following the instructions from Facebook on this one, though thanks for noting! I'll fix it :)

About the sync .. I'm still working on a data mapping possibility, which may enable to do what you want simply from the ACP or a data map file :) Though, the time table for that still can be extended .. ;)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect
edfungus
Registered User
Posts: 14
Joined: Wed Aug 19, 2009 8:35 pm

Re: [BETA] Facebook Connect 0.3.0

Post by edfungus »

Just wondering, where would you turn off safe mode? Would it be in like myPhpadmin or would i have to contact my web hoster?
Encore204
Registered User
Posts: 314
Joined: Sun Feb 05, 2006 9:54 pm
Contact:

Re: [BETA] Facebook Connect 0.3.0

Post by Encore204 »

Hans, a question...
I will try to to add mod to subsilver II using the old instructions for 0.2.5.1
is there any chance of sucsess,or am i doomed to fail :D
plasmino
Registered User
Posts: 261
Joined: Sat Jul 25, 2009 11:12 am

Re: [BETA] Facebook Connect 0.3.0

Post by plasmino »

I upgrade from 0.2.5.1 to 0.3.0 without problems ..
you should check the differences of the old with the new one.
^ _ ^
good luck
chicochaleur29
Registered User
Posts: 50
Joined: Tue Jun 03, 2008 2:38 pm

Re: [BETA] Facebook Connect 0.3.0

Post by chicochaleur29 »

plasmino wrote:I upgrade from 0.2.5.1 to 0.3.0
How?
User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.0

Post by DeViAnThans3 »

edfungus wrote:Just wondering, where would you turn off safe mode? Would it be in like myPhpadmin or would i have to contact my web hoster?
Safe Mode has to be turned off in the "php.ini" file. Some webhosters allow their customers to modify this file themselves, but usually you must contact your host. Note that some hosting companies have a set policy which implies they will not turn off the Safe Mode for security reasons. Other hosting companies may have servers with and without safe mode, in this case you will probably be moved to a server without safe mode after contacting the host. So basically, just contact your host, and see what they say :)
Encore204 wrote:Hans, a question...
I will try to to add mod to subsilver II using the old instructions for 0.2.5.1
is there any chance of sucsess,or am i doomed to fail :D
You probably will be abled to do this, these notes may help (actually, with these notes I an get the subsilver instructions done in less than an hour once started .. if you rather let me do it, may be easier ;) ):
  • Note the new template file which was added in 0.3.0 - ucp_fbconnect_settings.html
  • Note that the "GET" form action in fbconnect_body.html became a "POST" action
  • Note the additional edit in overall_header.html, in the DOCTYPE
  • Note the additional "/{FBLANG}" on the places where the facebook connect button is added (login_body.html and index_body.html)
I think that's everything that changed style-wise since 0.2.5.1 .. let me know if you want me to do it ;) I'm going to get the translations fixed later this evening too so :)
chicochaleur29 wrote:
plasmino wrote:I upgrade from 0.2.5.1 to 0.3.0
How?
There are no upgrade instructions since nobody replied to my question a few pages back, and I guessed it would than be a waste of time :).
A quick "upgrade" guide though, without actually being a upgrade would be:
  • Do NOT forget to take file + database backups before proceeding with the next steps !!! It is always possible something goes wrong, and backups are NECESSARY in cases like these. :)
  • Uninstall the MOD (undo all changes you did with the MODX of 0.2.5.1), except do NOT delete the phpbb_fbids table.
  • Go to phpMyAdmin and run the following SQL on your phpbb_fbids table:

    Code: Select all

    ALTER TABLE `phpbb_fbids` ADD `datahash` TEXT NOT NULL;
    ALTER TABLE `phpbb_fbids` CHANGE `edit` `edit` BIGINT( 40 ) NOT NULL;
  • Install the MODX of 0.3.0, and update any files which are within the root/ folder of the MOD archive.
  • If you want to make sure the data of existing Facebook users at your forum is also synced, run the sync update script which is to be downloaded *here*. NOTE: This script empties all profile fields of existing Facebook users, even if the date in these fields isn't fetched from Facebook.
Important to note: The way data imports are done is going to change a lot. It is not recommended to install this MOD on live boards yet!!

Thanks for your continued support everyone :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect
Encore204
Registered User
Posts: 314
Joined: Sun Feb 05, 2006 9:54 pm
Contact:

Re: [BETA] Facebook Connect 0.3.0

Post by Encore204 »

DeViAnThans3 wrote:
You probably will be abled to do this, these notes may help (actually, with these notes I an get the subsilver instructions done in less than an hour once started .. if you rather let me do it, may be easier ;) ):
  • Note the new template file which was added in 0.3.0 - ucp_fbconnect_settings.html
  • Note that the "GET" form action in fbconnect_body.html became a "POST" action
  • Note the additional edit in overall_header.html, in the DOCTYPE
  • Note the additional "/{FBLANG}" on the places where the facebook connect button is added (login_body.html and index_body.html)
I think that's everything that changed style-wise since 0.2.5.1 .. let me know if you want me to do it ;) I'm going to get the translations fixed later this evening too so :)
Please Hans, if you can spare some time for the instructions :)
Most of the people are using subsilver II :mrgreen:

btw Hans, i am thinking of installing this mod on a live board, but will disable data synchronization as it seems it can cause a lot of trouble, and to be honest, it's not that important for us .
I know that this is not advised, but September is the most important month for us, and this would be a huge benefit for our community.
So,wish me luck :)
So wish me luck
User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.0

Post by DeViAnThans3 »

I'll get the instructions done later today (well, I hope I do :D).

IF you disable data importing as a whole at your live board .. well, on other parts, there isn't much that is going to change, so I think it will be fine to install it than, just handle it with care, and surely take back-ups and stuff. :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect
chicochaleur29
Registered User
Posts: 50
Joined: Tue Jun 03, 2008 2:38 pm

Re: [BETA] Facebook Connect 0.3.0

Post by chicochaleur29 »

DeViAnThans3 wrote: [*] Uninstall the MOD (undo all changes you did with the MODX of 0.2.5.1)
Can i have this version please? (0.2.5.1)
User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.0

Post by DeViAnThans3 »

chicochaleur29 wrote:
DeViAnThans3 wrote: [*] Uninstall the MOD (undo all changes you did with the MODX of 0.2.5.1)
Can i have this version please? (0.2.5.1)
Sure, download *here*. :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect
chicochaleur29
Registered User
Posts: 50
Joined: Tue Jun 03, 2008 2:38 pm

Re: [BETA] Facebook Connect 0.3.0

Post by chicochaleur29 »

thank you

How to delete this :

Code: Select all

INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_apikey', '', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_appsecret', '', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_usergroup', '2', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_friendimport', '1', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_notification', '1', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_avatartype', 'pic_square', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_autolang', '1', '0'
);
INSERT INTO `phpbb_config` ( `config_name` , `config_value` , `is_dynamic` )
VALUES (
'fbconnect_dataimport', '1', '0'
);
User avatar
chuckun
Registered User
Posts: 27
Joined: Wed Oct 12, 2005 9:13 pm
Contact:

Re: [BETA] Facebook Connect 0.3.0

Post by chuckun »

This mod is really coming along nicely!

I've sent a lot of interest to this thread from my webmaster blog, after having made a post about it.. ^_^

Anyway, I'm really pleased to see this is back in BETA and the sync process has been made.. This is a big step forward ^_^

I've no doubt that there will be an RC very soon? :D :mrgreen:

I really look forward to the full stable release of this mod! It'll be perfect for one of my forums! :D

Thanks a lot!
Jack
User avatar
rosdi
Registered User
Posts: 166
Joined: Wed May 14, 2008 10:26 am
Contact:

Re: [BETA] Facebook Connect 0.3.0

Post by rosdi »

I'm waiting for RC soon.
User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.0

Post by DeViAnThans3 »

@Chicochaleur29: Run the following SQL on your phpbb_config table:

Code: Select all

DELETE FROM phpbb_config WHERE config_name = 'fbconnect_avatartype';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_autolang';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_dataimport';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_apikey';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_appsecret';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_usergroup';
DELETE FROM phpbb_config WHERE config_name = 'fbconnect_friendimport';
This should do the trick :)
@Chuckun: Thanks a lot! :) Well, I'm not yet talking about RC, the data importing needs to be rewritten completely, but next to that, all major features are there. Some more enhancements and minor features should be added, and than it's ready to go RC .. but that can still take up several weeks to even one or more month(s).. depending on the amount of problems we come across ;)

@Rosdi: Well, as said, RC can still take a little time, but once it's there, I'm sure it can be a helpful MOD for many forums ;)

TY all for your support.. Yesterday I didn't find the time anymore to fix subSilver instructions, nor will I today (normally), but tomorrow I have a day off.
Also some good news people: my development PC has returned, and so far, it is working quite smoothly! :) If it keeps working without breaking again, this will speed up the development of this MOD considerably, since I can work on it locally than, and no longer dependant on FTP and external PHP servers ;)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect
Locked

Return to “[3.0.x] Abandoned MODs”