[ABD] Facebook Connect 0.3.4

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
mitchboy999
Registered User
Posts: 125
Joined: Tue Jan 20, 2009 1:48 pm

Re: [BETA] Facebook Connect 0.3.4

Post by mitchboy999 » Thu Dec 31, 2009 5:51 pm

DeViAnThans3 wrote:I've no idea, this is all very weird ... have you tried clearing the cache again by manually deleting all files in /cache/ ?

Could you also elaborate on any MODs you've installed next to the portal MOD which may cause any irregularities?
Also, could you post/PM me your board version (3.0.6?) as well as PHP + MySQL version? :)
Arcade, Portal and Download Mod.
phpBB3 3.0.6 with MySQL 5.1.41, PHP Version 5.3.1.

Is there any other way i can help you? I really don't understand whats going on? and i have cleared the cache about 10 times now and manually deleting them.

- mitchboy999

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Thu Dec 31, 2009 6:04 pm

mitchboy999 wrote:
DeViAnThans3 wrote:I've no idea, this is all very weird ... have you tried clearing the cache again by manually deleting all files in /cache/ ?

Could you also elaborate on any MODs you've installed next to the portal MOD which may cause any irregularities?
Also, could you post/PM me your board version (3.0.6?) as well as PHP + MySQL version? :)
Arcade, Portal and Download Mod.
phpBB3 3.0.6 with MySQL 5.1.41, PHP Version 5.3.1.

Is there any other way i can help you? I really don't understand whats going on? and i have cleared the cache about 10 times now and manually deleting them.

- mitchboy999
I'm very confused now too.
Could you maybe check that also all modifications to includes/functions.php are done correctly? I'm only asking this since something went wrong with the styles edit too ;) Maybe the same thing is applicable to includes/functions.php . Especially check if the following line is present!!

Code: Select all

'ENABLE_FBCONNECT'				=> (trim($config['fbconnect_apikey']) != "") ? true : false,
In case that edit wasn't done either, I recommend that you re-check ALL edits as outlined in install.xml :)

Let me know!! ;)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

mitchboy999
Registered User
Posts: 125
Joined: Tue Jan 20, 2009 1:48 pm

Re: [BETA] Facebook Connect 0.3.4

Post by mitchboy999 » Thu Dec 31, 2009 6:19 pm

DeViAnThans3 wrote:
mitchboy999 wrote:
DeViAnThans3 wrote:I've no idea, this is all very weird ... have you tried clearing the cache again by manually deleting all files in /cache/ ?

Could you also elaborate on any MODs you've installed next to the portal MOD which may cause any irregularities?
Also, could you post/PM me your board version (3.0.6?) as well as PHP + MySQL version? :)
Arcade, Portal and Download Mod.
phpBB3 3.0.6 with MySQL 5.1.41, PHP Version 5.3.1.

Is there any other way i can help you? I really don't understand whats going on? and i have cleared the cache about 10 times now and manually deleting them.

- mitchboy999
I'm very confused now too.
Could you maybe check that also all modifications to includes/functions.php are done correctly? I'm only asking this since something went wrong with the styles edit too ;) Maybe the same thing is applicable to includes/functions.php . Especially check if the following line is present!!

Code: Select all

'ENABLE_FBCONNECT'				=> (trim($config['fbconnect_apikey']) != "") ? true : false,
Got it working. The Fuctions.php was the old one.

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Thu Dec 31, 2009 6:31 pm

Great to hear ;)

Best wishes for 2010 everyone! ;)
This'll be the last issue I solved in 2009.. :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

ScrapbookSupplies
Registered User
Posts: 361
Joined: Tue Jan 16, 2007 7:59 pm

Re: [BETA] Facebook Connect 0.3.4

Post by ScrapbookSupplies » Fri Jan 01, 2010 2:30 am

Hi Hans!
I was off the computer until now, so my replies are late. Thank you for helping though. ;)
DeViAnThans3 wrote:Hey,

1) The file not found error: this is very weird.. does this happen after you log in (provided login credentials)? Does it also happen if you go to the ACP again after getting the error?
Please note that it is impossible to log in with Facebook Connect to your admin control panel. There are many reasons why, but the major one is security, obviously.
It was happening when I'd log in to the ACP, trying to use the FB Connect. If I use the regular log in button there is no problem. Phew!
DeViAnThans3 wrote:2) Avatars
Again quite some possible explanations.
  • Is data import enabled in the ACP -> facebook connect settings ?
  • Are remote avatars allowed?
  • Is PHP safe mode off?
  • Are there any restrictions on PHP functions fsockopen() or fopen() functions to remotely connect to other servers?
First check these .. :)

Also: note that Facebook permissions are taken into account. You can't see avatars from other Facebook people if you also can't see them at Facebook. There also is a difference when logged in via Facebook Connect or not.. :)
The data import and off site linking of avatars are enabled.
However, php safe mode is OFF (they wont turn it on). And my webhost said the fsockopen() or fopen() functions are enabled. Also I checked the permissions/privacy on my own personal facebook account and I am visible, so at least my avatar should show up, I think anyway.

Do you have any other thoughts on it?

Again, I appreciate help. Have a great new year!!

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Fri Jan 01, 2010 3:49 pm

ScrapbookSupplies wrote:Hi Hans!
I was off the computer until now, so my replies are late. Thank you for helping though. ;)
DeViAnThans3 wrote:Hey,

1) The file not found error: this is very weird.. does this happen after you log in (provided login credentials)? Does it also happen if you go to the ACP again after getting the error?
Please note that it is impossible to log in with Facebook Connect to your admin control panel. There are many reasons why, but the major one is security, obviously.
It was happening when I'd log in to the ACP, trying to use the FB Connect. If I use the regular log in button there is no problem. Phew!
DeViAnThans3 wrote:2) Avatars
Again quite some possible explanations.
  • Is data import enabled in the ACP -> facebook connect settings ?
  • Are remote avatars allowed?
  • Is PHP safe mode off?
  • Are there any restrictions on PHP functions fsockopen() or fopen() functions to remotely connect to other servers?
First check these .. :)

Also: note that Facebook permissions are taken into account. You can't see avatars from other Facebook people if you also can't see them at Facebook. There also is a difference when logged in via Facebook Connect or not.. :)
The data import and off site linking of avatars are enabled.
However, php safe mode is OFF (they wont turn it on). And my webhost said the fsockopen() or fopen() functions are enabled. Also I checked the permissions/privacy on my own personal facebook account and I am visible, so at least my avatar should show up, I think anyway.

Do you have any other thoughts on it?

Again, I appreciate help. Have a great new year!!
Hey

It is impossible to log in to the admin panel with Facebook Connect; I btw thought I made sure the Facebook Connect button was hidden when accessing the ACP login screen? I find it quite weird that it show the button with you than ..
However, you should not use the Facebook Connect button than when accessing the ACP. This won't work, and I also will never make it work, for obvious security implications. :) (Again, normally no button should show up :? )

About the avatars. Safe mode is the way it should be! (off) Seen all this, I can't think of any probable other reasons why it wouldn't show the avatars..?
Are avatars in general enabled? Haven't you disabled the viewing of avatars in your UCP forum settings? Have you logged in via Facebook Connect or normal login to the forum?.. :)

Thanks!! Happy 2010 to you too :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

User avatar
rosdi
Registered User
Posts: 166
Joined: Wed May 14, 2008 10:26 am
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by rosdi » Mon Jan 04, 2010 4:27 pm

Will this mod add FaceBook Profile address in UCP like MSN button, so other members can add this user to their contact in FB?

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Mon Jan 04, 2010 4:39 pm

rosdi wrote:Will this mod add FaceBook Profile address in UCP like MSN button, so other members can add this user to their contact in FB?
As you may have seen in the feature list in the first post or at the demo board, no, it doesn't add such button. :)
It does, if data importing is enabled, set the website to their Facebook if no other site is entered already. Would that be sufficient for you? :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

User avatar
rosdi
Registered User
Posts: 166
Joined: Wed May 14, 2008 10:26 am
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by rosdi » Mon Jan 04, 2010 4:57 pm

Sorry, I don't understand this "It does, if data importing is enabled, set the website to their Facebook if no other site is entered already."

BTW, I will give a try to mod and see.

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Mon Jan 04, 2010 5:23 pm

rosdi wrote:Sorry, I don't understand this "It does, if data importing is enabled, set the website to their Facebook if no other site is entered already."

BTW, I will give a try to mod and see.
hey

I actually try to say that if you enable Facebook "data importing" in the Facebook Connect settings in your ACP (if you have this MOD installed), the "website" profile field of all Facebook users will automatically be set to their Facebook address. Unless if they have already enterred something inside that website field :)

haha, sorry, sometimes my explanations can be quite unclear.. I hope this makes it a bit more clear to you? :)

Thanks!!
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

bobtheman
Registered User
Posts: 3
Joined: Sat Dec 26, 2009 6:32 pm

Re: [BETA] Facebook Connect 0.3.4

Post by bobtheman » Mon Jan 04, 2010 8:38 pm

any idea when this will be released?

nka
Registered User
Posts: 10
Joined: Tue Jan 04, 2005 6:33 pm
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by nka » Mon Jan 04, 2010 9:10 pm

This look very interesting. We be even more if we are able to send update to profile (something like "{URL} liked this topic : {URL}" with a Single click on the forum).

*Subscribing*
.: :: nka :: :.

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Tue Jan 05, 2010 7:10 am

bobtheman wrote:any idea when this will be released?
Hopefully 0.4.0 will release within the next week. Once 0.4.0, we aren't too far away from an RC (depends on the amount of bugs in 0.4.0..). Once RC, the MOD will be submitted to the MOD DB validation queue about a week after it has became RC (to allow last-minute feedback on the renewed install process). Once the MOD gets validated, it can be considered released.
It's hard to set an exact time frame for that; but in best case, it could be by the beginning of February :)
But that really is "best case" :P
nka wrote:This look very interesting. We be even more if we are able to send update to profile (something like "{URL} liked this topic : {URL}" with a Single click on the forum).

*Subscribing*
Working on that now ;)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

bobtheman
Registered User
Posts: 3
Joined: Sat Dec 26, 2009 6:32 pm

Re: [BETA] Facebook Connect 0.3.4

Post by bobtheman » Tue Jan 05, 2010 2:40 pm

what, if any, license is the modification under?

And, have you thought about incorporating other authentication methods like; openid, myspace, yahoo etc etc maybe under a new Mod name?

User avatar
DeViAnThans3
Registered User
Posts: 877
Joined: Sat Oct 08, 2005 10:39 pm
Location: Belgium

Re: [BETA] Facebook Connect 0.3.4

Post by DeViAnThans3 » Tue Jan 05, 2010 4:00 pm

bobtheman wrote:what, if any, license is the modification under?
As the install.xml states - and just like the phpBB license - GNU General Public License v2.
bobtheman wrote:And, have you thought about incorporating other authentication methods like; openid, myspace, yahoo etc etc maybe under a new Mod name?
Thought about - yes.
Actually realising such MODs - probably no, for several reasons :) One of the most important is, I haven't seen much interest in other such MODs. You're the second person over the past 80 pages who asked for such thing :)
I only provide support via the appropriate topics! Please no PM or mails! :)
My MODs :: [BETA] Facebook Connect

Locked

Return to “[3.0.x] Abandoned MODs”