[ABD] Facebook Connect 0.3.4

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Wizard Sleeve
Registered User
Posts: 75
Joined: Wed Jun 25, 2008 12:13 am

Re: [BETA] Facebook Connect 0.3.4

Post by Wizard Sleeve » Sun Feb 28, 2010 8:46 pm

I installed the plugin fine, and then connected my facebook account to my account.. and then i couldn't get into the admin control panel... I couldn't loggout either...

when logging out i get this error:

You were not logged out, as the request did not match your session. Please contact the board administrator if you continue to experience problems

(lucky i built a second site to test this on)

How do i resolve this issue?

guillaume.rivest
Registered User
Posts: 2
Joined: Sat Feb 13, 2010 9:11 pm

Re: [BETA] Facebook Connect 0.3.4

Post by guillaume.rivest » Mon Mar 01, 2010 8:00 am

Ran into an issue when upgrading to 3.0.6 to 3.0.7 with FBConnect installed.

Somehow, the class acm was declared twice and this prevented the upgrade from proceeding.

Nothing in the mod files declares a class acm, but functions_fbconnect.php, on line 14, has:

Code: Select all

require_once($phpbb_root_path . "includes/acm/acm_file.".$phpEx);
Presumably, this made acm_file.php run twice during the upgrade process, and declare the class acm twice. I commented the line out, and the upgrade worked. I've kept the line commented out since and the mod seems to keep working fine without it, so far.

Encore204
Registered User
Posts: 314
Joined: Sun Feb 05, 2006 9:54 pm
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by Encore204 » Mon Mar 01, 2010 11:12 am

guillaume.rivest wrote:Ran into an issue when upgrading to 3.0.6 to 3.0.7 with FBConnect installed.

Somehow, the class acm was declared twice and this prevented the upgrade from proceeding.

Nothing in the mod files declares a class acm, but functions_fbconnect.php, on line 14, has:

Code: Select all

require_once($phpbb_root_path . "includes/acm/acm_file.".$phpEx);
Presumably, this made acm_file.php run twice during the upgrade process, and declare the class acm twice. I commented the line out, and the upgrade worked. I've kept the line commented out since and the mod seems to keep working fine without it, so far.
So does the mod work normally on 2.0.7 ?

plasmino
Registered User
Posts: 261
Joined: Sat Jul 25, 2009 11:12 am

Re: [BETA] Facebook Connect 0.3.4

Post by plasmino » Mon Mar 01, 2010 7:10 pm

yes Encore204 ;)

Encore204
Registered User
Posts: 314
Joined: Sun Feb 05, 2006 9:54 pm
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by Encore204 » Mon Mar 01, 2010 8:29 pm

mkay, me is off to do an upgrade :D

Encore204
Registered User
Posts: 314
Joined: Sun Feb 05, 2006 9:54 pm
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by Encore204 » Mon Mar 01, 2010 10:07 pm

guillaume.rivest wrote:Ran into an issue when upgrading to 3.0.6 to 3.0.7 with FBConnect installed.

Somehow, the class acm was declared twice and this prevented the upgrade from proceeding.

Nothing in the mod files declares a class acm, but functions_fbconnect.php, on line 14, has:

Code: Select all

require_once($phpbb_root_path . "includes/acm/acm_file.".$phpEx);
Presumably, this made acm_file.php run twice during the upgrade process, and declare the class acm twice. I commented the line out, and the upgrade worked. I've kept the line commented out since and the mod seems to keep working fine without it, so far.
hi there!
i tried this, and finnaly, the update procedure started.
But unfortunatly, after i was to update files, i get this error

Code: Select all

Parse error: syntax error, unexpected $end in /home/nturus/public_html/forum/includes/functions_content.php on line 834

has anything similar happened to you ?

dramacius
Registered User
Posts: 47
Joined: Thu Oct 30, 2008 12:54 pm

Re: [BETA] Facebook Connect 0.3.4

Post by dramacius » Thu Mar 04, 2010 4:48 pm

Hi I have a problem with this mod on PHPBB3.0.6 I have all the links and admin/user control panels I have set up my api and secret key but nothing happens when users clickthe facebook connect link on login and when I go to the ucp for facebook connect I get this message
Edit Facebook settings

Your account is not linked to a Facebook account.
I am also using a couple of other mods including Damysterious Portal XL Premod and Moderator Notify sorry can't remember the link to this mod but I got it from this site.

any ideas what I might have done wrong?

edit: I also have smix auto feed bot mod thing.



Nevermind problem fixed itself. I must have been a bit impatient
Last edited by dramacius on Thu Mar 04, 2010 10:20 pm, edited 1 time in total.

man128
Registered User
Posts: 22
Joined: Sun May 04, 2008 1:43 am

Re: [BETA] Facebook Connect 0.3.4

Post by man128 » Thu Mar 04, 2010 8:48 pm

Is this mod working well with phpbb3.0.7??????????
Boxing, MMA, Conspiracy, and NFL Discussions. Free Arcade Games at TwoEdge.us

User avatar
cruzerv3
Registered User
Posts: 90
Joined: Thu Jul 23, 2009 10:24 am
Location: Switzerland

Re: [BETA] Facebook Connect 0.3.4

Post by cruzerv3 » Thu Mar 04, 2010 9:00 pm

man128 wrote:Is this mod working well with phpbb3.0.7??????????
Yes.
[sorry for my poor english]

dramacius
Registered User
Posts: 47
Joined: Thu Oct 30, 2008 12:54 pm

Re: [BETA] Facebook Connect 0.3.4

Post by dramacius » Fri Mar 05, 2010 3:11 am

Damn I am having trouble with my facebook connect button not working again

my site is http://supporttheanimals.tk if someone cares to take a look.

nothing happens when I click it from the login screen.

User avatar
cruzerv3
Registered User
Posts: 90
Joined: Thu Jul 23, 2009 10:24 am
Location: Switzerland

Re: [BETA] Facebook Connect 0.3.4

Post by cruzerv3 » Fri Mar 05, 2010 4:39 am

dramacius wrote:Damn I am having trouble with my facebook connect button not working again

my site is http://supporttheanimals.tk if someone cares to take a look.

nothing happens when I click it from the login screen.
Did you set correctly the script? Like in styles/yourstyle/template/login_body.html, styles/yourstyle/template/overall_header.html
[sorry for my poor english]

dramacius
Registered User
Posts: 47
Joined: Thu Oct 30, 2008 12:54 pm

Re: [BETA] Facebook Connect 0.3.4

Post by dramacius » Fri Mar 05, 2010 5:00 am

cruzerv3 wrote:
dramacius wrote:Damn I am having trouble with my facebook connect button not working again

my site is http://supporttheanimals.tk if someone cares to take a look.

nothing happens when I click it from the login screen.
Did you set correctly the script? Like in styles/yourstyle/template/login_body.html, styles/yourstyle/template/overall_header.html
I just tried this but it didn't solve the problem, the button still does nothing

dramacius
Registered User
Posts: 47
Joined: Thu Oct 30, 2008 12:54 pm

Re: [BETA] Facebook Connect 0.3.4

Post by dramacius » Fri Mar 05, 2010 5:12 am

I deleted my facebook app and created a new one, fingures crossed that solved the problem.

liketobemad
Registered User
Posts: 19
Joined: Mon Mar 16, 2009 6:28 pm
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by liketobemad » Fri Mar 05, 2010 9:37 am

it really worked like a charm. I first had some apprehensions as the Mod author said it may now work... but any how it worked...

Thanks a lot to the MOD author...
Please visit my portal for travel, fun , info, softwares, Quizzes
My website - http://dilipkumar.in

ecwpa
Registered User
Posts: 107
Joined: Thu Sep 25, 2003 2:13 am
Contact:

Re: [BETA] Facebook Connect 0.3.4

Post by ecwpa » Fri Mar 05, 2010 10:50 am

awesome stuff man, looking forward a final release
carefull, not english speaker native here

Locked

Return to “[3.0.x] Abandoned MODs”