[ABD] Real Upload Progress Bar v2.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
ServA1
Registered User
Posts: 42
Joined: Fri Aug 14, 2009 3:14 pm
Location: Australia

Re: [RC] Real Upload Progress Bar v1.0.1

Post by ServA1 » Fri Apr 02, 2010 12:33 am

New version available - v2.0.1. Includes many changes and fixes.
Super fast USA based website hosting available with a bunch of useful stuff ready to go (ffmpeg, imagemagick, nginx etc), message me if you are interested.

ServA1
Registered User
Posts: 42
Joined: Fri Aug 14, 2009 3:14 pm
Location: Australia

Re: [RC] Real Upload Progress Bar v1.0.1

Post by ServA1 » Fri Apr 02, 2010 12:54 am

FeuerSturm wrote:Hello!

I am having the problem of the upload being done in the background
without any information being displayed as well.

I am using a ProSilver based Template called "Vintage" and I tripple checked
all edits and even had automod do the edits for me successfully.

The extension is installed and running like it should, I have no ide what's wrong,
all it shows is:

Code: Select all

Percent uploaded: 0%
Upload speed: 0Kbs 
Average speed: 0Kbs
Time left: 0min 0sec
and the "blank" progressbar.

Any help would be appreciated, i really like the idea of this mod!

Thanks in advance!

EDIT

I am usually using Google Chrome and it doesn't work, now i tried it with IE8 and it worked like
a charme!
Is there any way to get it to work with non-IE browsers as well?
This mod will only work in Chrome if you add a target to the html form like so -

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" target="_blank" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
The above fix works but you won't want a new window opening every time you upload something.

The other way is to make an iframe like so in your posting_layout.html template like so (put it on the first line) -

Code: Select all

<iframe name=uploadtarget" id="uploadtarget" src="" width="1px" height="1px"></iframe>
Then you need to add a target to your html form pointing to the iframe like so -

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" target="uploadtarget" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
The problem with this is when the upload is finished the page is not refreshed and upload progress stalls at 99% completion.

Chrome has it's own built in upload progress indicator anyway if you have a look at the bottom left of the browser when you are uploading something.

So the best way to deal with this bug I have found so far is to simply gracefully degrade Chrome so that when an upload occurs absolutely no upload progress is displayed at all.
Super fast USA based website hosting available with a bunch of useful stuff ready to go (ffmpeg, imagemagick, nginx etc), message me if you are interested.

ServA1
Registered User
Posts: 42
Joined: Fri Aug 14, 2009 3:14 pm
Location: Australia

Re: [RC] Real Upload Progress Bar v2.0.1

Post by ServA1 » Sat Apr 10, 2010 3:25 am

I just noticed a small cosmetic error in my latest version of the mod (2.0.1). I have fixed the install instructions and reuploaded the mod.

For those that have already installed the latest version, the change is as follows and all it involves is removing the "0%" part -

Open: style/prosilver/template/posting_attach_body.html

Change this:
<dl>
<dt></dt>
<dd><span class="progressbar" id="uploadprogressbar"></span>0%</dd>
</dl>

To this:
<dl>
<dt></dt>
<dd><span class="progressbar" id="uploadprogressbar"></span></dd>
</dl>
Super fast USA based website hosting available with a bunch of useful stuff ready to go (ffmpeg, imagemagick, nginx etc), message me if you are interested.

User avatar
Meis2M
Translator
Posts: 870
Joined: Wed Mar 03, 2010 11:32 am
Location: IR.Damghan
Name: میثم نوبری
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by Meis2M » Tue Apr 27, 2010 12:46 pm

i have a problem.. in this command

style/subsilver2/template/posting_body.html
Find

Code: Select all

<form action="{S_POST_ACTION}" target="progressFrame" method="post" name="postform"{S_FORM_ENCTYPE}>

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
i cant find the code and replace with new code... there is a similar code

Code: Select all

	<form action="{S_POST_ACTION}" method="post" onsubmit="Gettext('message',true)" name="postform"{S_FORM_ENCTYPE}>
>
when i replace new code with this code... this mod workk but a problem.. i cant edit a post...
when i edit a post and submit it. in new page see " Character is low "...

can u help me?
phpBB persian international support
Ultimate SEO Friendly URL - Extension
Follow us in Instagram
Free upgrade and install extensions on your forum - drop me PM

User avatar
hah
Registered User
Posts: 85
Joined: Sat Feb 13, 2010 11:49 am
Location: Pernik, Bulgaria
Name: Alex Georgiev
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by hah » Fri May 07, 2010 1:46 pm

Meis2M wrote:i have a problem.. in this command

style/subsilver2/template/posting_body.html
Find

Code: Select all

<form action="{S_POST_ACTION}" target="progressFrame" method="post" name="postform"{S_FORM_ENCTYPE}>

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
i cant find the code and replace with new code... there is a similar code

Code: Select all

	<form action="{S_POST_ACTION}" method="post" onsubmit="Gettext('message',true)" name="postform"{S_FORM_ENCTYPE}>
>
when i replace new code with this code... this mod workk but a problem.. i cant edit a post...
when i edit a post and submit it. in new page see " Character is low "...

can u help me?
Before

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
Type

Code: Select all

<script type="text/javascript">
function doStuff() {

Gettext('message',true);
beginUpload();

}

</script>
Then Replace

Code: Select all

<form id="postform" onsubmit="beginUpload();" enctype="multipart/form-data" method="post" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
<input id="progress_key" name="UPLOAD_IDENTIFIER" type="hidden" value="{S_UP_ID}" />
With

Code: Select all

<form id="postform" method="post" onsubmit="doStuff();" action="{S_POST_ACTION}"{S_FORM_ENCTYPE}>
<input id="progress_key" name="UPLOAD_IDENTIFIER" type="hidden" value="{S_UP_ID}" />
Using Almsamim's WYSIWYG?
Well I found a solution if you use it. :)

User avatar
Meis2M
Translator
Posts: 870
Joined: Wed Mar 03, 2010 11:32 am
Location: IR.Damghan
Name: میثم نوبری
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by Meis2M » Fri May 07, 2010 2:12 pm

Wow... its work perfect... u a real friend.. tnx brother.. ;)
phpBB persian international support
Ultimate SEO Friendly URL - Extension
Follow us in Instagram
Free upgrade and install extensions on your forum - drop me PM

NetCorp
Registered User
Posts: 7
Joined: Tue Aug 31, 2010 9:03 pm

Re: [RC] Real Upload Progress Bar v2.0.1

Post by NetCorp » Tue Aug 31, 2010 9:32 pm

I have some errors when I install with AutoMOD: see http://tinyurl.com/automod
EDIT: Forget installing with AutoMOD, impossible. :(

Doesn't work in Opera.
Infact, I can't post anymore :o . If I click the upper "Submit" or "Preview" buttons I get this error: The submitted form was invalid. Try submitting again. The lower buttons "Add the file", "Preview", "Submit" and "Cancel" do not react at all.

In Prosilver: I can't post, none of the buttons react. The format buttons do not react and you can't add emoticons anymore.

Works in IE. But if you click "Cancel" while uploading, the upload doesn't stop but begins again from 0. :?

ServA1
Registered User
Posts: 42
Joined: Fri Aug 14, 2009 3:14 pm
Location: Australia

Re: [RC] Real Upload Progress Bar v2.0.1

Post by ServA1 » Sat Sep 18, 2010 7:36 pm

NetCorp wrote:I have some errors when I install with AutoMOD: see http://tinyurl.com/automod
EDIT: Forget installing with AutoMOD, impossible. :(
:?
I didn't make this mod to work with AutoMOD so I don't know why you even assumed that.
NetCorp wrote:Doesn't work in Opera.
Infact, I can't post anymore :o . If I click the upper "Submit" or "Preview" buttons I get this error: The submitted form was invalid. Try submitting again. The lower buttons "Add the file", "Preview", "Submit" and "Cancel" do not react at all.
It works in Opera, I have tested it and the upload goes through as normal without any errors. The only problem being that the progressbar doesn't degrade as gracefully as I would want for that browser, it shows up but doesn't return any information. Anyway I will make this mod either work for Opera like it does on other browsers, or i'll make it degrade better in the next version. But rest assured, the attachment upload still works for Opera as the mod is now.
NetCorp wrote:In Prosilver: I can't post, none of the buttons react. The format buttons do not react and you can't add emoticons anymore.
In prosilver you have made an editing error/s, that simple.
NetCorp wrote:Works in IE. But if you click "Cancel" while uploading, the upload doesn't stop but begins again from 0.
It works in IE. If you press the stop button on your browser the upload will stop after the current information is completely sent. Then if you press upload again it goes back to 0% and starts again. Whats the problem? Did you expect it to resume where you left off uploading? lol because that's not how it works, even the standard phpBB attachment upload doesn't do that.
Super fast USA based website hosting available with a bunch of useful stuff ready to go (ffmpeg, imagemagick, nginx etc), message me if you are interested.

User avatar
K2
Registered User
Posts: 56
Joined: Fri Jan 03, 2003 5:30 am
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by K2 » Fri Sep 24, 2010 10:39 pm

Hello ServA1, nice mod.

I just installed this mod on my board, and I am having the same issue that FeuerSturm is/was having, but under IE8. I have JSON 1.2.1 installed, uploadprogress 1.01 is also installed and verified via phpinfo. I use a custom template, but it's just a modified version of prosilver so the template edits were identical.

Gonna try uploading a file under a few different browsers to see how it acts, but right now it's just a blank bar showing 0% progress.

FYI - the only step in the DIY instructions I could not do was an actual server reboot. I am lucky enough that my host installed uploadprogress rather quickly upon request, and it appeared as functional as soon as I edited my php.ini file - is a server rebooot absolutely necessary or should this mod work with just the package install/file edits?

EDIT - getting the exact same issue using FF 3.6.10 and Safari.
Last edited by K2 on Sun Sep 26, 2010 4:37 am, edited 1 time in total.

User avatar
spaceace
Registered User
Posts: 1857
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by spaceace » Fri Sep 24, 2010 11:47 pm

i finally decided to give this a go and was having some problems getting it to work. contacted my host and this was the reply...
Unfortunately, the UploadProgress PECL package is not compatible with our hosting environment. UploadProgress can only work on Apache installations with mod_php. On our servers, however, PHP is installed as CGI/SuExec and not as a module.
so, before you try this mod, make sure your host is able to run it ;)

to eliminate the need to know who my host is, it's icdsoft... advertised on this site ;)

satandream
Registered User
Posts: 383
Joined: Thu Mar 06, 2008 12:47 pm

Re: [RC] Real Upload Progress Bar v1.0.1

Post by satandream » Mon Oct 04, 2010 11:22 am

topara wrote:Hi, how to install uploadprogress-1.0.1 on my server, and where do I upload folder contents uploadprogress-1.0.1
This depends on the system you are using for ubuntu/debian it works with

Code: Select all

pecl install uploadprogress

User avatar
AHTEPO
Registered User
Posts: 37
Joined: Fri Feb 08, 2008 7:00 pm
Location: Russia, KRD

Re: [RC] Real Upload Progress Bar v2.0.1

Post by AHTEPO » Wed Oct 20, 2010 2:44 pm

ServA1, please fix download link! There are no file... :(

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by muggins » Fri Oct 22, 2010 3:45 pm

Try this: phpBB_Real_Upload_Progress_Bar_v1.0.1.zip

That will work if your network isn't blocked... ;)
Muggins

User avatar
AHTEPO
Registered User
Posts: 37
Joined: Fri Feb 08, 2008 7:00 pm
Location: Russia, KRD

Re: [RC] Real Upload Progress Bar v2.0.1

Post by AHTEPO » Mon Nov 08, 2010 3:42 pm

Thanks, muggins! But can anyone upload v2.0.1?

User avatar
muggins
Registered User
Posts: 1183
Joined: Fri Feb 22, 2008 5:12 pm
Location: Texas
Name: Donovan
Contact:

Re: [RC] Real Upload Progress Bar v2.0.1

Post by muggins » Mon Nov 08, 2010 4:48 pm

I downloaded it from the link in the first post. :?

If you can't get it there, here it is.
Muggins

Locked

Return to “[3.0.x] Abandoned MODs”