[ABD] Social Networking Site Buttons 2.2.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DocSommer » Sat Dec 26, 2009 3:01 pm

I'm not great in image editing but I'll give it a shot of course. I also wanted to remove some of the already existing networks wich are not really popular here and my plan was to "recycle" these, like renaming the "bebo" stuff to youtube stuff - guess I just have to change the language files for that.

Edit:

Here's the first button (youtube) - I hope it's ok:

http://www.jansommer.net/stuff/youtube_button.zip

The archive is including two different colored versions.

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DoYouSpeakWak » Sat Dec 26, 2009 3:41 pm

DocSommer wrote:I'm not great in image editing but I'll give it a shot of course. I also wanted to remove some of the already existing networks wich are not really popular here and my plan was to "recycle" these, like renaming the "bebo" stuff to youtube stuff - guess I just have to change the language files for that.

Edit:

Here's the first button (youtube) - I hope it's ok:

http://www.jansommer.net/stuff/youtube_button.zip

The archive is including two different colored versions.
if you simple replacing a existing image with another its more simple. Change the language files and overwrite the image with the new one. Very simple. Remember to refresh imageset and purge cache.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DocSommer » Sat Dec 26, 2009 3:51 pm

shure that :)

another question - there is ascreenshot that is showing something within the ACP. Maybe I'm blind but I couldn't find something within the ACP that looks related to this mod - any hints?

Edit:

Next button:

http://www.jansommer.net/stuff/studivz_button.zip


Edit2:

I think I found that ACP settings - seems that is just the display of the profile settings if I manage a user. But I'm looking for a solution to edit the URL settings of the social networking sites, like removing the prepared "bebo". Well I now realized that I need to edit the template files for that so it's not a big deal ;)

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DoYouSpeakWak » Sat Dec 26, 2009 6:16 pm

Your right the settings for this mod is in the "manager user" part.

You dont have to change the template if your just reusing a old button. Simple alter the language edits that comes with the mod and reupload your button, refresh imageset and your done.

Nice buttons. Thanks for sharing.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DocSommer » Sat Dec 26, 2009 6:35 pm

Thanks - if anyone needs other buttons just leave me a PM. I can't promise anything but I can give it a try ;)

@template edits:

Well you may need indeed need to edit the templates - depend on what network you like to re-use. The Bebo link for an example is written that way within the template files: <a href="http://www.bebo.com/{postrow.U_BEBO}" - here is is necessary to remove the "http://www.bebo.com/" part or change it against "http://www.youtube.com/" so the user just need to enter his youtube user name instead of the profile URL.

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DoYouSpeakWak » Sat Dec 26, 2009 6:41 pm

DocSommer wrote:Thanks - if anyone needs other buttons just leave me a PM. I can't promise anything but I can give it a try ;)

@template edits:

Well you may need indeed need to edit the templates - depend on what network you like to re-use. The Bebo link for an example is written that way within the template files: <a href="http://www.bebo.com/{postrow.U_BEBO}" - here is is necessary to remove the "http://www.bebo.com/" part or change it against "http://www.youtube.com/" so the user just need to enter his youtube user name instead of the profile URL.
Sure some url may require you edit that as well. Good thing you seem to be on the top of it.

Post number 1000 :D :)
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DocSommer » Sat Dec 26, 2009 7:06 pm

Well I'm learning slowly but constant :lol:
Post number 1000 :D :)
Image
Image

hojko
Registered User
Posts: 69
Joined: Wed Aug 11, 2004 2:20 am
Location: Slovakia

Re: [RC] Social Networking Site Buttons 2.2.0

Post by hojko » Mon Dec 28, 2009 2:45 am

Version 2.2.0 - error in installation file subsilver2_edits.xml:

Code: Select all

<td class="row2"><input class="post" type="text" name="myspace" size="30" maxlength="255" value="[b]{_MYSPACE}[/b]" /></td>
Have must MYSPACE withou _, please correct it :)

oecherjung
Registered User
Posts: 10
Joined: Wed Aug 26, 2009 6:31 am
Location: Germany
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by oecherjung » Mon Dec 28, 2009 2:07 pm

Hello,

my installation fail,

if i start http://www-users.rwth-aachen.de/Guido.F ... uttons.php

i become an error (you can see the failure - link aktive!)


after the faild installtion, i don't can start my forum http://www.Treffpunkt-Boscheln.de (white space)

i hope someone can help me.

oechi
PHP 4.4.1 | MYSQL 4.0.15 | phpBB3 Version 3.0.5 | Style: Pro-Silver
Test Account: http://www.treffpunkt-boscheln.de | User: qwert | PW: qwert123

future74
Registered User
Posts: 135
Joined: Mon Nov 16, 2009 2:08 am
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by future74 » Mon Dec 28, 2009 5:47 pm

Hi,

I installed this mod today but one of the options is not working

Twitter... when i enter my twitter username and roll my mouse over the twitter image i get this URL...

http://my_web_url/forum/twitter_username

it should be:

http://www.twitter.com/username

Can anyone help please ?


Im sure i haven't missed anything in the setup

future74
Registered User
Posts: 135
Joined: Mon Nov 16, 2009 2:08 am
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by future74 » Mon Dec 28, 2009 6:22 pm

Problem solved...

subsilver2 template guide is wrong

Code: Select all

<tr>
	<td class="gen" nowrap="nowrap" align="{S_CONTENT_FLOW_END}">{L_TWITTER}: </td>
	<td><!-- IF USER_TWITTER --><a href="{USER_TWITTER}">{TWITTER_IMG}</a><!-- ELSEIF USER_TWITTER -->{TWITTER_IMG}<!-- ENDIF --></td>
</tr>
it should be:

Code: Select all

<tr>
	<td class="gen" nowrap="nowrap" align="{S_CONTENT_FLOW_END}">{L_TWITTER}: </td>
	<td><!-- IF USER_TWITTER --><a href="http://www.twitter.com/{USER_TWITTER}">{TWITTER_IMG}</a><!-- ELSEIF USER_TWITTER -->{TWITTER_IMG}<!-- ENDIF --></td>
</tr>

User avatar
DoYouSpeakWak
Registered User
Posts: 2307
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DoYouSpeakWak » Mon Dec 28, 2009 6:35 pm

future74 wrote:Problem solved...

subsilver2 template guide is wrong

Code: Select all

<tr>
	<td class="gen" nowrap="nowrap" align="{S_CONTENT_FLOW_END}">{L_TWITTER}: </td>
	<td><!-- IF USER_TWITTER --><a href="{USER_TWITTER}">{TWITTER_IMG}</a><!-- ELSEIF USER_TWITTER -->{TWITTER_IMG}<!-- ENDIF --></td>
</tr>
it should be:

Code: Select all

<tr>
	<td class="gen" nowrap="nowrap" align="{S_CONTENT_FLOW_END}">{L_TWITTER}: </td>
	<td><!-- IF USER_TWITTER --><a href="http://www.twitter.com/{USER_TWITTER}">{TWITTER_IMG}</a><!-- ELSEIF USER_TWITTER -->{TWITTER_IMG}<!-- ENDIF --></td>
</tr>
Thanks for reporting this. This will be looked over before the next update.
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid phpBB help and System administrator services.

future74
Registered User
Posts: 135
Joined: Mon Nov 16, 2009 2:08 am
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by future74 » Mon Dec 28, 2009 6:54 pm

no problem...

i found another small error in the subsilver2 template guide:

styles/subsilver2/template/ucp_profile_profile_info.html

Code: Select all

<tr> 
	<td class="row1" width="35%"><b class="genmed">{L_UCP_MYSPACE}: </b></td>
	<td class="row2"><input class="post" type="text" name="myspace" size="30" maxlength="255" value="{_MYSPACE}" /></td>
</tr>
need to be:

Code: Select all

<tr> 
	<td class="row1" width="35%"><b class="genmed">{L_UCP_MYSPACE}: </b></td>
	<td class="row2"><input class="post" type="text" name="myspace" size="30" maxlength="255" value="{MYSPACE}" /></td>
</tr>

future74
Registered User
Posts: 135
Joined: Mon Nov 16, 2009 2:08 am
Contact:

Re: [RC] Social Networking Site Buttons 2.2.0

Post by future74 » Mon Dec 28, 2009 6:58 pm

i forgot to say thanks for this great mod. hehe :)

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [RC] Social Networking Site Buttons 2.2.0

Post by DocSommer » Mon Dec 28, 2009 7:01 pm

oecherjung wrote:Hello,

my installation fail,

if i start http://www-users.rwth-aachen.de/Guido.F ... uttons.php

i become an error (you can see the failure - link aktive!)


after the faild installtion, i don't can start my forum http://www.Treffpunkt-Boscheln.de (white space)

i hope someone can help me.

oechi
Try to enable the debugging feature in config.php - simply remove the "//" at the bottom of the config.php. After doing this, try to access the page again to check what the debugging is saying. Did you use a proper editor for the code changes (Keyword "utf without BOM")? I barely remind to had the same problem after editing the language files and accidently saved them in ASCII format. Also a missing ' can force trouble like this.

I'd recommend notepad++ to edit and check your files.

Locked

Return to “[3.0.x] Abandoned MODs”