[ABD] Link Page 0.0.5

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
FreakyBlue
Registered User
Posts: 331
Joined: Sun Jul 27, 2008 6:00 pm
Name: David Jansen
Contact:

Re: [DEV] Link Page 0.0.4

Post by FreakyBlue »

You haven't made the necessary edits to the ./includes/constants.php file.
Check the install.xml file again that's included in the MOD package. If it's an update from v0.0.3 to 0.0.4 you should check the update_0.0.3_to_0.0.4 file in the ./contrib/update folder.
My music and tutorials -> https://youtube.com/gh0stwrit3rMusic/
Former phpBB Style and Mod Author -> https://www.phpbb.com/customise/db/auth ... tributions
User avatar
FreakyBlue
Registered User
Posts: 331
Joined: Sun Jul 27, 2008 6:00 pm
Name: David Jansen
Contact:

Re: [DEV] Link Page 0.0.4

Post by FreakyBlue »

Today I've made good progress on the development of the Linkpage MOD.
A lot of features have been added. For example:
  1. - Added group permissions
    - Added configuration settings module
    - Added disable linkpage option
    - Added set column value option for category and links page
    - Added max links and max categories value option for category and links page
    - Added pagination to linkpage MOD pages
    - Added use external links option
    - Added viewonline integration
The only feature I want to add also for the next release is the click counter of links. I hope to get that done soon.

If you use this MOD and you have translated it to another language than Dutch, English or Italian, I would really love it if you would share it. You can pm me here @ phpBB.com or @ IDLaunch.org.
My music and tutorials -> https://youtube.com/gh0stwrit3rMusic/
Former phpBB Style and Mod Author -> https://www.phpbb.com/customise/db/auth ... tributions
User avatar
FreakyBlue
Registered User
Posts: 331
Joined: Sun Jul 27, 2008 6:00 pm
Name: David Jansen
Contact:

Re: [ALPHA] Link Page 0.0.5

Post by FreakyBlue »

With proud I announce the release of MOD version 0.0.5. The Linkpage MOD has left the [DEV] status and has entered the [ALPHA] phase.

What's new in this version?
Development report version 0.0.5:
1. Added group permissions
2. Added click counter links
3. Added configuration settings module
4. Added disable linkpage option
5. Added set column value option for category and links page
6. Added max links and max categories value option for category and links page
7. Added pagination to linkpage MOD pages
8. Added use or disable category image option
9. Added use or disable link image option
10. Added use external links option (bitpixel integration)
11. Added viewonline integration

No bugfixes are included, cause there were no known bugs ;)

Happy updating.
Greetz,
FreakyBlue
My music and tutorials -> https://youtube.com/gh0stwrit3rMusic/
Former phpBB Style and Mod Author -> https://www.phpbb.com/customise/db/auth ... tributions
Peter77sx
Registered User
Posts: 3260
Joined: Wed Nov 09, 2005 2:51 pm

Re: [ALPHA] Link Page 0.0.5

Post by Peter77sx »

Very nice... just updated. it's come a long ways and congrats for ALPHA release :)

2 suggetions: If lp_index.php is gonna be used instead, maybe add a index.html in the directory... i personally might rename it to index.php see if that works out for me. I like directories to work that way. :lol:

Also, maybe later down the road make another way to choose category to place a link. ( dropdown list maybe ) but i'm sure you've thought about this already being that the MOD is still in early stages.


Thanks agian. :)
lovelysummer
Registered User
Posts: 437
Joined: Fri Mar 20, 2009 1:49 pm

Re: [ALPHA] Link Page 0.0.5

Post by lovelysummer »

Hi Freakyblue,

Updated to 0.0.5 , I got problems. Images in link category cannot be generated and this happens to ACP also but images in the links index is fine. My previous root is images/linkpage/images/myfishsite.png and worked fine.

Secondly, in viewonline , to click the link category goes to the category page , but everything is collapsed. I noticed the url is

Code: Select all

http://my_forum/linkpage/lp_category.php
But the exact url is

Code: Select all

http://my_forum/linkpage/lp_category.php?cat_id=1
Any idea ? Did I do something wrong? :(

Thank you
User avatar
FreakyBlue
Registered User
Posts: 331
Joined: Sun Jul 27, 2008 6:00 pm
Name: David Jansen
Contact:

Re: [ALPHA] Link Page 0.0.5

Post by FreakyBlue »

Peter77sx wrote:If lp_index.php is gonna be used instead, maybe add a index.html in the directory... i personally might rename it to index.php see if that works out for me. I like directories to work that way. :lol:
I've used that structure before, but many complained that the active tab from a navigation menu is hard to code that way (the board index link also lights up). This way this can easily be avoided ;)
Just changing the lp_index.php to index.php won't work. You need to edit the code also to get that work.
lovelysummer wrote:Updated to 0.0.5 , I got problems. Images in link category cannot be generated and this happens to ACP also but images in the links index is fine. My previous root is images/linkpage/images/myfishsite.png and worked fine.
Check your settings for the link images. Don't use the external link option (set to no) and activate link images. Refresh your template files and check again. It should work fine that way ;)

About the viewonline .. I'll take care of it in the next release.
My music and tutorials -> https://youtube.com/gh0stwrit3rMusic/
Former phpBB Style and Mod Author -> https://www.phpbb.com/customise/db/auth ... tributions
lovelysummer
Registered User
Posts: 437
Joined: Fri Mar 20, 2009 1:49 pm

Re: [ALPHA] Link Page 0.0.5

Post by lovelysummer »

Thanks for your reply Freakblue. Setting the Use external image to 'no' now I get the images. :D

One more minor question about permission. Being as a founder and an admin simoutanously, I have to set myself permission under Admin group. Otherwise I cannot view the link page. This is my case. What about if someone is a founder but not an admin ? Does his permission is already included?

Thankyou very much. :)
Peter77sx
Registered User
Posts: 3260
Joined: Wed Nov 09, 2005 2:51 pm

Re: [ALPHA] Link Page 0.0.5

Post by Peter77sx »

FreakyBlue wrote:
Peter77sx wrote:If lp_index.php is gonna be used instead, maybe add a index.html in the directory... i personally might rename it to index.php see if that works out for me. I like directories to work that way. :lol:
I've used that structure before, but many complained that the active tab from a navigation menu is hard to code that way (the board index link also lights up). This way this can easily be avoided ;)
Just changing the lp_index.php to index.php won't work. You need to edit the code also to get that work.
Well that is strange... and yes, I know. ;)
User avatar
canadianlatitude
Registered User
Posts: 94
Joined: Sat Nov 17, 2007 11:13 am
Contact:

Re: [ALPHA] Link Page 0.0.5

Post by canadianlatitude »

:mrgreen: Update went great. Thanks. :)
User avatar
FreakyBlue
Registered User
Posts: 331
Joined: Sun Jul 27, 2008 6:00 pm
Name: David Jansen
Contact:

Re: [ALPHA] Link Page 0.0.5

Post by FreakyBlue »

canadianlatitude wrote::mrgreen: Update went great. Thanks. :)
You're welcome ;)

Today I've noticed two bugs in the Linkpage MOD v0.0.5. When updating the link category content or the link information content in the ACP module, the view or click count is being reset to zero. That should not happen.

I already got the fix for it. You can find it at the bugtracker @ IDLaunch.org: http://idlaunch.org/tracker.php?p=4
My music and tutorials -> https://youtube.com/gh0stwrit3rMusic/
Former phpBB Style and Mod Author -> https://www.phpbb.com/customise/db/auth ... tributions
lovelysummer
Registered User
Posts: 437
Joined: Fri Mar 20, 2009 1:49 pm

Re: [ALPHA] Link Page 0.0.5

Post by lovelysummer »

Thanks for the bug fixed :mrgreen:
User avatar
canadianlatitude
Registered User
Posts: 94
Joined: Sat Nov 17, 2007 11:13 am
Contact:

Re: [ALPHA] Link Page 0.0.5

Post by canadianlatitude »

Thanks. :mrgreen: :D
Holger
Registered User
Posts: 1838
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [ALPHA] Link Page 0.0.5

Post by Holger »

thanks a lot for developing this great mod!

Is it possible for the boardmembers to add links?
If not: freature request :D
Holger
Registered User
Posts: 1838
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [ALPHA] Link Page 0.0.5

Post by Holger »

I installed 0.0.5 and I get this when I try to add a category:
SQL ERROR [ mysqli ]

Field 'linkcategory_view' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_linkpage_categories (linkcategory_title, linkcategory_desc, linkcategory_image, linkcategory_order, linkcategory_image_use, linkcategory_blank) VALUES ('Bloggar', 'Länkar till externa bloggar', '', 0, 2, 1)

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/acp/acp_linkpage.php
LINE: 161
CALL: dbal_mysqli->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_linkpage->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
Holger
Registered User
Posts: 1838
Joined: Tue Mar 12, 2002 3:54 pm
Location: Hannover

Re: [ALPHA] Link Page 0.0.5

Post by Holger »

FreakyBlue wrote:
canadianlatitude wrote::mrgreen: Update went great. Thanks. :)
You're welcome ;)

Today I've noticed two bugs in the Linkpage MOD v0.0.5. When updating the link category content or the link information content in the ACP module, the view or click count is being reset to zero. That should not happen.

I already got the fix for it. You can find it at the bugtracker @ IDLaunch.org: http://idlaunch.org/tracker.php?p=4
By the way, I tried this fix and I get errormessages by that.
Locked

Return to “[3.0.x] Abandoned MODs”