[ABD]AlternateLogin(Windows Live,Facebook,OpenID)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Sir Charles
Registered User
Posts: 33
Joined: Fri May 19, 2006 9:05 am
Location: Vienna, Austria
Name: Martin

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by Sir Charles » Fri Nov 15, 2013 11:43 pm

Hi all,

I have a problem which I can't solve for myself. In my forums I had the Version 2012-02.12.01 installed and everything worked fine. Some months ago, this changed and I hoped through updating the mod, this problem would be resolved. Well, I ran into problems with deleting useless code from the files for upgrading to version 2013.08.04.01, but the essential problem wasn't solved:

When someone comes newly to the forum (not registered), opening the index-page is not possible. Nearly immediately you are redirected to the Login page of Facebook.

Please see for yourself: http://debuetanten.at/phpBB3/index.php or http://debuetanten.at and then clicking on "Forum".

I guess, something is interfering with the old version of the mod as a antother forums modified with this mod worked without any problems...

Any help would be appreciated :)

rainy1
Registered User
Posts: 1
Joined: Sat Nov 16, 2013 1:40 pm
Location: http://www.hkgames.org
Contact:

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by rainy1 » Sat Nov 16, 2013 1:48 pm

Hi all

I have some question about facebook login
my forum is here: http://hkgames.org/forum

When i Login with facebook account which email are XXX@yahoo.com.hk then it show
"You have been successfully logged in!" And Redirect to home page and still showing as a unlogged in user.

When i login with facebook account whcih email are XXX@yahoo.ca, All things goes well!
I have searched for few hours and i don't know what is going on.
May you help me?

forforce
Registered User
Posts: 323
Joined: Fri Oct 04, 2013 7:57 am
Contact:

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by forforce » Tue Dec 03, 2013 7:28 pm

How can we make facebook like button to show a image from the topic when you like a topic ? Can that be done ?
https://www.cumseface.eu , We have tutorials for everything / Te ajutam se te descurci singur .

forforce
Registered User
Posts: 323
Joined: Fri Oct 04, 2013 7:57 am
Contact:

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by forforce » Wed Dec 04, 2013 8:46 pm

Anybody ?
p.s. Beside the image problem , as I see now, the url from the liked topic seems to be rewrited too , in a bad way, instead of looking like this: http://www.cumseface.eu/viewtopic.php?t=88 , it`s looking like this: http://www.cumseface.eu/viewtopic.php?t ... n_ref_map=[]

Can this problem be solved ? Thanks in advance.
https://www.cumseface.eu , We have tutorials for everything / Te ajutam se te descurci singur .

User avatar
ViolaF
Registered User
Posts: 1446
Joined: Tue Aug 14, 2012 11:52 pm

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by ViolaF » Thu Dec 05, 2013 1:20 pm

http://stackoverflow.com/q/11528701
http://stackoverflow.com/a/15267462

See also image example from
viewtopic.php?f=72&t=2120397&start=15#p13153013

Code: Select all

<meta property="og:image" content="http://www.YOUR-BOARD-URL-HERE.COM/images/example.png" />
so only the phpbb3-part is left, to figure out, how to get the image-lnk in post
(i think only one image eg. the-first is possible?) - i dont know facebook at all..

User avatar
Neuropass
Registered User
Posts: 1158
Joined: Fri Apr 17, 2009 2:02 pm
Location: SciTE4AutoIt3

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by Neuropass » Sat Dec 14, 2013 2:33 am

Hi,

is this still supported/maintained? if so, how stable is it for a live board?

forforce
Registered User
Posts: 323
Joined: Fri Oct 04, 2013 7:57 am
Contact:

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by forforce » Sat Dec 14, 2013 9:59 pm

Stable for me on v. 3.0.12 . working good till now. But still it has some bugs.
https://www.cumseface.eu , We have tutorials for everything / Te ajutam se te descurci singur .

rakista
Registered User
Posts: 1
Joined: Sat Dec 21, 2013 11:20 am

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by rakista » Sat Dec 21, 2013 11:27 am

Hello!

I installed this mod in my forum but I can't make it work.. Here is the error when I clicked the "log in with FB" button. "Invalid App ID: 0"

Hoping for your response. Thanks! ;)

User avatar
robra
Registered User
Posts: 147
Joined: Thu Dec 09, 2010 2:09 am
Location: Brazil

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by robra » Sun Dec 22, 2013 12:33 am

Hi, mjimeyg.

I am installing the alternatelogin-2013.08.04.01 version in my phpBB 3.0.12 version using the last version of AutoMOD, but some problems exist:
1- On pages of index, login and register, the image of facebook button is broken. See below:
Image
Image
Image

2- When I click on the broken image of facebook button, I am redirected to the facebook login page:
Image
After enter with the login and password, I see this facebook page...
Image
...and after I click on "OK" button, I am redirected to panel page with this message error:
Image
"An error occured attempting to retrieve an access token."

Below is my facebook API and my ACP CONSOF facebook settings:
Image
Image

I don't know where and what I am missing.

Thank you for any help. :roll:

Clenzowen
Registered User
Posts: 30
Joined: Sun Jan 09, 2011 3:50 pm

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by Clenzowen » Wed Dec 25, 2013 7:41 pm

merci de supprimer ce message


thank you to delete this message

User avatar
mjimeyg
Registered User
Posts: 840
Joined: Sat Aug 29, 2009 7:38 pm
Location: London

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by mjimeyg » Sat Jan 11, 2014 6:07 am

First of all, my apologies to everyone who asked a question and didn't get a response. For some reason the phpBB seems to only send me notifications some of the time.

Anyway, I will attempt to answer the questions posed in this post.
forforce wrote:Good idea, now testing :) , thanks.
edit: ok , I think it`s working , one more thing :) . I found a bug, when I log in from forum and try to acces social options from UCP , I get redirected to home page, If I log in with facebook, I can acces it.(It would be nice to be hidden if you are not logged in with facebook).
p.s. On like button from topic, how can I make it to show the 1st picture from that topic on facebook wall when someone click on like and how can I remove url ,(to be hidden when showing on facebook wall) , And If it would be possible, how can I make it to show the 1st sentence from the topic I like instead of website description ? Thank you all for answers.
edit 2: Can you add google+ and only Google+ login to be near Facebook login , and google+ like button for topics as well ?
The bug that redirects you must be something to do with either the board you installed it on or how you installed it. Also check that you are using the latest version as I think that was a bug in previous versions.

As for the picture showing when clicking Facebook Like button, are you talking about a picture in the post of the user's avatar?

Either way it would involve altering the Facebook meta data in the page header so that the picture tag holds the value you want.

The same process is necessary to make it show the first sentence except you need to edit the description tag.

I don't think you can make it hide the url but I might be wrong, I will look into it.

Google and Google+ are a part of the OpenID section. You would need to edit the jquery plugin for that.

To center a like button I think you can just encase it in '<center>' tags.
maxlinux2000 wrote:Please note this bug

Image

Image

This occurs in a phpbb3.0.11 with installed and configured wp-united

version of alternatelogin MOD, used: alternatelogin-2013.08.04.01.zip
The error doesn't give any details and the action be performed when the error occurred is a simple one. You will need to check that the paths on your board are the same as on a standard installation.
Sir Charles wrote:Hi all,

I have a problem which I can't solve for myself. In my forums I had the Version 2012-02.12.01 installed and everything worked fine. Some months ago, this changed and I hoped through updating the mod, this problem would be resolved. Well, I ran into problems with deleting useless code from the files for upgrading to version 2013.08.04.01, but the essential problem wasn't solved:

When someone comes newly to the forum (not registered), opening the index-page is not possible. Nearly immediately you are redirected to the Login page of Facebook.

Please see for yourself: http://debuetanten.at/phpBB3/index.php or http://debuetanten.at and then clicking on "Forum".

I guess, something is interfering with the old version of the mod as a antother forums modified with this mod worked without any problems...

Any help would be appreciated :)
Did you manage to fix this problem? I tried your forum and it worked for me.
rainy1 wrote:Hi all

I have some question about facebook login
my forum is here: http://hkgames.org/forum

When i Login with facebook account which email are XXX@yahoo.com.hk then it show
"You have been successfully logged in!" And Redirect to home page and still showing as a unlogged in user.

When i login with facebook account whcih email are XXX@yahoo.ca, All things goes well!
I have searched for few hours and i don't know what is going on.
May you help me?
Are you using the same computer and browser for both emails? It sounds like it might be a problem with your cookies or cached pages.
ViolaF wrote:http://stackoverflow.com/q/11528701
http://stackoverflow.com/a/15267462

See also image example from
viewtopic.php?f=72&t=2120397&start=15#p13153013

Code: Select all

<meta property="og:image" content="http://www.YOUR-BOARD-URL-HERE.COM/images/example.png" />
so only the phpbb3-part is left, to figure out, how to get the image-lnk in post
(i think only one image eg. the-first is possible?) - i dont know facebook at all..
I will use this to try and alter the like button posts.
rakista wrote:Hello!

I installed this mod in my forum but I can't make it work.. Here is the error when I clicked the "log in with FB" button. "Invalid App ID: 0"

Hoping for your response. Thanks! ;)
Did you check to see if the App Id was actually being stored in the ACP?
Questions answered via forums only, no pms or emails. Thank you.

ConSof Alternate Login for phpBB

Image Image

User avatar
mjimeyg
Registered User
Posts: 840
Joined: Sat Aug 29, 2009 7:38 pm
Location: London

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by mjimeyg » Sat Jan 11, 2014 6:15 am

robra wrote:Hi, mjimeyg.

I am installing the alternatelogin-2013.08.04.01 version in my phpBB 3.0.12 version using the last version of AutoMOD, but some problems exist:
1- On pages of index, login and register, the image of facebook button is broken. See below:
Image
Image
Image

2- When I click on the broken image of facebook button, I am redirected to the facebook login page:
Image
After enter with the login and password, I see this facebook page...
Image
...and after I click on "OK" button, I am redirected to panel page with this message error:
Image
"An error occured attempting to retrieve an access token."

Below is my facebook API and my ACP CONSOF facebook settings:
Image
Image

I don't know where and what I am missing.

Thank you for any help. :roll:
It looks like the Mod didn't install properly. Check for conflicts with other mods.
Questions answered via forums only, no pms or emails. Thank you.

ConSof Alternate Login for phpBB

Image Image

User avatar
mjimeyg
Registered User
Posts: 840
Joined: Sat Aug 29, 2009 7:38 pm
Location: London

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by mjimeyg » Sun Feb 09, 2014 6:45 am

The latest version of Alternate Login is now available.

This version now exchanges the Facebook Access Token for an extended token which lasts 60 days. It stores it in the Users Table.

There are new features that allow users to send their posts to their Facebook Status, Invite their Facebook friends and for Administrators to set new topics to be posted to their Facebook Page.

You can download it here: http://sourceforge.net/projects/alterna ... p/download
Questions answered via forums only, no pms or emails. Thank you.

ConSof Alternate Login for phpBB

Image Image

bikempire
Registered User
Posts: 3
Joined: Mon Feb 24, 2014 4:31 pm

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by bikempire » Mon Feb 24, 2014 4:36 pm

Hi everyone, I've just installed alternate log in and everything looked like working but when I got into a topic it gives the following error:

Code: Select all

Error General
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 [1064]

SQL

SELECT user_avatar_type, user_avatar FROM (phpbb_users u) WHERE u.user_id = 

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/includes/hooks/hook_alternatelogin.php
LINE: 59
CALL: dbal_mysqli->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: CSAlternateLogin::page_header()

FILE: [ROOT]/includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: [ROOT]/includes/functions.php
LINE: 4955
CALL: phpbb_hook->call_hook()

FILE: [ROOT]/includes/session.php
LINE: 1829
CALL: phpbb_user_session_handler()

FILE: [ROOT]/viewtopic.php
LINE: 363
CALL: user->setup()
In the installation process everything went OK. Hope you can help me out. Thanks.

EDIT: I just relized that it only happens when the thread is a Global thread, in regular and fixed threads everything works ok

User avatar
mjimeyg
Registered User
Posts: 840
Joined: Sat Aug 29, 2009 7:38 pm
Location: London

Re: [RC]AlternateLogin(Windows Live,Facebook,OpenID)

Post by mjimeyg » Tue Feb 25, 2014 5:24 pm

bikempire wrote:Hi everyone, I've just installed alternate log in and everything looked like working but when I got into a topic it gives the following error:

Code: Select all

Error General
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 [1064]

SQL

SELECT user_avatar_type, user_avatar FROM (phpbb_users u) WHERE u.user_id = 

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()

FILE: [ROOT]/includes/hooks/hook_alternatelogin.php
LINE: 59
CALL: dbal_mysqli->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: CSAlternateLogin::page_header()

FILE: [ROOT]/includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: [ROOT]/includes/functions.php
LINE: 4955
CALL: phpbb_hook->call_hook()

FILE: [ROOT]/includes/session.php
LINE: 1829
CALL: phpbb_user_session_handler()

FILE: [ROOT]/viewtopic.php
LINE: 363
CALL: user->setup()
In the installation process everything went OK. Hope you can help me out. Thanks.

EDIT: I just relized that it only happens when the thread is a Global thread, in regular and fixed threads everything works ok
Thanks for finding this, I was able to replicate it and I believe I have fixed it:

Find the $sql array at around line 34 in hook_alternatelogin.php and replace it with the following:

Code: Select all

$sql_array = array(
				'SELECT'		=> '*',
				'FROM'			=> array(POSTS_TABLE => 'p'),
				'WHERE'			=> 'p.topic_id = ' . $topic_id,
				'ORDER_BY'		=> 'p.post_id'
			);
An update is now available: http://sourceforge.net/projects/alterna ... p/download
Questions answered via forums only, no pms or emails. Thank you.

ConSof Alternate Login for phpBB

Image Image

Locked

Return to “[3.0.x] Abandoned MODs”