[ABD] Demon Chat

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Tue Mar 29, 2011 11:17 pm

From what I've seen, it's been stable in the last couple of versions. I still have some big bugs to work out, one of which is fixed (sound not playing) and I'm working on a couple others. I'd recommend waiting for the next version before I went live, but if you are just wanting to test the MOD for right now, go ahead and download and install it. If you find any bugs or have any suggestions, please let me know.

~n00b~
Registered User
Posts: 2
Joined: Tue Mar 29, 2011 11:50 pm

Re: [DEV] Demon Chat

Post by ~n00b~ » Tue Mar 29, 2011 11:55 pm

Demon Chat installed without a problem, however clicking send does not add a post.
Furthermore, if I add a row to the phpbb_chat_messages table in my database, the post shows up but the delete/ban links do nothing.
Also, I briefly tried adding a password protected channel but it does not ask for a password when changing to that channel.
I also had to add CHAT_DISABLED in the language file.
:?

kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Wed Mar 30, 2011 11:12 pm

That almost sounds like demon_chat.js isn't getting linked in the page for whatever reason. Does the chat stol update like it should? Also, the CHAT_DISABLED language issue will be fixed in the next update.

~n00b~
Registered User
Posts: 2
Joined: Tue Mar 29, 2011 11:50 pm

Re: [DEV] Demon Chat

Post by ~n00b~ » Thu Mar 31, 2011 1:38 am

I found the issue... I set the "Enable sound" setting to No right off the bat.
Changing that to Yes fixed the problem.

Also, I cannot delete/ban via the archive. The buttons show up but do nothing. :cry:
And do posts in channels with passwords not go in the archive?

User avatar
Hero Factory
Registered User
Posts: 11
Joined: Tue Mar 29, 2011 12:07 pm
Location: Türkiye

Re: [DEV] Demon Chat

Post by Hero Factory » Fri Apr 01, 2011 1:39 pm

Thanks but ı will give some advice for this mod:

First=>İf you add Open/Close button, it will be better ;)

Second=>Add buttons(Bbcode...) down ;)

Thanks =)

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [DEV] Demon Chat

Post by superj707 » Sat Apr 02, 2011 9:35 pm

I know you are busy fixing the sound issue but quickly could you tell me how to adjust the time the font color hold cookie lasts?

users are saying it expires to quickly. They would like to save font color like a month.

kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Sun Apr 03, 2011 12:52 am

I don't actually have a time set for that cookie so it is a session cookie that gets deleted when the browser exits. This is the line you will be looking for:

Code: Select all

jQuery.cookie(\'chatColorHold\', \''+color+'\');
Please note that this isn't the full line

You will want to replace that with something like this:

Code: Select all

jQuery.cookie(\'chatColorHold\', \''+color+'\', {expires: 7});
The value of the expires option is the number of days, so in my above code, the cookie will expire in 7 days.
Hero Factory wrote:First=>İf you add Open/Close button, it will be better ;)

Second=>Add buttons(Bbcode...) down ;)
1. I'm going to be implementing this but I want to get the remaining bugs fixed first.
2. Are you referring to a dropdown style feature? Like how it works in mchat?

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [DEV] Demon Chat

Post by superj707 » Sun Apr 03, 2011 5:34 pm

well I found the code you sugggested in demonchat.js I change it out with no effect
Also in the blow screen shot you can see two problems. After some time the bbcode for color doesn't parse.
Also the message highlighted in yellow has the WRONG time. It was posted the same time user with green name said "no" 10:34 AM

Image

kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Mon Apr 04, 2011 12:39 am

superj707 wrote:After some time the bbcode for color doesn't parse.
Also the message highlighted in yellow has the WRONG time. It was posted the same time user with green name said "no" 10:34 AM
Do you know roughly how long it took before the bbcode color stopped parsing and did it give any errors? Also did these problems exist before or after you change the jquery cookie setting?

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [DEV] Demon Chat

Post by superj707 » Mon Apr 04, 2011 7:58 pm

kmklr72 wrote:
superj707 wrote:After some time the bbcode for color doesn't parse.
Also the message highlighted in yellow has the WRONG time. It was posted the same time user with green name said "no" 10:34 AM
Do you know roughly how long it took before the bbcode color stopped parsing and did it give any errors? Also did these problems exist before or after you change the jquery cookie setting?
they existed before I changed the cookie.
I guess it just takes a few hours.

kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Thu Apr 07, 2011 6:56 pm

Do you know if this problem started recently or has it been happening since you updated? Also, what browser are you using when this happens, and has anyone else on your site reported this issue?

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [DEV] Demon Chat

Post by superj707 » Sun Apr 10, 2011 4:00 pm

kmklr72 wrote:Do you know if this problem started recently or has it been happening since you updated? Also, what browser are you using when this happens, and has anyone else on your site reported this issue?
lots of people have reported the issue. I don't know when it started. I do know that I am using firefox though.

User avatar
Jamy
Registered User
Posts: 429
Joined: Mon Mar 24, 2003 12:02 pm
Location: Mississippi

Re: [DEV] Demon Chat

Post by Jamy » Sun Apr 10, 2011 8:32 pm

I just installed demon_chat2.2 and the best I can tell all works fine except that Im running it with social network and in the chat room itself the social network chat says chat undefined. I removed demon chat from the forums index so the social network chat would work there. but it's not really a big deal cause if your in the chat room what good is the other chat system anyway?

wonderland2001
Registered User
Posts: 11
Joined: Mon Apr 11, 2011 6:42 pm

Re: [DEV] Demon Chat

Post by wonderland2001 » Mon Apr 11, 2011 7:14 pm

Hi,

i got some problem with your chat module.
When i place your files on the root he give me this erro:

Code: Select all

 [phpBB Debug] PHP Notice: in file /includes/functions. php on line 4505: Cannot modify header information - headers already sent by (output started at /language/nl_x_forma l/common.php:1)[phpB B Debug] PHP Notice: in file /includes/functions. php on line 4507: Cannot modify header information - headers already sent by (output started at /language/nl_x_forma l/common.php:1)[phpB B Debug] PHP Notice: in file /includes/functions. php on line 4508: Cannot modify header information - headers already sent by (output started at /language/nl_x_forma l/common.php:1)[phpB B Debug] PHP Notice: in file /includes/functions. php on line 4509: Cannot modify header information - headers already sent by (output started at /language/nl_x_forma l/common.php:1)


I haven't yet install the chat module, only copy the files

I use a rockthemes phpbb style


thanks for the help
regard,
Jacky

kmklr72
Registered User
Posts: 477
Joined: Sat Dec 29, 2007 9:37 pm
Location: St. Louis, USA
Name: Kevin

Re: [DEV] Demon Chat

Post by kmklr72 » Mon Apr 11, 2011 11:10 pm

Enable DEBUG and DEBUG_EXTRA in config.php and give me the errors that pop up. You should get more information (specifically where the error is) with debugging enabled. Also, are you browsing to chat.php without having first done the code edits and run the installer?

Locked

Return to “[3.0.x] Abandoned MODs”