Page 33 of 52

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Sat Mar 19, 2011 1:00 am
by 4_seven
if you setup all right (incl. config-file), it should appear. if not, your board don't supports fopen() or other unknown reason.

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Sat Mar 19, 2011 2:01 am
by Volksdevil
Apologies but I may just be getting confused...

It shows within forum sections like this>>> http://www.volksdevil.com/forum/viewforum.php?f=6

But not on the index? I didn't see any edits for the index page, so I'm guessing you mean forum sections by saying forum index?

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Sat Mar 19, 2011 11:48 am
by 4_seven
Yes. It means forum index, as you see in demo..

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Sat Mar 26, 2011 5:50 pm
by Eragon
How can I use this modification in the custom pages ?

thanks for reply

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Sat Mar 26, 2011 8:33 pm
by 4_seven
just implement it. i think, it should not be that hard. i have no time for those codings..

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Wed Apr 27, 2011 6:25 pm
by inikad
Hi, :)

Could it be possible to delete automaticaly the old thumbnail when image in first topic is replaced by another one (using the same thumb id to replace it for example), instead of to create a new thumbnail and to let the older in img_thumbs folder?

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Wed Apr 27, 2011 7:32 pm
by murdmon
was wondering if it was possible to put this mod as an add on to

Top Topics 1.3 by Kamahl19
http://www.phpbb.com/community/viewtopi ... &t=1692895

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Wed Apr 27, 2011 7:49 pm
by 4_seven
inikad wrote:Could it be possible to delete automaticaly the old thumbnail when image in first topic is replaced by another one (using the same thumb id to replace it for example), instead of to create a new thumbnail and to let the older in img_thumbs folder?
An orphan-module (like in acp for [attachment]s) and an auto-delete module is planned for the next versions.

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Wed Apr 27, 2011 7:51 pm
by 4_seven
murdmon wrote:was wondering if it was possible to put this mod as an add on to

Top Topics 1.3 by Kamahl19
http://www.phpbb.com/community/viewtopi ... &t=1692895
If i have time for extra tours the next months and it give coins for that, than yes.

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Wed Apr 27, 2011 7:59 pm
by inikad
4_seven wrote:
inikad wrote:Could it be possible to delete automaticaly the old thumbnail when image in first topic is replaced by another one (using the same thumb id to replace it for example), instead of to create a new thumbnail and to let the older in img_thumbs folder?
An orphan-module (like in acp for [attachment]s) and an auto-delete module is planned for the next versions.
Oki, thanks. :)

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Fri Apr 29, 2011 10:30 pm
by ekamei
This mod is pretty nice, definitely keep in touch on this one.

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Tue May 03, 2011 10:11 am
by nuxtovios
After installing the mod a have only images for attachments and no for images posted [img]
What I'm doing wrong?
SMTP / cURL / PHP Sockets on my hosting plan are off


My config file: first_x_in_forum_index_config.php

Code: Select all

<?php
/**
*
* @package First Topic [pic] on Forum Index  v.0.0.6
* @version $Id: first_x_in_forum_index_config.php 2356 2356 2010-11-04 12:00:17Z 4seven $
* @copyright (c) 2010 / 4seven
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
*
*/

/**
* @ignore
*/
if (!defined('IN_PHPBB'))
{
	exit;
}
	
// First Topic [pic] on Forum Index  / 4seven / 2010
//----------------SETTINGS - START -------------------
//------------------------------------------------------------
//----------BASIC-SETTINGS----------------

// set function-mode of mod:

$function_mode = 'img';

// enter as given: img,  attachment or mix (first come - first serve)
// $display_priority = 'img';  // later

//--------------------------------------------------------------

// make your  desired settings here

$width_or_height_img  = 'mix';

// enter as given: width, height or mix 
// explanation of mix: centered cropped  pic with exact squared fit

//--------------------------------------------------------------

// make the setting of max thumb-size in px here 
// counts for width, height or mix

$convert_max_size = 80;

// don't make it to big ;)

//--------------------------------------------------------------

// activate the display of an "no [img] pic" 
// but, before u activate this > make a pic and save it  
// with the size of $convert_max_size and correct fit (given by $width_or_height_img )
// name it no_img.jpg and load it up to images/img_thumbs

$no_pic_img = 'no';

// enter as given: yes or no

//--------------------------------------------------------------

// placeholder with perfect fit, instead of "no [img] pic"
// if $no_pic_img = 'no' and $no_img_placeholder = 'no'  > the topic title fit is shown in standard phpbb3 mode
// hint: only active if $no_pic_img = 'no'

$no_img_placeholder = 'no';

// enter as given: yes or no 

//--------------------------------------------------------------

// colour of border around thumb and "no [img] pic"

$border_color = '#F6F4D0';

// enter in HEX eg. '#F6F4D0' (for prosilver) or 'lightgray' or 'transparent'  (no border)

//--------------------------------------------------------------

// activate this mode for showing thumbs in search.php 
// (Search Results,View unanswered posts, View active topics etc.)

$active_4_search = 'yes';

// enter as given: yes or no

//--------------------------------------------------------------

// ----------------[img] SETTINGS--------------------

// ------------[attachment] SETTINGS---------------

// enter here the forum id's that will show thumbing  of [attachment]

$affected_forum_att	= array(4,7,9); 

// enter as given: (7,8,9) 

//--------------------------------------------------------------

// enter here the forum id's that will show thumbing  of [img]

$affected_forum_img	= array(1,2,3,4,5,6,7,8,9); 

// enter as given: (7,8,9) 

//--------------------------------------------------------------
//----------------SETTINGS - END -------------------
// First Topic [pic] on Forum Index  / 4seven / 2010
?>
Style Used Dirtyboard
Files that I edited

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Tue May 03, 2011 11:31 am
by 4_seven
Have no time to check all your code. Also this is a unsupported Style.
But this i can say with a short look:

check via ftp the right chmod of folder images/img_thumbs (should be chmod 077 or min. 0755)
if this is given, check if files are present in this folder.

if not, than turn debug-mode on in config.php

find

Code: Select all

// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);          
replace with

Code: Select all

@define('DEBUG', true);
@define('DEBUG_EXTRA', true); 
check if any error-message appears. and post it here. if no error is give and you checked the whole install "by hand " again, then it seems that the img are uploaded on a protected server.
first post wrote:Note:
- No display of protected remote pics
in this case check it on another image hoster (may testwise http://www.loaditup.de (which works 100%))
and make a fresh topic with an image in first post in this style

Code: Select all

[img]http://www.imagehoster.com/pics/yourpic.jpg[/img]
Note: [img] with

Code: Select all

[img]http://www.imagehoster.com/pics/file.php?pic_id=33542[/img]
or similar don't work

if nothing helps, make a test-install on a fresh testboard on your server with standard style (prosilver)

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Thu May 05, 2011 11:42 am
by nuxtovios
images/img_thumbs is chmod 777

there are no files in this folder

img are uploaded on unprotected servers

imgs are posted in this style

Code: Select all

[img]http://www.imagehoster.com/pics/yourpic.jpg[/img]
didnt try test-install on a fresh testboard yet.

My error message off debug:

Code: Select all

Session IP/browser/X_FORWARDED_FOR check failed
»User IP “79.130.39” checked against session IP “87.202.181”, user browser string “mozilla/5.0 (windows nt 6.0) applewebkit/534.24 (khtml, like gecko) chrome/11.0.696.60 safari/534.24” checked against session browser string “mozilla/5.0 (windows nt 6.0) applewebkit/534.24 (khtml, like gecko) chrome/11.0.696.60 safari/534.24” and user X_FORWARDED_FOR string “” checked against session X_FORWARDED_FOR string “”.

Re: [DEV] First Topic [pic] on Forum Index v.0.0.6

Posted: Thu May 05, 2011 5:45 pm
by 4_seven
ACP > GENERAL > Security settings >

Code: Select all

Validated X_FORWARDED_FOR header
Sessions will only be continued if the sent X_FORWARDED_FOR header equals the one sent with the previous request. Bans will be checked against IPs in X_FORWARDED_FOR too.
No [x]
images/img_thumbs is chmod 777

there are no files in this folder
Seems there is fopen() disabled on your server
first post wrote:Requirements: fopen()
Other possible reasons:
- wired or forbidden path
- kind of restriction