[ABD] Last X [img] on Forum v.0.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
diogo_bc
Registered User
Posts: 5
Joined: Thu May 27, 2010 5:21 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by diogo_bc »

Hello! What a great Mod !! Congratulations..

I Would like to know if it can`t show the last Attachment Images??

Only the ??

Thank you!
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

for [attachment] take this...

[DEV] Last X [attachments] on Forum v.0.0.4
http://www.phpbb.com/community/viewtopi ... 25&start=0
Current Mods | Mod Base | php(BB) programming | No help via PM
ergoproxi
Registered User
Posts: 8
Joined: Sun May 23, 2010 3:39 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by ergoproxi »

on my forums we use the gallery system, so most uploaded images posted with the [IMG] tags have urls like this:
image.php?album_id=58&image_id=2158

Can someone please help me?
Is there any way for me to adjust the code so i can display those?

cheers

i looked into the SEO mod that would change the galley images URL (would need to install 4 mods for this), however SEO mod is not working with my forums

Thank you
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

only real jpg, png, gif..
http://www.mypics.com/folder/image.jpg
http://www.mypics.com/folder/image.png
http://www.mypics.com/folder/image.gif
.. will work.

no http://www.mypics.com/folder/file.php?bla_bla_id_123
no http://www.mypics.com/folder/image.php?bla_bla_id_123

Shure i could transform my mod, so it work with gallery.
But i don't use the gallery and have no clue about the syntax
and have no time to install and configure it only for transforming.
Current Mods | Mod Base | php(BB) programming | No help via PM
abdul_sma
Registered User
Posts: 6
Joined: Thu Jun 03, 2010 12:34 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by abdul_sma »

Hi
this is a great mod and it is working fine for me.
i have also installed the First Topic [pic] on Forum Index v.0.0.5.a mod (which is also a great one)

http://www.phpbb.com/community/viewtopi ... &t=1953215
My question is i dont want the last X img to be displayed. instead i want the first topic pic which is downloaded in the First Topic mod to be displayed in this mod in the index.
hope i have explained it clearly.
can you please help me on doing that
thelahera
Registered User
Posts: 24
Joined: Fri Jul 10, 2009 12:47 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by thelahera »

hello,
i don't want the mod to make thumbnails for my existing posts. I want only the new posts to be handled by this MOD please tell me how can i do that?

Thank You. :idea:

PS: also i want to know how to put this MOD in viewtopic :idea:
User avatar
onelazyguy
Registered User
Posts: 63
Joined: Sat Oct 02, 2010 2:55 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by onelazyguy »

4_seven,

How do I modify this so that it would only pull the first img of a new topic and display it?

Code: Select all

$sql_img = 'SELECT p.post_text, p.topic_id, p.post_time, p.post_id, p.post_time, f.forum_id, t.topic_id, t.forum_id, t.topic_title
from ' . POSTS_TABLE . ' p, ' . FORUMS_TABLE . ' f, ' . TOPICS_TABLE . ' t 
WHERE p.post_text LIKE "[img:%]%[/img:%]"
		AND f.forum_id = ' . $forum_id . '
		AND p.topic_id = t.topic_id
		AND ' . $db->sql_in_set('t.forum_id', $forumz_ary) . '
		AND t.forum_id IN (' . $forumz . ')
		ORDER BY post_id DESC';	
$result_img = $db->sql_query_limit($sql_img, $convert_real_img_size);
thank you...great mod in deed
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

find

Code: Select all

		AND p.topic_id = t.topic_id
after add

Code: Select all

		AND p.post_id = t.topic_first_post_id
find

Code: Select all

      ORDER BY post_id DESC'; 
replace with

Code: Select all

      ORDER BY post_id ASC'; 
Current Mods | Mod Base | php(BB) programming | No help via PM
gennyna
Registered User
Posts: 72
Joined: Mon Apr 06, 2009 7:29 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by gennyna »

I installed this mod, as soon as I finish all the changes and uppo files via ftp I get stuck around the site and I do not surf ..
Is there a way to solve?
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

I get stuck around the site and I do not surf
i do not fully understand, but it seems, that it not works for you. so check all edits again, give the right chmod to the named image thumb folder and make all settings right in config-area of this mod.
Current Mods | Mod Base | php(BB) programming | No help via PM
thelahera
Registered User
Posts: 24
Joined: Fri Jul 10, 2009 12:47 pm

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by thelahera »

4_seven wrote:find

Code: Select all

		AND p.topic_id = t.topic_id
after add

Code: Select all

		AND p.post_id = t.topic_first_post_id
find

Code: Select all

      ORDER BY post_id DESC'; 
replace with

Code: Select all

      ORDER BY post_id ASC'; 
a little problem here..
this pulls all the img s in first post.. not the first img
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

shure, then put only one img in first post.
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
onelazyguy
Registered User
Posts: 63
Joined: Sat Oct 02, 2010 2:55 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by onelazyguy »

one img does not work either...it takes like 3-5 minutes to load and after loading is done, it spits out an sql error.

what i'm looking for from this mod is the ability to pull the first image from a newly created topic only not post and display it..not take all images from a newly created topic and display them all..

I tried a forum with topics that only has 1 img and I config it to show 10 imgs but it only show couple of imgs not 10 and some imgs are duplicate of each other..in other word, same imgs are display multiple times instead just one img

hope you can figure it out
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by 4_seven »

the above code is completely untested, bcs. i have no time to test this out.
if i have time in the next weeks, i take a look.
further the standard intention of this mod is "Last X [img] on Forum".
Current Mods | Mod Base | php(BB) programming | No help via PM
User avatar
onelazyguy
Registered User
Posts: 63
Joined: Sat Oct 02, 2010 2:55 am

Re: [DEV] Last X [img] on Forum v.0.0.2

Post by onelazyguy »

further the standard intention of this mod is "Last X [img] on Forum".
absolutely understandable and thank you for your mod!

It is just my request and if you have time. It would be nice that you can take your mod "First Topic [pic] on Forum Index v.0.0.6" and take the thumbs and display them like your Last X [img] on Forum.
Locked

Return to “[3.0.x] Abandoned MODs”