[ABD] Smixmods Feed News Center v0.4.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Smix » Thu May 23, 2013 6:57 pm

Hello,
@Tomala
you probably didn't run the install file located in /contrib/ directory ;-) This mod is not yet prepared for Automod/Umil installations. Copy the file to your phpbb/root/contrib and run it ;)

@Sajaki
Thank you very much! I really appreciate your work and thank you! But at this moment, I´m not yet decided if it's the time for adding any new features, including umil, because the code is still in development and I don´t want to add new features while the core is not as much stable as I want. Anyway, I'll check out your work deeply than I'll decide ;) Anyway, thank you very much again! :)

Tomala
Registered User
Posts: 7
Joined: Tue Jul 10, 2007 10:51 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Tomala » Fri May 24, 2013 8:43 am

Thank you for your reply. :) I'm not sure how I missed the installer. I'll give it another go on my test board. :D

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Solidjeuh » Fri May 24, 2013 1:07 pm

Yes! I was waiting for this update!
Finally I can put the local news rss back on my forum! :D

But I have one little question, The feed description is a bit short.. Can I change the amount of characters somewhere?
I don't suffer from insanity. I enjoy every minute of it.

X85301
Registered User
Posts: 7
Joined: Wed Apr 17, 2013 5:52 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by X85301 » Fri May 24, 2013 2:04 pm

Solidjeuh wrote:Yes! I was waiting for this update!
Finally I can put the local news rss back on my forum! :D

But I have one little question, The feed description is a bit short.. Can I change the amount of characters somewhere?
i guess this depends of the newsfeed himself, and has nothing to do with the MOD ?

User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Solidjeuh » Fri May 24, 2013 3:17 pm

X85301 wrote:
Solidjeuh wrote:Yes! I was waiting for this update!
Finally I can put the local news rss back on my forum! :D

But I have one little question, The feed description is a bit short.. Can I change the amount of characters somewhere?
i guess this depends of the newsfeed himself, and has nothing to do with the MOD ?
Yeah I see it now.. Stupid me :lol:
I don't suffer from insanity. I enjoy every minute of it.

Tomala
Registered User
Posts: 7
Joined: Tue Jul 10, 2007 10:51 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Tomala » Tue May 28, 2013 7:57 am

Got this up and running perfectly on my test board, and the install to my main board was a success. :D

User avatar
Nachtschade
Registered User
Posts: 107
Joined: Thu Nov 15, 2012 12:29 am
Location: Netherlands
Name: Marcel

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Nachtschade » Wed Jun 05, 2013 4:14 pm

I've installed this using automod. After adding the modules when I go to the .mods tab I get the following error:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Table 'my_user_name_bb1.bb_sfnc_feeds' doesn't exist [1146]

SQL

SELECT id, feed_name, url, feed_type, next_update, last_update, refresh_after, available_feed_attributes, available_item_attributes, encoding, enabled_posting, enabled_displaying, template_for_displaying, template_for_posting, poster_id, poster_forum_destination_id, poster_topic_destination_id, posting_limit FROM bb_sfnc_feeds WHERE 1 ORDER BY id ASC

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_sfnc.php
LINE: 47
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_sfnc->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
Any help?
..vaak rankend of klimmend..

2faroffroad
Registered User
Posts: 18
Joined: Wed Feb 27, 2013 12:47 am

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by 2faroffroad » Sun Jun 23, 2013 12:37 am

hi. nice mod
is there any way to put a [html] [/html] bbcode before and after the message post so I do not have to worry about the html-to-bbcodes process... It does not seem to work anyways and will not work with tables and other things.


I'm using ATOM feed setting.
This would help fix the issue of editing a post that has HTML inside it as it is gets lost at that point.
Honda Pioneer Forum - http://Hondasxs.com

2faroffroad
Registered User
Posts: 18
Joined: Wed Feb 27, 2013 12:47 am

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by 2faroffroad » Sun Jun 23, 2013 2:15 am

@Nachtschade
Did you run the external installer after u ran the automod installer?
Honda Pioneer Forum - http://Hondasxs.com

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Mess » Mon Jun 24, 2013 7:19 am

2faroffroad wrote:hi. nice mod
is there any way to put a [html] [/html] bbcode before and after the message post so I do not have to worry about the html-to-bbcodes process... It does not seem to work anyways and will not work with tables and other things.


I'm using ATOM feed setting.
This would help fix the issue of editing a post that has HTML inside it as it is gets lost at that point.
There is no [html] bbcode, as that's a huge security risk.

User avatar
Sajaki
Registered User
Posts: 1354
Joined: Mon Mar 02, 2009 1:41 pm
Name: Andreas
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Sajaki » Thu Jun 27, 2013 10:14 am

hi Smix,

The post count of the posting bot does not increment. could you fix that please?

example: if you look at http://www.bbdkp.com/viewforum.php?f=85 and at the profile of the posting bot i created it still has a post count of 0.

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Mess » Thu Jun 27, 2013 12:47 pm

I am still very much looking forward to the post to topic feature. :P

User avatar
1mix
Registered User
Posts: 87
Joined: Sun May 24, 2009 7:21 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by 1mix » Thu Jun 27, 2013 1:07 pm

Mess wrote:I am still very much looking forward to the post to topic feature. :P
Same here..

FoulFoot
Registered User
Posts: 261
Joined: Mon Jun 23, 2003 1:04 am
Location: Honolulu, HI
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by FoulFoot » Fri Jun 28, 2013 1:25 am

OK, I'll take a crack at it --

This code is untested; please back up your originals before editing. It also includes my attempt at a fix for the "has this message been posted before?" problem.

OPEN

Code: Select all

includes/mods/sfnc/sfnc.class.php
FIND

Code: Select all

			// check if this topic is not already posted
			$sql = 'SELECT topic_title
					FROM ' . TOPICS_TABLE . '
					WHERE topic_title = "' . $db->sql_escape($subject) . '"
						AND topic_poster = ' . (int) $this->poster_id;

			$result = $db->sql_query($sql);
			$row = $db->sql_fetchrow($result);
			$db->sql_freeresult($result);

			// Do we have a new item to post ?
			if (strnatcasecmp($row['topic_title'], $subject))
			{
REPLACE WITH

Code: Select all

			// check if this post is already posted
			$sql = 'SELECT post_subject, post_text
					FROM ' . POSTS_TABLE . '
					WHERE post_subject = "' . $db->sql_escape($subject) . '"
						AND poster_id = ' . (int) $this->poster_id;

			$result = $db->sql_query($sql);
			$row = $db->sql_fetchrow($result);
			$db->sql_freeresult($result);

		   // Do we have a new item to post ?  
         // If post subjects match, next check entire message text for a match
			if (strnatcasecmp($row['post_text'], $message))
			{
FIND

Code: Select all

					'topic_id' => 0, //$this->poster_topic_destination_id, // temporarily absolutely disabled
REPLACE WITH

Code: Select all

					'topic_id' => $this->poster_topic_destination_id,
FIND

Code: Select all

				submit_post('post', $subject, $user->data['username'], POST_NORMAL, $poll, $data, true, true);
REPLACE WITH

Code: Select all

				submit_post('reply', $subject, $user->data['username'], POST_NORMAL, $poll, $data, true, true);
OPEN

Code: Select all

adm/style/acp_sfnc.html
FIND

Code: Select all

				<input name="poster_topic_destination_id" id="poster_topic_destination_id" type="text" maxlength="10" value="{POSTER_TOPIC_DESTINATION_ID}" disabled="disabled" />
REPLACE WITH

Code: Select all

				<input name="poster_topic_destination_id" id="poster_topic_destination_id" type="text" maxlength="10" value="{POSTER_TOPIC_DESTINATION_ID}" />
You'll need to create a topic for this to post into, and note the Topic ID # for the feed setting. I also suggest locking the topic (it won't prevent the bot from posting there, just other users).

Let me know if this works!

Foul

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Mess » Sat Jun 29, 2013 10:01 am

Ohhh cool, I test it out as soon as possible.

Locked

Return to “[3.0.x] Abandoned MODs”