[ABD] Smixmods Feed News Center v0.4.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
Smix
Registered User
Posts: 482
Joined: Mon Sep 11, 2006 1:07 am

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Smix » Wed Mar 27, 2013 11:37 am

Hello,
I'd love to get some feedback about the updating from 0.3.x to 0.4.0 with 0.4.0c package, anybody? It' s possibly not working as expected :oops: ...
Workaround still works, remove the phpbb_smixmods_feed_news_center table from database and also please drop all rows related to sfnc from phpbb_config table - It's those : sfnc_download_function, sfnc_cron_init, sfnc_cron_posting, sfnc_index_init, sfnc_index_posting, sfnc_version ... It will make a fresh install ... but in this moment, I'd love to get the update working
Peter77sx & Mess wrote:
camaro92 wrote:Omg.. This is getting worse..
Maybe not a good idea to install a MOD on live board that is in DEV status yet. If it's giving you that much trouble, try waiting till it's in RC or Beta..
His problems are not related to mod itself - adding modules into ACP will always be manual in beta or RC versions and possibly in the final versions (don't quote me in the future :-D ). I'm not using UMIL (or any other modules or software), because I don't want users to require additional phpBB modules for installing this mod and installation of this mod is made as easy as possible and adding modules (basic phpBB task) will possibly always be a manual action.
Anyway, yes, it's not recommended to be installed on a live board.


User avatar
Jessica
Former Team Member
Posts: 4342
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by Jessica » Thu Mar 28, 2013 1:45 am

You could use .MODs as a parent, no need to create a whole new tab, especially if you're planning to install future mods that do need a whole new tab...but I'm glad you got it :]
Pro-choice, Atheist, Pro-LGBT rights
Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 1:50 am

Done!

Ok. So I want to see if this works.. What do I do here to activate it? I don't want to use a CRON but allow the software to do it.
Index init:
If enabled, index.php will init downloading of ONE feed
Disabled Enabled

Index posting:
If enabled, after initiation on index.php, content will be posted to forum
Disabled Enabled

Cron init:
Enable, if you´ll use a CRON job for updating the feeds (update_feeds.php in phpBB ROOT directory). If enabled, index.php will never init downloading or posting of feed and ALL feeds will be updated.
Disabled Enabled

Cron posting:
If enabled, after initiation on cron.php, content will be posted to forum
Disabled Enabled

Download function:
Which function is used to download the feed? (simplexml recommended)
Thanks

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 1:55 am

I also am trying to set it to 15 mins but seems won't save.. Has to be 1hr? I have to wait 1 hour to see it post?

User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by wintstar » Thu Mar 28, 2013 3:59 am

camaro92 wrote:I also am trying to set it to 15 mins but seems won't save.. Has to be 1hr? I have to wait 1 hour to see it post?
How is your php setting from the server?

Code: Select all

allow_url_fopen = ?
allow_url_include = ?

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 4:07 am

Where do I look?

User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by wintstar » Thu Mar 28, 2013 5:52 am

ACP --> System --> GENERAL TASKS --> PHP Information

Look at "Core"

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 6:18 am

Great thanks!

Ok to answer the question

allow_url_fopen = YES
allow_url_include = NO

User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by wintstar » Thu Mar 28, 2013 6:40 am

Look at the picture

Image

If that is set with you, it should work.

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 6:48 am

Excellent! Done.. Do I still need to wait an hour and then on the next hour for it to post? How do I activate it without CRON? Thanks

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 6:50 am

Nevermind WORKS!!!! 5 posts already NICE!!

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 7:05 am

Sent a small donation. Not much but am sure anything is appreciated :-)
I was wondering if there is a changelog? I am curious what was changed from the one I have installed 0.4.0b to the new one I just noticed 0.4.0c

How much is involved to upgrade? Thanks

User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by wintstar » Thu Mar 28, 2013 7:11 am

I have not yet upgraded to 0.4.0c. As for me, the version 0.4.0b works.

camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Re: [DEV] Smixmods Feed News Center v0.4.0

Post by camaro92 » Thu Mar 28, 2013 7:19 am

Was hoping I could copy/paste the entire template
[sfnc_item_title], [sfnc_feed_name], [sfnc_item_link], [sfnc_item_description], [sfnc_item_image], [sfnc_feed_language], [sfnc_feed_copyright], [sfnc_feed_generator], [sfnc_feed_pages], [sfnc_item_guid], [sfnc_item_comments], [sfnc_item_category], [sfnc_item_pubDate], [sfnc_item_comments-url], [sfnc_item_rss-url], [sfnc_item_postid], [sfnc_item_thumbnail]
And see what posts and then determine what i want as I really don't know what these all do. But unfornatly you can't post it

Only
[sfnc_item_title], [sfnc_feed_name], [sfnc_item_link], [sfnc_item_description], [sfnc_item_image], [sfnc_feed_language], [sfnc_feed_copyright], [sfnc_feed_generator], [sfnc_feed_pages], [sfnc_item_guid], [sfnc_item_comments], [sfnc_item_category]
Otherwise you get an error
General Error
SQL ERROR [ mysql4 ]

Data too long for column 'template_for_posting' at row 1 [1406]

SQL

UPDATE phpbb_sfnc_feeds SET feed_name = 'AUTOBLOG.CA', feed_type = 'rss', url = 'http://ca.autoblog.com/category/chevrolet/rss.xml', encoding = 'UTF-8', enabled_posting = 1, enabled_displaying = 0, template_for_posting = '[sfnc_item_title], [sfnc_feed_name], [sfnc_item_link], [sfnc_item_description], [sfnc_item_image], [sfnc_feed_language], [sfnc_feed_copyright], [sfnc_feed_generator], [sfnc_feed_pages], [sfnc_item_guid], [sfnc_item_comments], [sfnc_item_category],[sfnc_item_comments-url], [sfnc_item_rss-url], [sfnc_item_postid], [sfnc_item_thumbnail]\n[sfnc_item_title], [sfnc_feed_name], [sfnc_item_link], [sfnc_item_description], [sfnc_item_image], [sfnc_feed_language], [sfnc_feed_copyright], [sfnc_feed_generator], [sfnc_feed_pages], [sfnc_item_guid], [sfnc_item_comments], [sfnc_item_category]', template_for_displaying = '', poster_id = 12530, poster_forum_destination_id = 56, poster_topic_destination_id = 0, refresh_after = 3600, posting_limit = 9, next_update = 0 WHERE id = 1

BACKTRACE

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_sfnc.php
LINE: 204
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_sfnc->main()

FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()

Locked

Return to “[3.0.x] Abandoned MODs”