[ABD] phpBB Social Network 0.7.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by wintstar » Thu Sep 23, 2010 5:59 am

The Mod not working in Internet Explorer IE8, in Firefox it is all ok

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Thu Sep 23, 2010 6:02 am

I'm using IE 8 here, and it working fine, I think it depend on your settings.

Daniel
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

User avatar
wintstar
Registered User
Posts: 280
Joined: Sat Mar 07, 2009 12:39 pm

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by wintstar » Thu Sep 23, 2010 6:08 am

*Daniel wrote:I'm using IE 8 here, and it working fine, I think it depend on your settings.
Daniel
I think too :?

probably because of my age, I am over 40 :roll:

EDIT
It works, the error was in the language file :D

pickyj
Registered User
Posts: 2
Joined: Fri Jul 30, 2010 6:23 pm
Location: /home/blackhatdbl
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by pickyj » Thu Sep 23, 2010 1:16 pm

Fix for the error:

Code: Select all

?>

$lang = array_merge( $lang, array(    'ACP_IM_MANAGEMENT'            => 'Instant messenger',    'ACP_IM_CONFIGURATION'         => 'IM configuration',    'ACP_IM_SETTINGS'              => 'IM settings',    'ACP_IM_BUTTONS_SETTINGS'      => 'IM buttons settings',    'ACP_IM_PURGING'               => 'IM Purging',    'UCP_IM_MAIN'                  => 'IM chat & User status',    'UCP_IM_MAIN_SETTINGS'         => 'IM main settings',    'UCP_IM_MAIN_USERSTATUS'       => 'IM user status',    'UCP_IM_MAIN_PURGE_MESSAGES'   => 'IM purge messages',    // Confirm boxes    'LOG_IM_PURGE_MESSAGES'        => '<strong>Deleted Instant messenger messages</strong>',    'LOG_IM_PURGE_RECD_MESSAGES'   => '<strong>Deleted Instant messenger recieved messages</strong>',));
Find

Code: Select all

$lang = array_merge( $lang, array( 'ACP_IM_MANAGEMENT' => 'Instant messenger', 'ACP_IM_CONFIGURATION' => 'IM configuration', 'ACP_IM_SETTINGS' => 'IM settings', 'ACP_IM_BUTTONS_SETTINGS' => 'IM buttons settings', 'ACP_IM_PURGING' => 'IM Purging', 'UCP_IM_MAIN' => 'IM chat & User status', 'UCP_IM_MAIN_SETTINGS' => 'IM main settings', 'UCP_IM_MAIN_USERSTATUS' => 'IM user status', 'UCP_IM_MAIN_PURGE_MESSAGES' => 'IM purge messages', // Confirm boxes 'LOG_IM_PURGE_MESSAGES' => 'Deleted Instant messenger messages', 'LOG_IM_PURGE_RECD_MESSAGES' => 'Deleted Instant messenger recieved messages',));
Replace with

Code: Select all


$lang = array_merge( $lang, array(
    'ACP_IM_MANAGEMENT'            => 'Instant messenger',
    'ACP_IM_CONFIGURATION'         => 'IM configuration',
    'ACP_IM_SETTINGS'              => 'IM settings',
    'ACP_IM_BUTTONS_SETTINGS'      => 'IM buttons settings',
    'ACP_IM_PURGING'               => 'IM Purging',
    'UCP_IM_MAIN'                  => 'IM chat & User status',
    'UCP_IM_MAIN_SETTINGS'         => 'IM main settings',
    'UCP_IM_MAIN_USERSTATUS'       => 'IM user status',
    'UCP_IM_MAIN_PURGE_MESSAGES'   => 'IM purge messages',
    // Confirm boxes
    'LOG_IM_PURGE_MESSAGES'        => '<strong>Deleted Instant messenger messages</strong>',
    'LOG_IM_PURGE_RECD_MESSAGES'   => '<strong>Deleted Instant messenger recieved messages</strong>',));

?>
Demo: [removed]
Better?:D (e-mail me [removed], or pm me to my board [removed])
Last edited by camm15h on Thu Sep 23, 2010 1:21 pm, edited 1 time in total.
Reason: Links not required, thanks.

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by keith10456 » Thu Sep 23, 2010 5:43 pm

Which file should the edit(s) be made in and which error are you referring to?

pickyj
Registered User
Posts: 2
Joined: Fri Jul 30, 2010 6:23 pm
Location: /home/blackhatdbl
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by pickyj » Thu Sep 23, 2010 7:40 pm

keith10456 wrote:Which file should the edit(s) be made in and which error are you referring to?
uh, sorry...
/language/en/acp/common.php
Also, crappy code at the end of /includes/costants.php

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Thu Sep 23, 2010 11:58 pm

I found another issue, if you look at my profile: http://prophpbb.atbhost.net/forums/memb ... rofile&u=2 you will see that the layout is crap. Is it suppose to be like that?

Daniel
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Mr. Man!
Registered User
Posts: 109
Joined: Sat Jul 31, 2010 6:05 am
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Mr. Man! » Fri Sep 24, 2010 1:02 am

*Daniel wrote:
M1sT3rM4n wrote:Hi Daniel,

So do I just need to run those queries in SQL and we can call it a day?
As long as you didn't run the installer, you should be fine, but please make a backup first.

Also if your prefix is not phpbb_ then change that to what your using

Also anyone who made the edit posted by WascallyWabbit, can can revert then back, or just re-upload the original files.

One last thing, you need to add the moduals into the UCP and admin panel as well


Daniel
Crap.... but I did. If I uninstall the module, and move all the mod items via FTP, but don't run the installer, will it be ok?

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Fri Sep 24, 2010 2:14 am

M1sT3rM4n wrote:
*Daniel wrote:
M1sT3rM4n wrote:Hi Daniel,

So do I just need to run those queries in SQL and we can call it a day?
As long as you didn't run the installer, you should be fine, but please make a backup first.

Also if your prefix is not phpbb_ then change that to what your using

Also anyone who made the edit posted by WascallyWabbit, can can revert then back, or just re-upload the original files.

One last thing, you need to add the modules into the UCP and admin panel as well


Daniel
Crap.... but I did. If I uninstall the module, and move all the mod items via FTP, but don't run the installer, will it be ok?
You may need to clean your database up. There were mistakes in the installer as well... Some of the table names and values are incorrect.

It not all bad news, you can try my sql (after doing a full backup)

The only thing that I am worried about is

Code: Select all

ALTER TABLE phpbb_zebra ADD approval tinyint(1);
If you run the installer, that may have been done for you already.

Go ahead, edit the files on your computer and upload then via ftp and run the sql.

Once done, just go and add modules by hand

I REPEAT, MAKE A FULL BACKUP FIRST

Daniel
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

Jan Christensen
Registered User
Posts: 140
Joined: Sun May 16, 2004 10:42 am
Location: Denmark

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Jan Christensen » Fri Sep 24, 2010 8:47 am

This MOD could be quite usefull once the bugs are deleted - did any of you find a way to make this MOD work with the gallery MOD?

I have the gallery MOD installed, and the instant messenger bar just won't show.

I tried as Daniel posted, and set everything to "no" in ACP - it didn't solve the problem.

I installed this MOD using the im_install.php file, corrected the issue about the "can not be NULL" as mentioned earlier in this topic. I did not use automod, but edited the files manually and yes, I did check several times that the edits made indeed are correct.

Im sorry if my english is a bit crappy this morning, I have been working with this all night long..

Anyone?
Jan Christensen • Danish language package author • Olympus DK Team

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by keith10456 » Fri Sep 24, 2010 1:53 pm

*Daniel wrote:I found another issue, if you look at my profile: http://prophpbb.atbhost.net/forums/memb ... rofile&u=2 you will see that the layout is crap. Is it suppose to be like that?

Daniel
You need to provide a test login and password.

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Fri Sep 24, 2010 10:57 pm

@pickyj: Thank you for the SQL, this works wonderfully now!

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Sat Sep 25, 2010 2:37 am

keith10456 wrote:
*Daniel wrote:I found another issue, if you look at my profile: <LINK REMOVED DUE TO BEEN ATTACKED> you will see that the layout is crap. Is it suppose to be like that?

Daniel
You need to provide a test login and password.
Ahh sorry,
Last edited by Danielx64 on Tue Sep 28, 2010 4:26 am, edited 1 time in total.
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

The_F4m3
Registered User
Posts: 2
Joined: Sat Sep 25, 2010 1:23 pm

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by The_F4m3 » Sat Sep 25, 2010 1:39 pm

After a lot of problems and several self-made fixes I have a problem i don't unterstand:
For guests is everything fine, but as you log in the bar didn't appear. After another fix it shows up, but it don't work. The boxes don't show up like they should and the number of Users is also empty.
But during the login it works sometimes for a part of a second. I have absolute no Idea where I should search for to fix it.

If somone has an idea or just want to see what their is:
http://rpg.naruto-xtreme.de/ (German, Bar in English)
test-acc: 'tester'
test-pw: '1pw4tester'

Sorry for my bad english and thanks
F4m3

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Sat Sep 25, 2010 5:41 pm

What part of the site is the messenger designed to follow?

I have some custom pages on my board where the messenger is not following anything, it just stays still...stuck in the middle of the screen: http://www.veinsfetiche.com/home.php

Locked

Return to “[3.0.x] Abandoned MODs”