[ABD] phpBB Social Network 0.7.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Sun Sep 26, 2010 8:31 pm

After giving my users some time to play with this, we have found the following problems with the friends approval system:

When we preform a search, it teats anyone who is not on our friends list as if they are on our foe list.
When we try to add members to our friends list, any member we try to add, we get the following error: "You can not add users to your friends list who are on your foes list."
At the same time though, our foes list is empty.
When we add people to our foes list, the foes list remains empty.

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Sun Sep 26, 2010 11:59 pm

I think I got the answer for that one, There are 2 manage friends and 2 manage foe mods, one for the usual phpbb and the other comes with this mod. I think you need to add then into the user's UCP
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Mon Sep 27, 2010 1:00 am

*Daniel wrote:I think I got the answer for that one, There are 2 manage friends and 2 manage foe mods, one for the usual phpbb and the other comes with this mod. I think you need to add then into the user's UCP
I did that.

I removed the old friends / foes, and added the ucp_im_friends and the ucp_im_foes.

My board: www.veinsfetiche.com/forums/

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Danielx64 » Mon Sep 27, 2010 1:15 am

cdodds wrote:
*Daniel wrote:I think I got the answer for that one, There are 2 manage friends and 2 manage foe mods, one for the usual phpbb and the other comes with this mod. I think you need to add then into the user's UCP
I did that.

I removed the old friends / foes, and added the ucp_im_friends and the ucp_im_foes.

My board: http://www.veinsfetiche.com/forums/
I tried to sign up and I get
Column 'user_referrer' cannot be null [1048]
Off topic, where did you get the ajax for the reg form from? I like it
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Mon Sep 27, 2010 4:27 am

*Daniel wrote:
cdodds wrote:
*Daniel wrote:I think I got the answer for that one, There are 2 manage friends and 2 manage foe mods, one for the usual phpbb and the other comes with this mod. I think you need to add then into the user's UCP
I did that.

I removed the old friends / foes, and added the ucp_im_friends and the ucp_im_foes.

My board: http://www.veinsfetiche.com/forums/
I tried to sign up and I get
Column 'user_referrer' cannot be null [1048]
Off topic, where did you get the ajax for the reg form from? I like it
Yeah, I was setting up referral link mod and integrating it with the ultimate points system today.
The error is gone now.

Still, here is a test account which I just made:
Account: Test2
Pass: TestPass7

----------------------
As for the ajax reg, I got it from: http://www.phpbb3-mods.com
But, that site no longer exists.
You can still find it in a few places though by googling, "AJAX User Registration Checks" phpbb3
http://www.google.com/search?hl=en&rlz= ... =&gs_rfai=

Mr. Man!
Registered User
Posts: 109
Joined: Sat Jul 31, 2010 6:05 am
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Mr. Man! » Tue Sep 28, 2010 12:42 am

So nothing from the code developer after so many complaints??

Jan Christensen
Registered User
Posts: 140
Joined: Sun May 16, 2004 10:42 am
Location: Denmark

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Jan Christensen » Tue Sep 28, 2010 4:36 am

Jan Christensen wrote:This MOD could be quite usefull once the bugs are deleted - did any of you find a way to make this MOD work with the gallery MOD?

I have the gallery MOD installed, and the instant messenger bar just won't show.

I tried as Daniel posted, and set everything to "no" in ACP - it didn't solve the problem.

I installed this MOD using the im_install.php file, corrected the issue about the "can not be NULL" as mentioned earlier in this topic. I did not use automod, but edited the files manually and yes, I did check several times that the edits made indeed are correct.

Im sorry if my english is a bit crappy this morning, I have been working with this all night long..

Anyone?
No solutions about this??
Jan Christensen • Danish language package author • Olympus DK Team

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by cdodds » Tue Sep 28, 2010 1:45 pm

Jan Christensen wrote:
Jan Christensen wrote:This MOD could be quite usefull once the bugs are deleted - did any of you find a way to make this MOD work with the gallery MOD?

I have the gallery MOD installed, and the instant messenger bar just won't show.

I tried as Daniel posted, and set everything to "no" in ACP - it didn't solve the problem.

I installed this MOD using the im_install.php file, corrected the issue about the "can not be NULL" as mentioned earlier in this topic. I did not use automod, but edited the files manually and yes, I did check several times that the edits made indeed are correct.

Im sorry if my english is a bit crappy this morning, I have been working with this all night long..

Anyone?
No solutions about this?
Is it not showing only in the gallery, or is it not showing everywhere?
Last edited by cdodds on Wed Sep 29, 2010 2:04 pm, edited 2 times in total.

idans
Registered User
Posts: 2
Joined: Tue Sep 28, 2010 5:14 pm

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by idans » Tue Sep 28, 2010 5:18 pm

when I send a message to a user, he does not get it, also i have to refresh the page to see my messages.
what i need to do?

User avatar
novanilla
Registered User
Posts: 332
Joined: Wed Jul 02, 2008 1:08 pm
Location: Colorado
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by novanilla » Wed Sep 29, 2010 1:45 pm

Wow.... Kinda makes me glad I haven't upgraded from 0.4.0 yet. Not as many features, but at least it's still working. I will be happy when there are fewer things going wrong for people.

User avatar
keith10456
Registered User
Posts: 2315
Joined: Thu Feb 24, 2005 6:55 pm
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by keith10456 » Wed Sep 29, 2010 1:58 pm

novanilla wrote:Wow.... Kinda makes me glad I haven't upgraded from 0.4.0 yet. Not as many features, but at least it's still working. I will be happy when there are fewer things going wrong for people.
Likewise :)

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by superj707 » Wed Sep 29, 2010 4:08 pm

The reason I uninstalled this mod was because it was to buggy. I really like this mod. I am hoping that it becomes more optimized and less buggy.

Peter77sx
Registered User
Posts: 3253
Joined: Wed Nov 09, 2005 2:51 pm

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by Peter77sx » Thu Sep 30, 2010 6:26 am

From what I understand, these mods are in BETA, DEV for a reason. to also help the mod authors test and give feedback. necessarily not ideal for a live site. :)

User avatar
NowTech
Registered User
Posts: 36
Joined: Wed May 26, 2010 10:32 am
Location: New York City
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by NowTech » Sun Oct 03, 2010 8:28 am

*Daniel wrote:Here the sql, it not finished, I just need to work out one last bit but I almost got it

UPDATE: I think I got all the sql that is required

Code: Select all

CREATE TABLE IF NOT EXISTS phpbb_config_im (
  config_name varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  config_value varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  is_dynamic tinyint(1) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (config_name),
  KEY is_dynamic (is_dynamic)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_disable', '0', 1);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_only_friends', '1', 1);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_allow_sound', '1', 1);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_override_cfg', '1', 1);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('zebra_alert_friend', '1', 1);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_allow_status', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_news', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_login', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_pm', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_search', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_status', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_news_count', '5', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_button_effect', 'clicks', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_allow_search_friends_posts', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_allow_friend_list', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_allow_user_note', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_zebra_approvals', '1', 0);
INSERT INTO phpbb_config_im (config_name, config_value, is_dynamic) VALUES('im_view_status_topic', '1', 0);


CREATE TABLE IF NOT EXISTS phpbb_im (
  `from` mediumint(8) NOT NULL,
  `to` mediumint(8) NOT NULL,
  message text COLLATE utf8_bin NOT NULL,
  sent int(11) NOT NULL,
  recd tinyint(1) unsigned NOT NULL DEFAULT '0',
  KEY sent (sent)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;


CREATE TABLE IF NOT EXISTS phpbb_users_im (
  user_id int(9) unsigned NOT NULL DEFAULT '0',
  user_status varchar(1024) COLLATE utf8_bin DEFAULT NULL,
  user_friends_only tinyint(1) unsigned NOT NULL DEFAULT '1',
  user_deny_im tinyint(1) unsigned NOT NULL DEFAULT '0',
  user_sound_im tinyint(1) unsigned NOT NULL DEFAULT '1',
  user_zebra_alert_friend tinyint(1) unsigned NOT NULL DEFAULT '1',
  user_note varchar(512) COLLATE utf8_bin DEFAULT NULL,
  PRIMARY KEY (user_id)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

ALTER TABLE phpbb_zebra ADD approval tinyint(1);
Daniel
Thank you very much, This fixes the problem I was having. :mrgreen:
Last edited by NowTech on Mon Oct 04, 2010 7:08 pm, edited 1 time in total.
"There's no such thing as a stupid question, but they're the easiest to answer!" :mrgreen:

User avatar
NowTech
Registered User
Posts: 36
Joined: Wed May 26, 2010 10:32 am
Location: New York City
Contact:

Re: [BETA] Instant Messenger + User status MOD 0.4.3

Post by NowTech » Sun Oct 03, 2010 8:45 am

Jan Christensen wrote:This MOD could be quite usefull once the bugs are deleted - did any of you find a way to make this MOD work with the gallery MOD?

I have the gallery MOD installed, and the instant messenger bar just won't show.

I tried as Daniel posted, and set everything to "no" in ACP - it didn't solve the problem.

I installed this MOD using the im_install.php file, corrected the issue about the "can not be NULL" as mentioned earlier in this topic. I did not use automod, but edited the files manually and yes, I did check several times that the edits made indeed are correct.

Im sorry if my english is a bit crappy this morning, I have been working with this all night long..

Anyone?

Looks ok on my development board
See first post for guest login.
"There's no such thing as a stupid question, but they're the easiest to answer!" :mrgreen:

Locked

Return to “[3.0.x] Abandoned MODs”