[ABD] Subject Prefix

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
hootaking
Registered User
Posts: 13
Joined: Sat Jun 26, 2010 12:28 pm

Re: [RC] Subject Prefix

Post by hootaking » Tue Nov 30, 2010 8:39 pm

error when i use search

help me

this is it

SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '216 + FROM phpbb_topics 217 + WHERE topic_id = '83'' at line 3 [1064]

SQL

SELECT topic_id, subject_prefix_id 216 + FROM phpbb_topics 217 + WHERE topic_id = '83'

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/hooks/hook_subject_prefix.php
LINE: 235
CALL: dbal_mysqli->sql_query()

FILE:
LINE:
CALL: sp_hook::add_subject_prefix_to_page()

FILE: includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: includes/template.php
LINE: 208
CALL: phpbb_hook->call_hook()

FILE: includes/functions.php
LINE: 4399
CALL: template->display()

FILE: search.php
LINE: 1008
CALL: page_footer()

User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [RC] Subject Prefix

Post by Jaymie1989 » Thu Dec 02, 2010 3:21 pm

Hey,

I just installed this and I got this error
General Error
SQL ERROR [ mysqli ]

Table 'board.phpbb_subject_prefixes' doesn't exist [1146]

SQL

SELECT * FROM phpbb_subject_prefixes

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/mods/subject_prefix/sp_cache.php
LINE: 46
CALL: dbal_mysqli->sql_query()

FILE: includes/mods/subject_prefix/sp_core.php
LINE: 40
CALL: sp_cache->obtain_subject_prefixes()

FILE: includes/mods/subject_prefix/sp_core.php
LINE: 426
CALL: sp_core::init()

FILE: includes/hooks/hook_subject_prefix.php
LINE: 75
CALL: require('includes/mods/subject_prefix/sp_core.php')

FILE:
LINE:
CALL: sp_hook::subject_prefix_init()

FILE: includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: includes/functions.php
LINE: 4760
CALL: phpbb_hook->call_hook()

FILE: includes/session.php
LINE: 1823
CALL: phpbb_user_session_handler()

FILE: index.php
LINE: 26
CALL: user->setup()

I cant view my index page or ACP.
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [RC] Subject Prefix

Post by imkingdavid » Thu Dec 02, 2010 4:00 pm

@Jaymie1989 - Did you run the SQL install file? At least one of the tables has not been created and as such cannot be found by the script. Double check that you ran the SQL install file.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [RC] Subject Prefix

Post by Jaymie1989 » Thu Dec 02, 2010 4:05 pm

Hi,

Sorry I forgot to add that I did run the SQL install.
When I got this error I went back to check that it was installed and it just gave me the same general error
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services

hootaking
Registered User
Posts: 13
Joined: Sat Jun 26, 2010 12:28 pm

Re: [RC] Subject Prefix

Post by hootaking » Fri Dec 03, 2010 8:13 am

i need query/queries to run sql

can one help me

User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [RC] Subject Prefix

Post by Jaymie1989 » Fri Dec 03, 2010 8:45 am

Jaymie1989 wrote:Hi,

Sorry I forgot to add that I did run the SQL install.
When I got this error I went back to check that it was installed and it just gave me the same general error
I still need help to fix this please.
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services

User avatar
Jaymie1989
Registered User
Posts: 1991
Joined: Thu Aug 02, 2007 5:21 pm
Name: Jaymie

Re: [RC] Subject Prefix

Post by Jaymie1989 » Fri Dec 03, 2010 3:04 pm

Jaymie1989 wrote:
Jaymie1989 wrote:Hi,

Sorry I forgot to add that I did run the SQL install.
When I got this error I went back to check that it was installed and it just gave me the same general error
I still need help to fix this please.
Dear creators of Sesame Street,
Kids are still fat. Can I come back now?
Sincerely, Cookie Monster.

View my MODs - Need phpBB help with MODs and Styles? Take a look at my phpBB3 services

User avatar
victory1
Registered User
Posts: 935
Joined: Sun Oct 10, 2010 6:47 pm
Contact:

Re: [RC] Subject Prefix

Post by victory1 » Fri Dec 03, 2010 3:33 pm

Jaymie1989 wrote:
Jaymie1989 wrote:
Jaymie1989 wrote:Hi,

Sorry I forgot to add that I did run the SQL install.
When I got this error I went back to check that it was installed and it just gave me the same general error
I still need help to fix this please.
This is the Dev thread and you're asking support in the wrong place. Here's the link:http://www.phpbb.com/customise/db/mod/s ... x/support/

mctoms
Registered User
Posts: 35
Joined: Mon Nov 16, 2009 9:29 am
Location: Poland
Name: Thomas
Contact:

Re: [Beta] Subject Prefix

Post by mctoms » Sun Dec 26, 2010 8:16 pm

Erik Frèrejean wrote:
wang5555 wrote:
Erik Frèrejean wrote:I've just released Subject Prefix 1.2.2-b1 through github, this release packages the following changes:
  • [Change] Some overall changes to make the code more readable.
  • [Change] Updated UMIL to v 1.0.3.
  • [Fix] #9 Prefix doesn't get added when using advanced search and show the results per topic.
  • [Fix] #11 The topic feed breaks when a topic has a prefix set.
  • [Fix] #12 "Special" searches trigger an error.
  • [Fix] #14 Support the "PhpBB3 SEO Title" MOD.
  • [Fix] #15 Remove excess line break when used with the "last post topic title MOD".
Yes I'm aware the release date in the install files is wrong :oops:
After update to "Subject Prefix 1.2.2-b1" mod, I get similar error when access some forums:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 379
CALL: dbal->sql_error()

FILE: includes/hooks/hook_subject_prefix.php
LINE: 128
CALL: dbal->sql_in_set()

FILE:
LINE:
CALL: sp_hook::add_to_index()

FILE: includes/hooks/hook_subject_prefix.php
LINE: 87
CALL: call_user_func()

FILE:
LINE:
CALL: sp_hook::add_subject_prefix_to_page()

FILE: includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: includes/template.php
LINE: 208
CALL: phpbb_hook->call_hook()

FILE: includes/functions.php
LINE: 4522
CALL: template->display()

FILE: viewforum.php
LINE: 773
CALL: page_footer()

Another, if guest access these forums who gets follow error message:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

[0]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
I think this nice mod should conflict with some had installed other mods.
But please forgive my stupid, I don't know which mod bring about effect.

This is my "viewforum.php" compression.
These forums get error message:
  1. forum_1
  2. forum_2
  3. forum_3
  4. forum_4
  5. forum_5
  6. forum_6
p.s. The 1~3 forums had set Subject Prefix, the 4~6 forums had not.

Above information hope to have some help. :oops:
Please try this patch, it should resolve this issue. I've issues to logon your ftp server so you'll have to do it manually ;).
Thanks a lot! I had the same problem! Ive cure it!

tomy91
Registered User
Posts: 41
Joined: Wed Apr 16, 2008 11:13 am

Re: [RC] Subject Prefix

Post by tomy91 » Tue Jan 25, 2011 2:05 pm

imkingdavid wrote:@Jaymie1989 - Did you run the SQL install file? At least one of the tables has not been created and as such cannot be found by the script. Double check that you ran the SQL install file.
Where are the SQL install file with all those queries! :?

eXo`
Registered User
Posts: 146
Joined: Sat Mar 13, 2010 7:28 pm

Re: [RC] Subject Prefix

Post by eXo` » Thu Feb 10, 2011 5:54 am

Just installed this mod, but can't see the settings in the ACP. Page is white. Must be because my php version is too old :( Will upgrade :D

lazyserv
Registered User
Posts: 19
Joined: Thu Nov 26, 2009 7:08 am

Re: [RC] Subject Prefix

Post by lazyserv » Wed Feb 16, 2011 7:15 pm

My board come error after i delete my test user and all my post so that my board can come to live and after i had done all those, my board suddenly come out this error.

FYI: I install Subject Prefix mod but i didn't set any prefix on the board yet, so i curious why the error come with the subject prefix

Below is my error code.

Code: Select all

General Error
SQL ERROR [ mysqli ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: includes/db/dbal.php
LINE: 379
CALL: dbal->sql_error()

FILE: includes/hooks/hook_subject_prefix.php
LINE: 126
CALL: dbal->sql_in_set()

FILE:
LINE:
CALL: sp_hook::add_subject_prefix_to_page()

FILE: includes/hooks/index.php
LINE: 141
CALL: call_user_func_array()

FILE: includes/template.php
LINE: 208
CALL: phpbb_hook->call_hook()

FILE: includes/functions.php
LINE: 4650
CALL: template->display()

FILE: index.php
LINE: 266
CALL: page_footer()
my forum link: http://forum.teamlz.com/

user751139
Registered User
Posts: 86
Joined: Thu Oct 01, 2009 2:46 am

Re: [RC] Subject Prefix

Post by user751139 » Mon Mar 21, 2011 10:23 am

I've tried many times over (actually a few hours now!) and still come to this error:

Code: Select all

Fatal error: Cannot redeclare setup_ads() (previously declared in /home/rex/public_html/ads/functions.php:25) in /home/romsbbor/public_html/ads/functions.php on line 87
Can anyone please help out.. Tried all versions including the latest version 1.2.2 and still the same issue

maxhel
Registered User
Posts: 79
Joined: Sat Apr 14, 2007 8:55 pm

Re: [RC] Subject Prefix

Post by maxhel » Sun May 29, 2011 8:33 am

anynews about this mod?

hmtaccess
Registered User
Posts: 27
Joined: Tue Jul 19, 2011 6:29 pm

Re: [RC] Subject Prefix

Post by hmtaccess » Wed Sep 14, 2011 2:27 pm

Error during install this mod

Code: Select all

Index name 'phpbb_topics_topic_first_post_id' on table 'phpbb_topics' is too long. The maximum is 24 characters.

Locked

Return to “[3.0.x] Abandoned MODs”