[ABD] [RC2] phpBB Mobile 2.0.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
artikkk
Registered User
Posts: 379
Joined: Sun Jan 04, 2009 1:37 pm
Location: Roma

Re: [RC] phpBB Mobile 2.0.0

Post by artikkk »

Italian language translate by me
http://www.megaupload.com/?d=IM83FL74

:mrgreen:
sorry for my bad english :S
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by callumacrae »

artikkk wrote:Italian language translate by me
http://www.megaupload.com/?d=IM83FL74

:mrgreen:
Thanks!

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by callumacrae »

Working on fixing the bugs I found, should have RC2 uploaded tomorrow.

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of
User avatar
Nawid
Registered User
Posts: 329
Joined: Sat Jun 27, 2009 4:32 pm
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by Nawid »

Thanks for the update.
I have redesigned the style a bit, but it's not ready yet. You could see it by visiting my forum (with phone).
:)
Image
Check SuperNova Orange style on:
SchoolLife.nl
phpBB.com
plasmino
Registered User
Posts: 261
Joined: Sat Jul 25, 2009 11:12 am

Re: [RC] phpBB Mobile 2.0.0

Post by plasmino »

artikkk wrote:Italian language translate by me
http://www.megaupload.com/?d=IM83FL74

:mrgreen:
italian language complete

http://www.megaupload.com/?d=V3QM4GVS
User avatar
Aurelienazerty
Registered User
Posts: 190
Joined: Sat Jan 08, 2005 8:21 pm
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by Aurelienazerty »

Hi,

I've got a problem with this mod :

Code: Select all

<b>[phpBB Debug] PHP Notice</b>: in file <b>/includes/session.php</b> on line <b>1602</b>: <b>preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Delimiter must not be alphanumeric or backslash</b><br />
Il my database I've got :
mobile_enabled 1
mobile_agents /iPad|iPhone|iOS|Opera Mobi|BlackBerry|Android|IEMobile|Symbian/

url : http://www.team-azerty.com/forum/

Also, when I go in the ACP, the phpBB Mobile settings are empty, it erase the value in DB as soon I visit the ACP mobile setting page.
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by callumacrae »

Aurelienazerty wrote:Hi,

I've got a problem with this mod :

Code: Select all

<b>[phpBB Debug] PHP Notice</b>: in file <b>/includes/session.php</b> on line <b>1602</b>: <b>preg_match() [<a href='function.preg-match'>function.preg-match</a>]: Delimiter must not be alphanumeric or backslash</b><br />
Il my database I've got :
mobile_enabled 1
mobile_agents /iPad|iPhone|iOS|Opera Mobi|BlackBerry|Android|IEMobile|Symbian/

url : http://www.team-azerty.com/forum/

Also, when I go in the ACP, the phpBB Mobile settings are empty, it erase the value in DB as soon I visit the ACP mobile setting page.
Try flushing the cache and trying again

Working on RC2 now, sorry for the delay.

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of
bhavesh
Registered User
Posts: 2
Joined: Fri Feb 04, 2011 6:16 am

Re: [RC] phpBB Mobile 2.0.0

Post by bhavesh »

Okay, I don't know what I'm doing wrong. I have the MOD installed, I enabled it and put

Code: Select all

/iPad|iPhone|iOS|Opera Mobi|BlackBerry|Android|IEMobile|Symbian/
in the regex field, but when I hit submit, nothing happens. If I click to another window, and go back, the settings did no save. I have tried to install this thing like 23908420934 times!! What is going on?!?!
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by callumacrae »

bhavesh wrote:Okay, I don't know what I'm doing wrong. I have the MOD installed, I enabled it and put

Code: Select all

/iPad|iPhone|iOS|Opera Mobi|BlackBerry|Android|IEMobile|Symbian/
in the regex field, but when I hit submit, nothing happens. If I click to another window, and go back, the settings did no save. I have tried to install this thing like 23908420934 times!! What is going on?!?!
I haven't a clue what is happening, but I did fix something similar to this and it should be fixed in the next RC

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of
bhavesh
Registered User
Posts: 2
Joined: Fri Feb 04, 2011 6:16 am

Re: [RC] phpBB Mobile 2.0.0

Post by bhavesh »

Well, after a while, I got it to work. When I went to the site using my phone, it displayed the mobile theme, but when I went to it again, using my computer, the whole theme was messed up. Am I supposed to change the STYLE ID anywhere?
User avatar
TrumpX
Registered User
Posts: 93
Joined: Tue Nov 16, 2010 2:45 pm
Location: Online

Re: [RC] phpBB Mobile 2.0.0

Post by TrumpX »

Hi,
I never tested this mod, but I am very intressted in it.
After taking a quick look at it, I have noticed that your acp_mobile.php is a little bit messed up...

You are never checking if submit was hit...
Therefore all values are cleared (set to false) everytime you are opening up the acp module...
Also you are adding a form key but you don't check it either...

I believe it should look like this instead:

Code: Select all

/**
* @ignore
*/
if (!defined('IN_PHPBB'))
{
	exit;
}

/**
* @package acp
*/
class acp_mobile
{
	var $u_action;

	function main($id, $mode)
	{
		global $config, $db, $template;
		
		$form_name = 'acp_mobile';
		add_form_key($form_name);
		
		if(isset($_POST['submit']))
		{
			if (!check_form_key($form_name))
			{
				trigger_error($user->lang['FORM_INVALID']. adm_back_link($this->u_action));
			}
			
			$mobile_enabled = request_var('enabled', $config['mobile_enabled']);
			$mobile_agents = request_var('agents', (string) $config['mobile_agents'], true);
			
			set_config('mobile_agents', $mobile_agents);
			set_config('mobile_enabled', $mobile_enabled);
		}

		$this->tpl_name = 'acp_mobile';
		$this->page_title = 'ACP_MOBILE';
		
		$template->assign_vars(array(
			'U_ACTION'			=> $this->u_action,
			'MOBILE_ENABLED'	=> $config['mobile_enabled'],
			'MOBILE_AGENTS'		=> $config['mobile_agents'],
		));
	}
}

-------------------
Edit:
To explain this better in case you don't understand (I am not a native english speaker)

This will return always a string no matter what

Code: Select all

$mobile_agents = request_var('agents', (string) false);
Since mobile_agents is always a string, this condition will always return true

Code: Select all

if ($mobile_agents !== false)
And your values will always be set to false
{S'PORT}_Skillz
Registered User
Posts: 284
Joined: Fri Aug 23, 2002 5:56 am

Re: [RC] phpBB Mobile 2.0.0

Post by {S'PORT}_Skillz »

Defiantly be glad when you finish with this. I also experienced the same problems above.

First, the site worked great when I tested it on my Galaxy S. Looked nice and was clean. Then I checked on my computer, all was well. I then proceeded to make a small edit to the overall_header.html file on the mobile version to make the site name dynamic, then I went to refresh the cache and whoa. Something got messed up big time. On the phone and on the computer, it was like this was no stylesheet being loaded. I then went to uninstall the mod via the install script, cleaned the cache and still the same problem. I ended up having to go back and deleting every single file that was uploaded and replacing the sessions.php file with my back, then going in and refreshing the template individually.

Once the bugs are ironed out, this will be an awesome addition to phpbb3.
{S'PORT}_Skillz
Registered User
Posts: 284
Joined: Fri Aug 23, 2002 5:56 am

Re: [RC] phpBB Mobile 2.0.0

Post by {S'PORT}_Skillz »

Alright, I take back what I last said. I installed the mod again and this time it seems to be working. I think the problem I was having before was because I wasn't "installing" the phpbb iPhone style but note that it is not listed under

ACP | STYLES | STYLE MANAGEMENT | Styles

Which I believe is so that users can select this style in their UCP, which makes sense.

You have to install each component individually.

ACP | STYLES | STYLE COMPONENTS | Templates
ACP | STYLES | STYLE COMPONENTS | Themes
ACP | STYLES | STYLE COMPONENTS | Imagesets

Once you do that, it all works just fine; and the slight template change I made is working perfectly as well.

I have NOT went to the

ACP | STYLES | STYLE MANAGEMENT | phpBB Mobile

Section of the ACP, because of the above mentioned issues. I fear this might cause some problems and I don't want to have to uninstall, then install it once more. :?
{S'PORT}_Skillz
Registered User
Posts: 284
Joined: Fri Aug 23, 2002 5:56 am

Re: [RC] phpBB Mobile 2.0.0

Post by {S'PORT}_Skillz »

Well I just went back to the site, following an email I got notifying me of a new reply. Once I got to the site, I experienced the same issue as before. Looks like the stylesheet wasn't working. Visited the site on my phone and it worked fine (mobile browser) I cleaned the cache for my theme manually and now the site works fine on the computer and the mobile version is non-existent on phone. No idea what the problem is.
User avatar
callumacrae
Former Team Member
Posts: 2662
Joined: Tue Feb 12, 2008 12:28 pm
Location: London, UK
Name: Callum Macrae
Contact:

Re: [RC] phpBB Mobile 2.0.0

Post by callumacrae »

You shouldn't have to install everything manually :/

Also, it will only be messed up on a computer if you use the bloat that people refer to as Internet Explorer. It uses CSS3 and IE is a few years behind.

I'm not sure why you're getting this error, I'll try to reproduce it.

~Callum
macr.ae = my website. you probably won't like it.
Proud user ofProud user of
Locked

Return to “[3.0.x] Abandoned MODs”