[ABD] Jump to my latest post v.0.0.2

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Sat Feb 18, 2012 9:55 pm

see edit of my last post
4_seven wrote:For the other modes it works ok?
Current Mods | Mod Base | php(BB) programming | No help via PM

Bash
Registered User
Posts: 337
Joined: Wed Mar 11, 2009 3:36 pm
Location: London, England
Name: Glenn

Re: [DEV] Jump to my latest post v.0.0.2

Post by Bash » Sat Feb 18, 2012 10:05 pm

Yes it works fine for the other modes (unread / your posts / active / unanswered).

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Sat Feb 18, 2012 10:08 pm

open

search.php

find

Code: Select all

        // Jump to my latest post / Search Addition / 4seven / 2011    
        if (!isset($topic_ids))
        {
           $topic_ids = array();
        }

        $topic_ids[] = $field;
        // Jump to my latest post / Search Addition / 4seven / 2011    
delete this code completely

instruction is corrected
Current Mods | Mod Base | php(BB) programming | No help via PM

Bash
Registered User
Posts: 337
Joined: Wed Mar 11, 2009 3:36 pm
Location: London, England
Name: Glenn

Re: [DEV] Jump to my latest post v.0.0.2

Post by Bash » Mon Feb 20, 2012 4:37 pm

That fixed it, thanks :)

Bash
Registered User
Posts: 337
Joined: Wed Mar 11, 2009 3:36 pm
Location: London, England
Name: Glenn

Re: [DEV] Jump to my latest post v.0.0.2

Post by Bash » Sun Mar 11, 2012 4:14 am

No problems after a lot of testing.

I think this should be approved by the mod team or w/e ;)

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Mon Mar 12, 2012 7:27 pm

thanks for reporting and i agree, to submit this soon.
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
jombo
Registered User
Posts: 65
Joined: Tue Jan 18, 2011 1:04 pm

Re: [DEV] Jump to my latest post v.0.0.2

Post by jombo » Wed Jun 06, 2012 8:13 pm

4_seven wrote:seems that something change in template in 3.0.9. - wired, bcs. the code was well tested. i check it, when i find time.
Yeap something is different in .09 I tried it several times just to make sure I didn't goof. The forum addon does the weird thing if you click on it in say test it will take you to last post in another forum. Works perfect in .10, .06, and even prerelease 3.1. But .09 has some weird thing going. The Search and rest is fine all versions I tested, just that forum addon in .09. It may be my board and other mods, but the .10 and 3.1 has most the same mods.

I did notice (not sure why) in .10 it did the same thing until I cleared FF cache but that didn't fix .09. After I seen clearing browser cache in .10 fixed it I retried .09 and it failed there. Maybe a FF restart? I will test that later.

Thanks 4 seven cool mod man.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Thu Jun 07, 2012 12:07 am

Thanks for feedback. Here is the fix
http://www.phpbb.com/community/viewtopi ... #p13115677
It fix it for several others and for myself
(Note: Its a fix for the Search Addition, not for the main mod)

But if you have the current version already and also checked this
http://www.phpbb.com/community/viewtopi ... #p13065596

then i can not reproduce > see demo forum > 3.0.10.

may i can have a testuser..
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Thu Jun 07, 2012 11:07 am

jombo wrote:The Search and rest is fine all versions I tested, just that forum addon in .09. It may be my board and other mods, but the .10 and 3.1 has most the same mods.
try this* as alternativ edit for viewtopic (v.0.0.2)
* alternativ edit

find

Code: Select all

		// Send vars to template
		$template->assign_block_vars('topicrow', array(
before add

Code: Select all

    // Jump to my latest post / 4seven / 2010	
    if (!isset($topic_ids))
    {
       $topic_ids = array();
    }

    $topic_ids[] = $topic_id;
    // Jump to my latest post / 4seven / 2010
instead of
original edit

find

Code: Select all

            unset($rowset[$topic_id]);
before add

Code: Select all

    // Jump to my latest post / 4seven / 2010	
    if (!isset($topic_ids))
    {
       $topic_ids = array();
    }

    $topic_ids[] = $topic_id;
    // Jump to my latest post / 4seven / 2010
clear all available board- and browser-caches
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
jombo
Registered User
Posts: 65
Joined: Tue Jan 18, 2011 1:04 pm

Re: [DEV] Jump to my latest post v.0.0.2

Post by jombo » Thu Jun 07, 2012 8:25 pm

4_seven wrote:Thanks for feedback. Here is the fix
http://www.phpbb.com/community/viewtopi ... #p13115677
It fix it for several others and for myself
(Note: Its a fix for the Search Addition, not for the main mod)

But if you have the current version already and also checked this
http://www.phpbb.com/community/viewtopi ... #p13065596

then i can not reproduce > see demo forum > 3.0.10.

may i can have a testuser..
Sorry but the board is an offline board 4-seven But I will test your fixes later. I took out the forum addon edits so I will put them back and test the above ideas. I wasn't concerned just wanted you to know for your experience is all. I am a mod tester is all I am I love to test em when you guys hack em lol. So I have several boards (dif versions) that I test on and they are all offline on an at home server. I only have 1 board online and it has been modded lots but I test em first real good before I put em on it.

I just install them then hack till I either fix the suckers or just delete em. But you do so many I wanted to give you feedback is all. I love your mods man, that last pic in a topic is an awesome mod. It will soon be on my online board I love it. Lately I been playing with the pre-release of 3.1 and about all your mods are on it and doing great even this one. It will not do SQL installers I am not smart enough to get it to do em same error everyone so any SQL has to be queries or imports from other working boards.

I have installed this mod prolly 20 times I know it well lol. I even hacked and improved it some, added it to Trashbin and Similar Topics. Keep on making them man I love to test em. A couple of my boards have over 70 mods on em the entire modbase and then some.

I just looked at the edits closer that is for the original part of the mod and it is fine it is the forum addon that is broken in .09 here.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Jump to my latest post v.0.0.2

Post by 4_seven » Thu Jun 07, 2012 11:18 pm

Thanks for your feedback and fun in effort :D
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: [ABD] Jump to my latest post v.0.0.2

Post by tumba25 » Fri Jun 29, 2012 9:07 am

Since the MOD author has been banned I'll lock this topic as [ABD] - Abandoned. If someone else wants to take over the development, please PM anyone on the MOD Team to request a link to your development topic. You can't reuse this topic, you need to start a new.

Notice!
We do not recommend that a user of the phpBB software install this mod, or any other mod that is marked as “abandoned” or “in development”, on a live forum. Doing so may cause your forum to not perform in the manner it should.


Thank you,
The phpBB Modifications Team
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net

Locked

Return to “[3.0.x] Abandoned MODs”