[RC] Classifieds MOD 2.0.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
panhead
Registered User
Posts: 723
Joined: Sat Dec 20, 2003 8:17 pm

Re: [RC] Classifieds MOD 1.1.0

Post by panhead »

I still have some members who use subsilver2 as default style. It is possible to make a (sub-)forum style default prosilver, is that also possible with this mod? The result would be that if they go to the classifieds it automatically would show the prosilver style.
foghornleghorn92
Registered User
Posts: 125
Joined: Thu Aug 05, 2010 5:07 pm

Re: [RC] Classifieds MOD 1.1.0

Post by foghornleghorn92 »

foghornleghorn92 wrote:I have found a few more things.
1. I'm getting this black space at the right side of the ads on the index page for recent ads is it meant to be like this?
2. Should there be a title on the top left of the ad box on index page?
3. Do you know where I go to edit the colour of the ad box to a lighter grey?
Image
Can anyone help me with any of these problems above? thanks.
emule
Registered User
Posts: 57
Joined: Tue Mar 30, 2010 11:50 am

Re: [RC] Classifieds MOD 1.1.0

Post by emule »

emule wrote:
emule wrote:hello

I have some problems in the update, here is the error code it gives me

Code: Select all

Fatal error: Cannot redeclare add_http() (previously declared in C:\wamp\www\phpbb3\wp-united\functions-general.php:28) in C:\wamp\www\phpbb3\buysell\includes\functions_buysell.php on line 94
I'm looking, I do not see or it could come from, can you help?

Anybody ? :|
Stingray1963
Registered User
Posts: 32
Joined: Thu Jul 20, 2006 10:17 pm
Contact:

Re: [RC] Classifieds MOD 1.1.0

Post by Stingray1963 »

I have upgraded to 1.1.0 from 1.0.0 . Everthing went trough, no errors during installation. Everything is working fine, including the uploader. But when viewing an ad, I get this:
PHP Notice: in file /buysell/single_ad.php on line 276: Undefined variable: forum_id

Any ideas?

Thanks in advance
Stingray1963
Registered User
Posts: 32
Joined: Thu Jul 20, 2006 10:17 pm
Contact:

Re: [RC] Classifieds MOD 1.1.0

Post by Stingray1963 »

*bump*
emule
Registered User
Posts: 57
Joined: Tue Mar 30, 2010 11:50 am

Re: [RC] Classifieds MOD 1.1.0

Post by emule »

emule wrote:
emule wrote:
emule wrote:hello

I have some problems in the update, here is the error code it gives me

Code: Select all

Fatal error: Cannot redeclare add_http() (previously declared in C:\wamp\www\phpbb3\wp-united\functions-general.php:28) in C:\wamp\www\phpbb3\buysell\includes\functions_buysell.php on line 94
I'm looking, I do not see or it could come from, can you help?

Anybody ? :|
there is no one to answer questions?
foghornleghorn92
Registered User
Posts: 125
Joined: Thu Aug 05, 2010 5:07 pm

Re: [RC] Classifieds MOD 1.1.0

Post by foghornleghorn92 »

emule wrote:there is no one to answer questions?
it's not looking like it and it's a pity because this mod is not far of being perfect :(
emule
Registered User
Posts: 57
Joined: Tue Mar 30, 2010 11:50 am

Re: [RC] Classifieds MOD 1.1.0

Post by emule »

my knowledge not allow me to deepen, or my request for help
User avatar
Stickygreen
Registered User
Posts: 179
Joined: Mon Oct 13, 2008 9:15 pm

Re: [RC] Classifieds MOD 1.1.0

Post by Stickygreen »

The mod author is most likely listening and just doesn't have the time to respond individually. He normally comes back and fixes all problems at once and releases a update from my experience. Just keep reporting problems and hopefully he will get to them soon.
User avatar
zenpig
Registered User
Posts: 642
Joined: Wed Aug 07, 2002 10:58 pm

Re: [RC] Classifieds MOD 1.1.0

Post by zenpig »

emule wrote:
emule wrote:
emule wrote:
emule wrote:hello

I have some problems in the update, here is the error code it gives me

Code: Select all

Fatal error: Cannot redeclare add_http() (previously declared in C:\wamp\www\phpbb3\wp-united\functions-general.php:28) in C:\wamp\www\phpbb3\buysell\includes\functions_buysell.php on line 94
I'm looking, I do not see or it could come from, can you help?

Anybody ? :|
there is no one to answer questions?
I don't use wp-united(isn't that abandoned?) but the author of that uses the same name of a function, add_http, as the author of this mod uses. It is usually just a matter of changing the name of the function(it is not a built in PHP one so should be ok) in either application throughout the script. To modify this classified script to have a different name of the function go to buysell/manage_ad.php lines 170 and 472 and buysell/includes/functions_buysell line 86...just change add_http in those three locations to something like addd_http. Since the classified script is still in development I'd actually recommend searching for all instances of add_http in the wp-united script and change it there but like I said I don't use it so have no idea where to change it.
Beer's proof that God loves us and wants us to be happy.
User avatar
zenpig
Registered User
Posts: 642
Joined: Wed Aug 07, 2002 10:58 pm

Re: [RC] Classifieds MOD 1.1.0

Post by zenpig »

Stingray1963 wrote:I have upgraded to 1.1.0 from 1.0.0 . Everthing went trough, no errors during installation. Everything is working fine, including the uploader. But when viewing an ad, I get this:
PHP Notice: in file /buysell/single_ad.php on line 276: Undefined variable: forum_id

Any ideas?

Thanks in advance
can you post what you have for line 276 in buysell/single_ad.php ?
Beer's proof that God loves us and wants us to be happy.
emule
Registered User
Posts: 57
Joined: Tue Mar 30, 2010 11:50 am

Re: [RC] Classifieds MOD 1.1.0

Post by emule »

zenpig wrote:
emule wrote:
emule wrote:
emule wrote:
emule wrote:hello

I have some problems in the update, here is the error code it gives me

Code: Select all

Fatal error: Cannot redeclare add_http() (previously declared in C:\wamp\www\phpbb3\wp-united\functions-general.php:28) in C:\wamp\www\phpbb3\buysell\includes\functions_buysell.php on line 94
I'm looking, I do not see or it could come from, can you help?

Anybody ? :|
there is no one to answer questions?
I don't use wp-united(isn't that abandoned?) but the author of that uses the same name of a function, add_http, as the author of this mod uses. It is usually just a matter of changing the name of the function(it is not a built in PHP one so should be ok) in either application throughout the script. To modify this classified script to have a different name of the function go to buysell/manage_ad.php lines 170 and 472 and buysell/includes/functions_buysell line 86...just change add_http in those three locations to something like addd_http. Since the classified script is still in development I'd actually recommend searching for all instances of add_http in the wp-united script and change it there but like I said I don't use it so have no idea where to change it.


actually wp-united script is abandoned, but quite functional in its current version. It works also quite well and I had no problems with the previous version of the ad.
I modified the files as indicated. Indeed, I have the error that I stated. But here are what I like when I valid error message.


Code: Select all

SQL ERROR [ mysql4 ]

Data too long for column 'thumb' at row 1 [1406]

SQL

INSERT INTO phpbb3_classifieds (ad_title, short_desc, ad_price, ad_price_text, ad_poster_id, cat_id, notify_comments, phone, days_active, paypal, paypal_currency, edit_time, last_edit_by, ad_date, ad_expire, ad_description, bbcode_uid, bbcode_bitfield, bbcode_options, thumb, ad_prefix_id, ad_location_id) VALUES ('test', 'sdsddfdsf', '42142', 0, 2, '1', 1, '', '', '', 'EUR', '', '', 1323884998, 1324489798, 'dsfsdfsdfdsdsfdsf', '', '', 7, 'http://localhost/phpbb3/buysell/images/thumb/neige 013_1323884964.jpg<b>[phpBB Debug] PHP Warning</b>: in file <b>/buysell/includes/functions_buysell.php</b> on line <b>70</b>: <b>imagejpeg() [<a href=\'function.imagejpeg\'>function.imagejpeg</a>]: Unable to open \'C:/wamp/www/phpbb3/buysell/images//thumb/neige 013_1323884964.jpg\' for writing: No such file or directory</b><br />', 0, 0)

BACKTRACE


FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: buysell/manage_ad.php
LINE: 294
CALL: dbal_mysql->sql_query()
User avatar
zenpig
Registered User
Posts: 642
Joined: Wed Aug 07, 2002 10:58 pm

Re: [RC] Classifieds MOD 1.1.0

Post by zenpig »

What are your permissions on the buysell/images and buysell/images/thumb directories? The data is too long for the thumb field in that table partly because it's inserting an error that it is unable to open the thumbs directory to place the image in.

The initial "add_http" redeclaration error was showing up now, btw, because it is a new function added by the auth of this mod that wasn't in previous versions.
Beer's proof that God loves us and wants us to be happy.
emule
Registered User
Posts: 57
Joined: Tue Mar 30, 2010 11:50 am

Re: [RC] Classifieds MOD 1.1.0

Post by emule »

permissions are good, writing and reading

if not, the "add_http" if I change to "addd_http" it is unlikely there no create errors?
User avatar
zenpig
Registered User
Posts: 642
Joined: Wed Aug 07, 2002 10:58 pm

Re: [RC] Classifieds MOD 1.1.0

Post by zenpig »

emule wrote:permissions are good, writing and reading

if not, the "add_http" if I change to "addd_http" it is unlikely there no create errors?
the change to addd_http shouldn't create any errors as long as you change it in the 3 locations previously pointed out. Make sure since you are working in Windows that the correct permissions are ok..set the permissions for the EVERYONE user to READ / WRITE / EXEC / DEL for the directories
Beer's proof that God loves us and wants us to be happy.
Locked

Return to “[3.0.x] Abandoned MODs”