[ABD] Facebook graph/connect logins and registration

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Skinny Vinny »

ty daniel. I must have accidentally sent the file alone instead of the entire folder at some point. Updated dl file, no change but removing misplaced duplicate.

opalelement
Registered User
Posts: 315
Joined: Wed Dec 27, 2006 4:05 am

Re: [RC] Facebook graph/connect logins and registration

Post by opalelement »

Is this based on the REST api or the GRAPH api?

EDIT: I looked at the code and it appears to be the REST api lol shoulda just looked before asking.

Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Skinny Vinny »

It is the Graph API, but uses an old REST API for revoking authorization only.

irdjfroggie
Registered User
Posts: 2
Joined: Sat Aug 14, 2010 2:52 pm

Re: [RC] Facebook graph/connect logins and registration

Post by irdjfroggie »

Hello,
as I try to connect to my forums with this MOD I get the following error:
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /hermes/bosweb/web272/b2723/ipg.jasoncphotoscom/forum/includes/functions_user.php:27) in /hermes/bosweb/web272/b2723/ipg.jasoncphotoscom/forum/includes/functions_user.php on line 82

Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Skinny Vinny »

Fetch latest dl file and replace hook file. I wrapped the include.

irdjfroggie
Registered User
Posts: 2
Joined: Sat Aug 14, 2010 2:52 pm

Re: [RC] Facebook graph/connect logins and registration

Post by irdjfroggie »

Works great now, thanks!

User avatar
katib
Registered User
Posts: 562
Joined: Thu Jun 26, 2008 12:27 pm

Re: [RC] Facebook graph/connect logins and registration

Post by katib »

I am using Advanced Double Activation Pack (ADAP)
Basically, new registration requires, first, user activation by email, then an admin have to approve membreship
So the registration settings on my forum are: user+admin
After installing Facebook graph/connect logins and registration and doing a registration test, I notice that users registring throuhgt FB button are automatically activated !! whitout need for email activation nor an admin approval

EDIT:
Well, I undestand, there is no need for email activation, Fb already checked user's email
but what about Admin approval?
There is also some required fields on registation, but it is not showed on registration throught FB button

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Peter77sx »

It wont let me log out of my forum no matter what browser i'm using... IE or FF. any ideas why?

Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Skinny Vinny »

katib wrote:I am using Advanced Double Activation Pack (ADAP)
Basically, new registration requires, first, user activation by email, then an admin have to approve membreship
So the registration settings on my forum are: user+admin
After installing Facebook graph/connect logins and registration and doing a registration test, I notice that users registring throuhgt FB button are automatically activated !! whitout need for email activation nor an admin approval

EDIT:
Well, I undestand, there is no need for email activation, Fb already checked user's email
but what about Admin approval?
There is also some required fields on registation, but it is not showed on registration throught FB button
The mod/hook is built for phpbb: if you have another mod that has altered/interefered with the native registration process/options, you're going to need a custom piece.

The hook does not interfere with phpbb native admin activation option. If the board is configure for admin approval, the account will not be instantly activated. If your board is just configure for user email activation, this connect skips it and creates the account active.

Peter, link.
Sounds to me like you added something that has status: true in the fb js, show me and I'll let you know.
Last edited by Skinny Vinny on Mon Aug 16, 2010 12:23 am, edited 1 time in total.

Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [RC] Facebook graph/connect logins and registration

Post by Danielx64 »

Skinny Vinny wrote:ty daniel. I must have accidentally sent the file alone instead of the entire folder at some point. Updated dl file, no change but removing misplaced duplicate.
Welcome anytime :)
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image

opalelement
Registered User
Posts: 315
Joined: Wed Dec 27, 2006 4:05 am

Re: [RC] Facebook graph/connect logins and registration

Post by opalelement »

Skinny Vinny wrote:It is the Graph API, but uses an old REST API for revoking authorization only.
Auth revoking just happens to be the part I scrolled to and based that comment on o.O

User avatar
ibraronaldo
Registered User
Posts: 45
Joined: Fri Jul 16, 2010 11:11 am

Re: [RC] Facebook graph/connect logins and registration

Post by ibraronaldo »

Some of you tell me why not working? I ran the entire manual is written in the first post.Ho also added the files, but I really want to work. To tell you the button does not come out even on facebook! Who you help me?

This is my site http://redsex.altervista.org/

Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [RC] Facebook graph/connect logins and registration

Post by Skinny Vinny »

I replied to you on svmods at http://svmods.com/viewtopic.php?f=7&p=238#p238

It's not working because it was not installed properly.
That will do it every time :)

nokia3310
Registered User
Posts: 25
Joined: Sat Aug 21, 2010 12:48 pm

Re: [RC] Facebook graph/connect logins and registration

Post by nokia3310 »

Skinny Vinny wrote:I replied to you on svmods at http://svmods.com/viewtopic.php?f=7&p=238#p238

It's not working because it was not installed properly.
That will do it every time :)

I have tried to understand how to install your plugin/mod and finding it hard to follow.

You never specified what to upload into the root folder of website.
Is the the whole files in the download folder or a specific folder.
A step by step guide for installation having 1, 2, 3 ect is the best way to explain installations instructions.

So what do i upload? is it the whole files/folder under the download folder or the root folder in the download folder?
Also where do i upload these folder or files? root?

Thanks
Best Android Apps(*only) = http://appsbytes.com

User avatar
ibraronaldo
Registered User
Posts: 45
Joined: Fri Jul 16, 2010 11:11 am

Re: [RC] Facebook graph/connect logins and registration

Post by ibraronaldo »

I did everything right, I installed the mod manually and with AutoMod, but the same thing. I checked a thousand times the files and everything is ok. What's wrong? Thanks

Edit: And finally I also run the test.php file and tells me everything is ok. But I do not see anything ok.

Locked

Return to “[3.0.x] Abandoned MODs”