[ABD] Facebook graph/connect logins and registration

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [ALPHA] Facebook graph/connect logins and registration

Post by superj707 »

yeah I think a basic version could come out before all this custom stuff gets added. I can't wait for what you have on your demo board right now. wooooot!
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

So far, only one issue has been found: a safari user ran into a refreshing loop. This is an issue with that particular browser not setting the facebook cookie properly, causing the facebook javascript and that particular browser to loop through page reloads...

I'm working on recreating the issue (have installed and tested hook in safari myself, but did not see the issue). Regardless if I can recreate it or not, I'm going to change the js from a page reload to a redirection so the hook can detect if there's an issue like this, and disabling the fb js for that users session.

I'll be away for awhile this afternoon, then working on identifying and resolving that users safari issue. First glance, I find many users with fb and safari problems, so it's not uncommon.

For everyone else though, it's worked like a charm. Unless something new pops up, I'll pack this up so people can test on their boards very soon.
superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [ALPHA] Facebook graph/connect logins and registration

Post by superj707 »

thanks for the update vinny. I am so excited about this that I have already promised it to my people.
looking forward to it.
you rock!!
User avatar
katib
Registered User
Posts: 562
Joined: Thu Jun 26, 2008 12:27 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by katib »

Ob btest board, after it imported my name asking me to cnfirm, I clicked on OK
Then I had a blank page
I refreshed the page? FireFox asked me to resend data. YES
Finally, the board says: thank you, you are registred..etc
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

That will corrected with the same fix as the safari missing cookie issue. The window reload is being replaced with an appended url for the cookie check and will resolve that issue as well.

This happens when you use the fb button from the registration screen, or any screen that was resolved via form post. Again, this will be resolved with the fix I'm working on for darcies encountered issue.

Will document it better later, waiting for darcie to confirm that what I see as the issue is in fact correct.
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

Darcie confirmed for me (tyvm!).
It's an error/issue on the client browser, but the hook needs to be changed to identify when such an error occurs and shut down the fb buttons. Will keep everyone posted as to progress.

If no other issues arise, I'll let people install and test on their boards.
Danielx64
Registered User
Posts: 1369
Joined: Wed Nov 04, 2009 5:51 am
Location: In a server room in Australia
Name: Daniel
Contact:

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Danielx64 »

Can you add the option to break the connection in the UCP so that users don't need to go to facebook and delete the app there?
Please note that I will not be porting any of my mods to phpBB 3.1. Sorry for the inconvenience this may cause.
Image
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

Daniel: I looked into it more, and yes. I'll quickly throw it in as well. It can be done through the original REST API, which is still supported. I'll add a link (with confirmation screen) into UCP and have the hook send the request. If it should fail, I'll throw an error screen instructing them to do so through the fb app settings.

Tested a call, revoked my own authorization.

Stability of the test board may go for a little while here as I throw this addition and the missing-cookie fix in. Shouldn't take very long, though. A few little things that I still want to test, then I'll start putting together instructions, etc.

Plans with gf today, but I'll get done as much as I can here.
superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [ALPHA] Facebook graph/connect logins and registration

Post by superj707 »

Its very nice how you keep us fully updated vinny.
Although I was sad when I checked the first page and there wasn't a download link. :(

have a nice day with your girl. Everyone needs a break.
superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [ALPHA] Facebook graph/connect logins and registration

Post by superj707 »

today is the day we get a demo right? I can hardly wait. WOOOOOOOOT!
I will keep checking back until it's posted.. im on the edge of my seat here.
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

I just got back home. Going to relax for a little bit, then back to work on this. I will have a download for the hook and instructions available before the end of the day.

I need to make a few changes and do a little testing first. The 'bad browser' issue discovered through darcie hasn't been completely resolved, and I won't release it unless it is. I know what I'm going to have to do.... will detail it later.
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

heredia21 wrote:So if we are already logged in to facebook. Are we going to be required to log in again to the forums?
If you're not logged into the forums, but logged into facebook, you'll now need to click the fb login button on your forum to have the hook log you in. The window will open for the usuall fb login, but then auto close itself and reload the page to let the hook log the user in. I originally had it so it automatically logged the fb user in, but this has just been changed to correct issue with 'bad browsers'. If something goes wrong on the client end, we can't have the js looping through reloads and redirects. This change corrects that.

My original fix for the 'bad browser' darcie discovered didn't resolve the issue completely. There's no way to build this fix without the proper values from the request/browser itself, which in a 'bad browser' can't be counted on. Killing that automatic action should resolve it.

When a 'bad browser' clicks an fb login button now, the page url is appended with a var to trigger the hook to check if the cookie that should have been set has been set. If not, it outputs a message that their browser isn't playing nice with us, and that they won'y be able to use the fb login/registration.

For the record, this should be a very rare occurrence. It's actually fortunate that darcie found it for us now, before this hook out in the wild.
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

Added optional language email welcome file svmods_fb_user_welcome.txt, svmods_fb_admin_welcome_inactive.txt, and svmods_fb_coppa_welcome_inactive.txt

If exists, will be used in welcome email. Otherwise, defaults are used
Last edited by Skinny Vinny on Sat Jul 24, 2010 9:06 pm, edited 1 time in total.
andredmau5
Registered User
Posts: 34
Joined: Wed Feb 03, 2010 10:38 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by andredmau5 »

Skinny Vinny wrote:Added optional language email welcome file user_svmods_fb_welcome.txt
If exists, will be used in welcome email. Otherwise, default user_welcome.txt is used.
Nice.. :D

a question, I have a CMS portal powered by Joomla and off course a phpbb3 forum, I'm using a bridge like rokbrigde of rockettheme. this bridge synchronizes phpbbusers with joomlausers, if a user has been registered from phpbb3, automatically is created in joomla.

with this mod.. this functionality still keep it working?.I don't think so, but i'd be nice if u get that. :oops:
Skinny Vinny
Registered User
Posts: 230
Joined: Tue Dec 01, 2009 7:10 pm

Re: [ALPHA] Facebook graph/connect logins and registration

Post by Skinny Vinny »

I've heard of that bridge, but have never used it nor am I familiar with it's code and methods. At some point, I'll have a look at it and see what can be done. If you wish to test this hook along side of the bridge, feel free to do so. If there's an incompatibility or issues with running them together, simply delete this hook file, purge the cache, and remove the (few) additions to the template.

From their site:
"No Joomla or phpBB3 hacks required"
This tells me that there shouldn't be an incompatibility. This hooks creating accounts, their bridge should see the account as any other account.

I'm getting it ready to distribute. Holding off releasing it till I hear back if removing the auto fb auth cleaned up darcies issue. There's only one reload in the hook itself when an fb id is found in cookie but doesn't belong to the logged in phpbb user. It kills that phpbb session and reloads.
Locked

Return to “[3.0.x] Abandoned MODs”

cron