[ABD]Attendance Mod(1.0.3)

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
charlieobrian
Registered User
Posts: 3
Joined: Tue Nov 01, 2011 6:27 pm
Location: Budapest

Re: [RC]Attendance Mod(1.0.3)

Post by charlieobrian » Thu Nov 03, 2011 8:43 pm

Thanks for the quick reply. I always make these changes on my test system, not on the live one. :D

So I will try to manually update the mod. Probably the best way will be to start with a clean phpbb3 installation and build everything from the beginning.

I will let you later about the results. Thanks again for this mod...

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [RC]Attendance Mod(1.0.3)

Post by wired076 » Fri Nov 04, 2011 6:51 am

charlieobrian wrote:Thanks for the quick reply. I always make these changes on my test system, not on the live one. :D

So I will try to manually update the mod. Probably the best way will be to start with a clean phpbb3 installation and build everything from the beginning.

I will let you later about the results. Thanks again for this mod...
No problems I look forward to hearing back on how you go.

If you have any feedback to the design and layout of the mod let me know and once the next few weeks of work are over I will see if I can make some improvements.

Big_Ham
Registered User
Posts: 10
Joined: Tue Dec 12, 2006 4:27 pm

Re: [RC]Attendance Mod(1.0.3)

Post by Big_Ham » Wed Nov 09, 2011 5:46 pm

GREAT MOD! Missed having this since upgrading to PHPBB3.


Any news on guest registration? I run a poker board where 25%+ of the attendees are often guests, so it's hard to get a real count using this mod.



THANKS for your hard work on it!

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Blue Blood » Sat Nov 12, 2011 8:42 am

its not working with tapatalk.. took me forever to figure out what mod was conflicting with tapatalk..
once I removed Attendance Mod tapatalk worked!!

Just thought I would share the info, and maybe you can fix the issue!!!

Thanks!!

charlieobrian
Registered User
Posts: 3
Joined: Tue Nov 01, 2011 6:27 pm
Location: Budapest

Upgrading from 0.2.6 to 1.0.3

Post by charlieobrian » Fri Nov 18, 2011 4:47 pm

wired076 wrote: No problems I look forward to hearing back on how you go.
I managed to upgrade by forum to phpbb ver. 3.0.9 and Attendance Mod to 1.0.3
To complicate the situation my phpbb forum is integrated into a Drupal 6 website. To keep things clear for myself, I started with original full install package of phpbb 3.0.9

The required steps:
moving original phpbb3 folder to a secure location and extracting new version to phpbb3 folder
restore phpbb config file
run install/database_upgrade.php
remove install folder
empty drupal and phpbb cache
testing normal forum functions (forums with Attendance mod will not work at this point)
updating drupal mod "phpbbforum"
installing phpbb mod "AutoMOD"
restoring customization (css files, localised buttons, etc)
installing phpbb mod "phpdrupalbridge"
removing Attendance Mod record from phpbb database, table phpbb_mod (this was necessary, as originally 0.2.6 was installed with autoMOD)
Install Attendance mod via AutoMOD
empty phpbb cache
testing
customizing \phpbb3\styles\prosilver\template\viewtopic_am_0.html
customizing \phpbb3\styles\prosilver\template\viewtopic_am_1.html
customizing functions_am.php

I had to remove some am_user_div sections in the viewtopic_am files, and also removed the following code from functions_am.php:

Code: Select all

<span class="am_registered_users">'.$am_mouseover_list.'</span>
as with the drupal embedded mode some roll-over functions did not work. It always listed all registered users for the events in every topic, not only when you moved the mouse over one of them.

Drakken
Registered User
Posts: 144
Joined: Thu Jun 12, 2003 6:59 pm
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Drakken » Fri Nov 18, 2011 6:33 pm

Blue Blood wrote:its not working with tapatalk.. took me forever to figure out what mod was conflicting with tapatalk..
once I removed Attendance Mod tapatalk worked!!

Just thought I would share the info, and maybe you can fix the issue!!!

Thanks!!
We are running AM & Tapatalk without issues. What problems are you having?

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Blue Blood » Sat Nov 19, 2011 3:34 pm

When I remove Attendance Mod no error.. I install it I get the error!!
Image

olibarke
Registered User
Posts: 2
Joined: Sun Nov 20, 2011 11:03 pm

Re: [RC]Attendance Mod(1.0.3)

Post by olibarke » Sun Nov 20, 2011 11:07 pm

Hi there,

Just wondering if there will be any potential for users being able to register for multiple options.

i.e.

If there is a multi-day event, over Mon, Tues, Weds - there is the option for one user to attend either one day, two days or three days?

Is this possible in the next release?

Many thanks!

Dunnocks
Registered User
Posts: 223
Joined: Tue Jul 05, 2011 9:16 pm
Location: Ireland

Re: [RC]Attendance Mod(1.0.3)

Post by Dunnocks » Tue Nov 22, 2011 10:05 pm

anyway i can remove the "REGISTERED ON" part of this mod?

the part where it shows when users registered?

Drakken
Registered User
Posts: 144
Joined: Thu Jun 12, 2003 6:59 pm
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Drakken » Wed Nov 30, 2011 3:03 pm

spankey1245 wrote:I did a FRESH installation of PHPBB 3.08, FRESH installation of automod, and installed Attendance mod using automod, so I'm pretty happy that this is a very clean installation. Whenever you enter a NORMAL post, without using the attendance feature, then click on preview, you are faced with 2 blank attendance options in your preview! (Perhaps this is related to the posting.php.... not sure).
Second to this bug, when you DO use the attendance feature in a post, then click on preview, it is not possible to click on submit to commit the message. The submit button simply does nothing (I think I saw this mentioned before somewhere here though).
I am also having this issue. Has anyone found a fix?

Image

Drakken
Registered User
Posts: 144
Joined: Thu Jun 12, 2003 6:59 pm
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Drakken » Fri Dec 02, 2011 7:32 pm

I got it working but with no AM preview at all.

open posting.php
delete:

Code: Select all

// --- Attendance Mod Start ---------------------------------------------------
// Type: Insert
	// Registration Preview
	if (!$am_delete && ($mode == 'post' || ($mode == 'edit' && $post_id == $post_data['topic_first_post_id']/* && (!$post_data['poll_last_vote'] || $auth->acl_get('m_edit', $forum_id))*/))
	&& $auth->acl_get('f_xam_create', $forum_id))
	{
		$s_am_layout 	= 'posting_preview_am_' . $post_data['am_layout'] . '.html';

		$template->assign_vars(array(
			'S_AM_LAYOUT'		=> am_registration_preview($s_am_layout, $post_data))
		);
	}
// --- Attendance Mod End -----------------------------------------------------
Sorry Blue, i tried to duplicate your error but I couldn't figure it out. Looks like its not getting the forum ID's value which might be a problem with your tapatalk installation.

First I'd reinstall tapatalk on your forum and see if that fixes it.

Verify the following code is in mobiquo/function/new_topic.php

Code: Select all

        'forum_id'              => (int) $forum_id,
If its there I'd double check your AM edits, mainly the ones dealing with forum_id. Possible posting.php?

User avatar
Blue Blood
Registered User
Posts: 763
Joined: Sat Apr 11, 2009 7:09 am
Location: U§A
Name: Blue Blood
Contact:

Re: [RC]Attendance Mod(1.0.3)

Post by Blue Blood » Tue Dec 27, 2011 5:27 am

cool thanks!!

Dunnocks
Registered User
Posts: 223
Joined: Tue Jul 05, 2011 9:16 pm
Location: Ireland

Re: [RC]Attendance Mod(1.0.3)

Post by Dunnocks » Sat Jan 07, 2012 11:28 pm

Dunnocks wrote:anyway i can remove the "REGISTERED ON" part of this mod?

the part where it shows when users registered?
anyone?

VTXrider
Registered User
Posts: 9
Joined: Thu Mar 30, 2006 4:14 am
Location: New York
Name: Jim Hughes

Re: [RC]Attendance Mod(1.0.3)

Post by VTXrider » Sun Jan 08, 2012 2:24 pm

Drakken wrote:
spankey1245 wrote:I did a FRESH installation of PHPBB 3.08, FRESH installation of automod, and installed Attendance mod using automod, so I'm pretty happy that this is a very clean installation. Whenever you enter a NORMAL post, without using the attendance feature, then click on preview, you are faced with 2 blank attendance options in your preview! (Perhaps this is related to the posting.php.... not sure).
Second to this bug, when you DO use the attendance feature in a post, then click on preview, it is not possible to click on submit to commit the message. The submit button simply does nothing (I think I saw this mentioned before somewhere here though).
I am also having this issue. Has anyone found a fix?

Image
My friend found a fix for the preview problem it is an extra line at the beginning and end of the am0 and am1 files. I will try to get the info again and see if he can post up here. It fixed my board.

Suggsy
Registered User
Posts: 6
Joined: Sat Feb 25, 2012 6:56 pm

Re: [RC]Attendance Mod(1.0.3)

Post by Suggsy » Sat Feb 25, 2012 7:02 pm

Hi has anyone tried this on version 3.0.10 as it is just what Ive been looking for, well done to everyone involved.

I can tell people that it works fine on 3.0.10 however I have problems when using a different Style
so Im guessing a manual install is required on these. If anyone else has an Idea I would love to hear from them

regards S

Locked

Return to “[3.0.x] Abandoned MODs”