[ABD] Video BBCode 1.0.5

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
crogamer
Registered User
Posts: 6
Joined: Sat Feb 12, 2011 5:15 pm

Re: [RC] Video BBCode 1.0.3

Post by crogamer » Sun Feb 13, 2011 12:13 am

Nope, it just messed up the whole forum. I can't access any page, they're all 403. I tried changing permissions for the whole phpbb3 folder to 755, didn't help. Luckily, this is a fresh forum installation so no harm done. However, the problem is repeatable, because I did another fresh install, repeated the steps, same thing. I'm going for a third install now, i'll try to install the mod manually this time.

EDiT: Yup, installed just fine manually. So it's either a problem with Automod FTP method, or a problem with UMIL 1.0.4 (i updated to this latest version cause automod complains about outdated version).

superj707
Registered User
Posts: 1136
Joined: Thu Feb 26, 2009 12:20 am

Re: [RC] Video BBCode 1.0.3

Post by superj707 » Tue Feb 15, 2011 9:24 pm

I would just like to inform people / authors that this mod is not compatible with
http://www.phpbb.com/community/viewtopi ... &t=1937925
demon chat.

if a video is posted in demon chat it opens up in it's own window. it's especially a problem in additional chat channels if multi demon chat channels are enabled.

thank you.

hexodark
Registered User
Posts: 3
Joined: Fri Mar 04, 2011 9:13 pm

Re: [RC] Video BBCode 1.0.3

Post by hexodark » Fri Mar 04, 2011 9:17 pm

Add a video Blip.tv

Code: Select all

// http://blip.tv/play/gtZKgc3VVgA
 array('blip.tv', 'play/%/%$%0', '<embed src="http://blip.tv/play/{ID_VIDEO}" type="application/x-shockwave-flash" width="640" height="480" allowscriptaccess="always" allowfullscreen="true"></embed>'),
use a url on exportable player

Privteer
Registered User
Posts: 18
Joined: Fri Dec 24, 2010 8:56 pm

Re: [RC] Video BBCode 1.0.3

Post by Privteer » Sun Mar 06, 2011 7:04 pm

I added a code for "videobb.com" in the video.php file :

Code: Select all

// videobb.com - http://www.videobb.com/video/7G6sUq8AIW15
	  array('videobb.com', 'video/%.%0', '<iframe class="video-player" type="text/html" width="631" height="385" src="http://www.videobb.com/e/{ID_VIDEO}" frameborder="0"></iframe>'),	  
here is a page with result : http://forum.mixandplay.fr/accueil-mixa ... o-t66.html

cdodds
Registered User
Posts: 228
Joined: Sat Jul 10, 2010 2:19 am
Name: Don Cdoddsy
Contact:

Re: [RC] Video BBCode 1.0.3

Post by cdodds » Tue Mar 08, 2011 8:50 am

Youtube videos are showing up blank when I use this code.
Any idea why?

Privteer
Registered User
Posts: 18
Joined: Fri Dec 24, 2010 8:56 pm

Re: [RC] Video BBCode 1.0.3

Post by Privteer » Tue Mar 08, 2011 7:27 pm

check in "video.php" if you have the correct code :

Code: Select all

// youtube.com - http://www.youtube.com/watch?v=9ixFf4ljuCg
	  array('youtube.com', 'v=%&%0', '<iframe class="youtube-player" type="text/html" width="631" height="385" src="http://www.youtube.com/embed/{ID_VIDEO}" frameborder="0"></iframe>'),
I changed the size of the player... you can customize it.

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.3

Post by sevenalive » Wed Mar 09, 2011 12:44 am

Updated the download with new 2 sites. Youtube is working fine, must be a problem on your end.

Blazeflack
Registered User
Posts: 50
Joined: Sat May 16, 2009 2:00 pm

Re: [RC] Video BBCode 1.0.3

Post by Blazeflack » Wed Mar 09, 2011 2:25 pm

Thanks for taking your time to keep this updated. There is a small error in your latest update, you forgot to add the 2 newly added sites within the array and as such a parse error will now happen.

Find

Code: Select all

      array('mlssoccer.com', 'id=%$%0', '<object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="480" height="324"><param name="source" value="http://mls.neulion.com/mlsvp/scripts/mls.xap"/><param name="initParams" value="catid=112,id={ID_VIDEO},shareembed=true,server=http://mls.neulion.com/mlsvp/,pageurl=http://www.mlssoccer.com/videos?id={ID_VIDEO}&catid=112"/><param name="background" value="Transparent" /><param name="minRuntimeVersion" value="3.0.40624.0" /><param name="autoUpgrade" value="true" /><param name="Windowless" value="true" /><param name="enableHtmlAccess" value="true"/></object>'), );
Change to (remove ");")

Code: Select all

      array('mlssoccer.com', 'id=%$%0', '<object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="480" height="324"><param name="source" value="http://mls.neulion.com/mlsvp/scripts/mls.xap"/><param name="initParams" value="catid=112,id={ID_VIDEO},shareembed=true,server=http://mls.neulion.com/mlsvp/,pageurl=http://www.mlssoccer.com/videos?id={ID_VIDEO}&catid=112"/><param name="background" value="Transparent" /><param name="minRuntimeVersion" value="3.0.40624.0" /><param name="autoUpgrade" value="true" /><param name="Windowless" value="true" /><param name="enableHtmlAccess" value="true"/></object>'),
Find

Code: Select all

array('blip.tv', 'play/%/%$%0', '<embed src="http://blip.tv/play/{ID_VIDEO}" type="application/x-shockwave-flash" width="640" height="480" allowscriptaccess="always" allowfullscreen="true"></embed>'),
Change to (add ");")

Code: Select all

array('blip.tv', 'play/%/%$%0', '<embed src="http://blip.tv/play/{ID_VIDEO}" type="application/x-shockwave-flash" width="640" height="480" allowscriptaccess="always" allowfullscreen="true"></embed>'), );

GRF
Registered User
Posts: 1
Joined: Wed Mar 09, 2011 2:19 pm

Re: [RC] Video BBCode 1.0.3

Post by GRF » Wed Mar 09, 2011 2:26 pm

Hi, thanks for the great mod! Is it possible to add the "#t" timestamp in youtube videos?

i.e.

http://www.youtube.com/watch?v=oHg5SJYRHA0

and

http://www.youtube.com/watch?v=oHg5SJYRHA0#t=1m25s

currently embed the youtube video from the beginning (0m0s).

I tried to play around with video.php, it looks like that initially"$id_video" contains everything after the "v=", however the hash sign + the rest appears to be parsed out somewhere in video.php.

Thanks and keep up the good work.

hexodark
Registered User
Posts: 3
Joined: Fri Mar 04, 2011 9:13 pm

Re: [RC] Video BBCode 1.0.3

Post by hexodark » Wed Mar 09, 2011 5:59 pm

hello :)

please help me to add this website in the php files

http://exposureroom.com/

tx :)

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.3

Post by sevenalive » Wed Mar 09, 2011 9:58 pm

Fixed that, as for exposureroom, it seems pretty easy the video ID is a looks like a hash provided by the url, so it can be done, however they provide no emded code. Contact the site and see if they allow embeds.

hexodark
Registered User
Posts: 3
Joined: Fri Mar 04, 2011 9:13 pm

Re: [RC] Video BBCode 1.0.3

Post by hexodark » Thu Mar 10, 2011 2:03 am

Code: Select all

<object id="xrPca6c0b5e493d4c9983418282b428aae6" width="960" height="528" type="application/x-shockwave-flash" data="http://exposureroom.com/flash/XRVideoPlayer2.swf?domain=exposureroom.com/&assetId=ca6c0b5e493d4c9983418282b428aae6&size=lr&titleColor=%23ffffff"><param name="movie" value="http://exposureroom.com/flash/XRVideoPlayer2.swf?domain=exposureroom.com/&assetId=ca6c0b5e493d4c9983418282b428aae6&size=lr&titleColor=%23ffffff" /><param name="allowNetworking" value="all" /><param name="allowScriptAccess" value="always" /><param name="allowFullScreen" value="True" /><param name="wmode" value="opaque" /></object><div><div class="viewOnXRDiv"><a href="http://exposureroom.com/ca6c0b5e493d4c9983418282b428aae6" class="viewOnXRLink" title="Saint Seiya  The Lost Canvas  (Opening) by miles prower - View it on ExposureRoom" target="_blank">View on ExposureRoom</a></div></div>
this code is te emded :)

NeonDevil
Registered User
Posts: 4
Joined: Sun Jan 16, 2011 8:26 am

Re: [RC] Video BBCode 1.0.3

Post by NeonDevil » Thu Mar 10, 2011 4:56 am

I think my recent discovery might shed some light for those videos showing up as 'blank'.

I currently use RokBridge to enable single logon between Joomla and PHPBB - the setup requires two seperate paths - PHPBB to be installed in /phpbb3/ and the bridge to be installed in /forum/.

As you can see, the following URLs go to the same page (kinda, one is wrapped in another index.php)

http://www.nvairsoft.com/phpbb3/index.php?f=9&t=70
http://www.nvairsoft.com/forum/index.php?f=9&t=70

The video code will only work in /phpbb3/

UPDATE:
It seems that updating the "HTML Replacement" of the BBCODE to include the full path of the video.php page in the <script> src="" helped me.

was:

Code: Select all

<script type="text/javascript" src="video.php?link={URL}"></script>
is:

Code: Select all

<script type="text/javascript" src="http://www.yoursite.com/phpbb3/video.php?link={URL}"></script>

So... if your forum is wrapped in another page other than your phpbb installation directory, this fix may work for you.

User avatar
zenrei
Registered User
Posts: 172
Joined: Fri Oct 06, 2006 1:34 pm

Re: [RC] Video BBCode 1.0.3

Post by zenrei » Fri Apr 01, 2011 5:39 pm

The installer isn't working for me.

I didn't copy umil, because it's not the latest version

Both uploaded files are set to 755

When I go to http://www.mysite.com/forum/install_video_bbcode.php

I get the login screen, then it refreshes to the board index.

What do I need to do to fix it?

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.3

Post by sevenalive » Fri Apr 01, 2011 10:11 pm

Do you have at least the latest umil on your server?

Locked

Return to “[3.0.x] Abandoned MODs”