[ABD] Video BBCode 1.0.5

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Tue Apr 19, 2011 4:53 am

Upgrade the script, as long as the video site is supported on the new script you shouldn't have a problem. You can always reference the old script arrays if there are any problems.

Olegus
Registered User
Posts: 5
Joined: Sat Apr 23, 2011 12:30 pm

Re: [RC] Video BBCode 1.0.4

Post by Olegus » Sat Apr 23, 2011 12:32 pm

Please add code for russian videoservice:

1. vkontakte.ru
2. video.mail.ru
3. smotri.com
4. video.yandex.ru

ahh72
Registered User
Posts: 45
Joined: Tue Jan 06, 2009 1:14 pm
Location: In der Nähe von Frankfurt, Deutschland
Name: @l€x
Contact:

Re: [RC] Video BBCode 1.0.4

Post by ahh72 » Sat Apr 23, 2011 1:40 pm

download link don't work

thanks in advance
- URL: http://www.peruvoley.com/foro
- Hosting: http://www.rogohosting.com
- phpBB version: 3.1.9
- Style: prosilver

Rumlik
Registered User
Posts: 28
Joined: Tue Feb 08, 2011 12:42 pm
Location: Czech Republik
Contact:

Re: [RC] Video BBCode 1.0.4

Post by Rumlik » Sun Apr 24, 2011 1:32 pm

Great mod! Thank you for it!!

Could someone add these Czech videoservers:

videacesky.cz
stream.cz

TDave00
Registered User
Posts: 21
Joined: Tue Sep 16, 2008 9:14 am

Re: [RC] Video BBCode 1.0.4

Post by TDave00 » Fri Apr 29, 2011 9:52 am

Did a manual install, and it works fine. I did notice that it changed our main logo back to the original file. No biggie. Quick fix. Just thought I would give you a heads up.

Is the issue with the Photobucket videos (and slideshows) because you can't get a width and height back from photobucket?

I setup a custom bbcode for photobucket, but the user has to add the width and height, and also remove this part of the url.

Code: Select all

?action=view&current=

Example link

Code: Select all

http://s305.photobucket.com/albums/nn213/tdave00/?action=view&current=100_3538.mp4
It's a little too difficult for most people, so I just end up editing their links manually. So, there's no way to get the height and width automagically? Just wondering?

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Fri Apr 29, 2011 1:32 pm

No the issue with photobucket is different. The url to a video, does not relate to the actual url or video id of video. The only way would be to scan the html source and find the video code and copy it and put that into the post. It's messy and results in a slower page load because it has to load your site + the photobucket html page. I have implemented this workaround for some sites, I haven't checked on photobucket because it seems that not many people use it for videos, when there are much better alternatives.

The point of this mod is to use the bbcode without special instructions or hacks needed. In your example they must edit the url for it to work, most users don't bother with instructions and will result in more work for moderators.

Photobucket url's are not consistent, this link won't work with your bbcode:

Code: Select all

http://media.photobucket.com/popular/video/allpopular/sv1cec/videos/ReassemblyAnimationHR.mp4?o=7
When I get a chance I'll need to fill out the requests from this thread if someone doesn't beat me to it and I'll check on Photobucket again. It won't be for another week or 2 since my desktop is down due to bad ram.

TDave00
Registered User
Posts: 21
Joined: Tue Sep 16, 2008 9:14 am

Re: [RC] Video BBCode 1.0.4

Post by TDave00 » Sat Apr 30, 2011 5:04 am

Thanks for the reply. Maybe I am missing something, but when I choose the embed code for that video it uses the same url (minus the "?action=view&current=").

Original Link

Code: Select all

http://s305.photobucket.com/albums/nn213/tdave00/?action=view&current=100_3538.mp4
Embed Code from Photobucket

Code: Select all

<embed width="600" height="361" type="application/x-shockwave-flash" allowFullscreen="true" allowNetworking="all" wmode="transparent" src="http://static.photobucket.com/player.swf" flashvars="file=http%3A%2F%2Fvid305.photobucket.com%2Falbums%2Fnn213%2Ftdave00%2F100_3538.mp4">
Here it is specifically.

Code: Select all

http%3A%2F%2Fvid305.photobucket.com%2Falbums%2Fnn213%2Ftdave00%2F100_3538.mp4
Now if I copy the embed code directly from that page (where photobucket displays the video) it seems different, but both embed codes work.

Code: Select all

<embed width="600" height="361" flashvars="overlayAdURL=http://b.photobucket.com/pbkt/hserver/viewid=1551555814/size=600x50/reg_zip=empty/user_kw=empty/cam_make=nikon,htc,kodak,samsung/cam_model=,easyshare,eris,coolpix/cam_type=PnS/m_carrier=T-Mobile_USA/sp=f/bf=4/ptype=landing/spon=empty/track=empty/ref_domain=empty/LINKED_DOMAINS=googlecom,coolchasercom,facebookcom,yahoocom,livecom/random=749536/area=video_overlay/age=37/gender=M/login=N/site=pb" allowfullscreen="true" allownetworking="all" allowscriptaccess="always" wmode="transparent" quality="high" bgcolor="#FFFFFF" name="mymovie" id="mymovie" style="undefined" src="http://static.pbsrc.com/flash/onSiteVideo.swf?file=http://vid305.photobucket.com/albums/nn213/tdave00/100_3538.mp4&os=1&ap=1" type="application/x-shockwave-flash">
You can see both codes working on the same page here.
http://www.tennesseeclassictruckclub.co ... utube.html

Like I said I use a custom (simple) BBcode on our site that has {simpletext1} for the width, {simpletext2} for the height, and then {text} for the url, so I know the direct link works with the embed code when just the "?action=view&current=" is removed.

We don't host images on our board, so we have integrated photobucket, and that's the first place our users look to display slideshows and hosted videos. Any help is appreciated to get this working.

Thanks,
Trai

JakeM0412
Registered User
Posts: 6
Joined: Fri Jul 02, 2010 11:45 am

Re: [RC] Video BBCode 1.0.4

Post by JakeM0412 » Sun May 08, 2011 9:32 pm

I'm having a problem with this mod on my forum - can you help?

I've been using the mod for quite a while, and it never worked properly with any browser other than Firefox - but with the new Firefox 4, it no longer works correctly with that browser either.

The problem is that it distorts the threads that videos are on, below the post with an embedded video, the thread displays with a series of columns squeezing the text out, and the text size becomes huge - eventually with nothing but the series of columns showing, and perhaps a portion of massive text.

This screencap will hopefully show you what I mean, some of the the columns can be seen on the left. It also makes the bulletin points in the bottom menu display as "&bull."


Image


This link shows the columns at both sides at the bottom of the thread (I had to shrink the browser window to capture this image, but it occurs with the window at any width)...

http://i1206.photobucket.com/albums/bb4 ... 2/vid2.png


We have heaps of videos posted - replacing them all now would be very difficult.

Here is the forum (you would have to register an account):

http://www.fan-freaks.com/forum

This thread will show you the problem clearly:

http://www.fan-freaks.com/forum/viewtop ... &start=100


Thanks for all the hard work on this mod, hope someone can help me sort out this issue.

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Mon May 09, 2011 3:17 pm

The problem you have isn't caused by this mod, I think it might be the style your using. Try using prosilver and see if it causes a problem. The only thing that get's inserted into the post is html embed code, nothing what would cause any of that.

User avatar
bollos
Registered User
Posts: 39
Joined: Thu Jul 27, 2006 4:43 pm

Re: [RC] Video BBCode 1.0.4

Post by bollos » Sat May 14, 2011 6:40 pm


User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Mon May 16, 2011 4:59 am

Google video is dead and will not be supported. http://video.google.com/support/bin/ans ... wer=138275

Olegus
Registered User
Posts: 5
Joined: Sat Apr 23, 2011 12:30 pm

Re: [RC] Video BBCode 1.0.4

Post by Olegus » Mon May 30, 2011 11:09 am

Olegus wrote:Please add code for russian videoservice:

1. vkontakte.ru
2. video.mail.ru
3. smotri.com
4. video.yandex.ru
Help, please!

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Mon May 30, 2011 4:44 pm

smotri.com is already done, you probably need to redownload and overwrite the video.php file.

On vkontakte.ru I just get an intro page and don't see any videos, you need to provide a video url and embed codes. If it requires registration and to be logged in to view videos, this mod will not support that.

I went to http://video.yandex.ru and all the videos just redirected to youtube, so I'm not sure what you want me to do there.

video.mail.ru, I can't find any embed codes, it doesn't help the site doesn't translate well in Chrome.

When requesting sites, provide the url and the embed codes to help speed up the process, especially if the site is not in english.

User avatar
Terceirense
Registered User
Posts: 49
Joined: Mon Oct 09, 2006 1:19 pm
Location: Açores Ilha Terceira
Contact:

Re: [RC] Video BBCode 1.0.4

Post by Terceirense » Sun Jun 19, 2011 7:27 pm

Can you add this http://videos.sapo.pt

thanks

User avatar
sevenalive
Translator
Posts: 437
Joined: Thu Feb 07, 2008 4:45 am
Location: Tempe, AZ
Name: Robert

Re: [RC] Video BBCode 1.0.4

Post by sevenalive » Mon Jun 20, 2011 12:38 am

Done, just redownload and overwrite the video.php, no need to reinstall.

Locked

Return to “[3.0.x] Abandoned MODs”