[ABD] Youtube [thumbs] on Forum Index v.0.0.1

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
kssite
Registered User
Posts: 26
Joined: Fri Aug 21, 2009 7:40 pm

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by kssite »

Sweet :)
Would be happy to do some testing if needed on that.

Regards
kssite
http://www.tubewood.com Best YouTube Videos :D

User avatar
Mess
Registered User
Posts: 985
Joined: Wed Jul 01, 2009 6:37 am
Name: Kim

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by Mess »

This unfortunately docent work with the new sharing format. Any chance you could look at it 4_seven?

Eksample:
http://youtu.be/ZTpb5Ehdc40

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

Hm, seems that this is just a new shortened url format from youtube, like bit.ly, to have some comfort for the users, but no generaly switch to a new url syntax. The old(!) format works anyway.
Current Mods | Mod Base | php(BB) programming | No help via PM

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by Peter77sx »

Hi 4_seven .. i don't see the download/topic for this on your new MOD site. are you still supporting this?

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

of course, but currently busy. i reupload it soon.
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

New download- and demo-link (read first post for further details)
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
irdem
Registered User
Posts: 172
Joined: Sat Oct 13, 2007 10:31 pm
Contact:

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by irdem »

hi 4_seven,
there is an issue with your mod on my forum: the hover option doesn't work with ie. no problem with firefox. see the result here.

however, I worked a little on your codes with new files and made a youtube thumb block for display recent youtube videos thumbs. see the firs block on this page
I used this script in html file:

Code: Select all

				<script type="text/javascript">
					// <![CDATA[
					function youtubeFeedCallback(thumb_youtube){
						document.write('<a href="{thumb_youtube.TUBE_LNK_1}"><img src="' + thumb_youtube["data"]["thumbnail"]["sqDefault"] + '"></a><br/>');
						document.write('<strong>' + thumb_youtube["data"][ "title" ] + '</strong><br/>');
						document.write('<i>Trh:</i>{thumb_youtube.YT_DATE}<br/>');
						document.write('<a href="{thumb_youtube.TUBE_LNK_1}">{L_GOTO_VIDEO}</a>');
					}
					// ]]>
				</script>
				<script type="text/javascript" src="http://gdata.youtube.com/feeds/api/videos/{thumb_youtube.VIDEO_ID1}?v=2&alt=jsonc&callback=youtubeFeedCallback"></script>

I thought maybe you could use anything like this in your mod..

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

irdem wrote:the hover option doesn't work with ie.
On your and my site it works for me with ie, so nothing to do.
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
irdem
Registered User
Posts: 172
Joined: Sat Oct 13, 2007 10:31 pm
Contact:

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by irdem »

thank you for help, here is my screen with ie8. but it works fine with ie8 on your demo forum;)

User avatar
darkonia
Registered User
Posts: 1901
Joined: Tue May 13, 2008 1:10 pm
Location: Munich, Germany
Contact:

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by darkonia »

irdem wrote:
however, I worked a little on your codes with new files and made a youtube thumb block for display recent youtube videos thumbs. see the firs block on this page
I used this script in html file:

Code: Select all

				<script type="text/javascript">
					// <![CDATA[
					function youtubeFeedCallback(thumb_youtube){
						document.write('<a href="{thumb_youtube.TUBE_LNK_1}"><img src="' + thumb_youtube["data"]["thumbnail"]["sqDefault"] + '"></a><br/>');
						document.write('<strong>' + thumb_youtube["data"][ "title" ] + '</strong><br/>');
						document.write('<i>Trh:</i>{thumb_youtube.YT_DATE}<br/>');
						document.write('<a href="{thumb_youtube.TUBE_LNK_1}">{L_GOTO_VIDEO}</a>');
					}
					// ]]>
				</script>
				<script type="text/javascript" src="http://gdata.youtube.com/feeds/api/videos/{thumb_youtube.VIDEO_ID1}?v=2&alt=jsonc&callback=youtubeFeedCallback"></script>

I thought maybe you could use anything like this in your mod..
great little addon, thx
MMOG-Heaven - Das Gaming Portal
Community bedeutet Gleichgesinnte finden - MMOG-Heaven ist Deine Community! Von Spielern für Spieler bietet Dir dieses Portal genau das, was ein Spieler braucht. Bleibe ständig informiert, finde die neuesten MMORPGs, oder suche die frischesten News aus der Welt des Online Gamings - dieses und vieles mehr erwartet Dich auf MMOG-Heaven.

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

irdem wrote:my screen
you can try this (which is normally not necessary)

find (in mod edits)

WIDTH, 480, PADDING, 4,

replace with

WIDTH, 480, HEIGHT, 360, PADDING, 4,

after that clear unexceptional all board-, template-, style- and browser-caches and hit ctrl+f5 on your site
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
irdem
Registered User
Posts: 172
Joined: Sat Oct 13, 2007 10:31 pm
Contact:

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by irdem »

my display problem solved for ie with this change:
I added
style=min-width:480px;
between "img" and "src".
here is the line after this change:

Code: Select all

					<!-- IF S_YOUTUBE_HOVER --><span style="javascript:void(0);width:480px;height:360px;" onmouseover="Tip('<img style=min-width:480px; src=http://i2.ytimg.com/vi/{topicrow.TUBE_IMG_1}/hqdefault.jpg width=480 height=360 />', WIDTH, 480, HEIGHT, 360, PADDING, 4, BGCOLOR, '#DFE9F3', BORDERCOLOR, '#027AB7', OFFSETX, 100, OFFSETY, -100)" onmouseout="UnTip()"><a href="{topicrow.TUBE_LNK_1}"><!-- ENDIF --><img style="margin-top:2px;" src="http://i2.ytimg.com/vi/{topicrow.TUBE_IMG_1}/default.jpg" alt="" /><!-- IF S_YOUTUBE_HOVER --></a></span><!-- ENDIF -->
thank you..

User avatar
4_seven
I've Been Banned!
Posts: 5155
Joined: Wed Apr 30, 2008 1:41 am

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by 4_seven »

thanks for feedback and this solution for ie-8-behaviour.
Current Mods | Mod Base | php(BB) programming | No help via PM

User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: [DEV] Youtube [thumbs] on Forum Index v.0.0.1

Post by tumba25 »

Since the MOD author has been banned I'll lock this topic as [ABD] - Abandoned. If someone else wants to take over the development, please PM anyone on the MOD Team to request a link to your development topic. You can't reuse this topic, you need to start a new.

Notice!
We do not recommend that a user of the phpBB software install this mod, or any other mod that is marked as “abandoned” or “in development”, on a live forum. Doing so may cause your forum to not perform in the manner it should.


Thank you,
The phpBB Modifications Team
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net

Locked

Return to “[3.0.x] Abandoned MODs”