[ADB] Facebook For PhpBB Light

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Thu Mar 31, 2011 1:47 am

Jamy wrote:the facebook connect button isn't showing, all Im getting is plain text with no link that says facebook connect
Can I have a link to your site your testing on please.
Last edited by keitzy on Thu Mar 31, 2011 1:54 am, edited 1 time in total.
Image

User avatar
Jamy
Registered User
Posts: 429
Joined: Mon Mar 24, 2003 12:02 pm
Location: Mississippi

Re: [ALPHA] Facebook 2011

Post by Jamy » Thu Mar 31, 2011 1:54 am

http://www.jsiproject.com

edit.. I reinstalled alternate login for the time being

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Thu Mar 31, 2011 2:07 am

The problem lies within your overall_header.html

You have not put in {FBINIT} just under the body tag.
Image

kickball365
Registered User
Posts: 101
Joined: Thu Jul 13, 2006 2:48 am
Contact:

Re: [ALPHA] Facebook 2011

Post by kickball365 » Thu Mar 31, 2011 2:51 am

just went to your demo site and attempted to login using facebook (& then create a account) and got the error:
The field “Rules” must be completed.
All fields have been filled in yet it won't get me past this:
http://fb2011.damienkeitel.com/ucp.php?mode=fbregister

FWIW
kickball365

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Thu Mar 31, 2011 3:02 am

Thats because I'm in the current phase of developing the custom profile fields.
I will change back to my main forums.
Image

User avatar
Jamy
Registered User
Posts: 429
Joined: Mon Mar 24, 2003 12:02 pm
Location: Mississippi

Re: [ALPHA] Facebook 2011

Post by Jamy » Thu Mar 31, 2011 4:24 am

this mod is awesome!

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Thu Mar 31, 2011 11:06 am

Well I had to scrap the fb:registration process as it does not support text area's.
The custom profile fields will break it.
So instead I will revert back to the original registration process but instead the form will be just using a username field and the custom profile fields with the rest being hidden input field values populated by a call via Facebook Javascript SDK.
Image

TheDean
Registered User
Posts: 53
Joined: Sat Oct 13, 2007 12:45 pm

Re: [ALPHA] Facebook 2011

Post by TheDean » Thu Mar 31, 2011 3:08 pm

there seems to be a problem with Internet Explorer, just when I enter the username and choose my FB profile picture to be my avatar and click "Register" the box just turns blank white and nothing shows up, Tried it using Opera and it works fine.. what's the problem here?

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Thu Mar 31, 2011 5:15 pm

Which Internet explorer?
Image

TheDean
Registered User
Posts: 53
Joined: Sat Oct 13, 2007 12:45 pm

Re: [ALPHA] Facebook 2011

Post by TheDean » Fri Apr 01, 2011 9:47 am

Internet Explorer 8

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Fri Apr 01, 2011 10:10 am

Yeah its a known facebook bug. Just try and resubmit and if it keeps happening I'll install M$ IE A YEAR LATE, I mean 8 and test it.
Sorry to be negative about IE but IE and I just don't mix.
Last edited by keitzy on Fri Apr 01, 2011 10:19 am, edited 1 time in total.
Image

User avatar
antroid
Registered User
Posts: 7
Joined: Wed Feb 16, 2011 12:27 am

Re: [ALPHA] Facebook 2011

Post by antroid » Fri Apr 01, 2011 10:19 am

Code: Select all

Fatal error: Cannot redeclare class ucp_fb2011_info in /opt/lampp/htdocs/includes/ucp/info/ucp_fb2011_.php on line 21
I got Error in Module management >> user control panel but this mod works perfectly :P in supernova

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Fri Apr 01, 2011 10:27 am

Wow. I am never using modx generator again. I will do it by hand and it will take me a week. :lol: .
Ok somehow there are two generated files in includes/ucp.
if not just rename the ucp_fb2011_.php to ucp_fb2011.php other wise please delete it. Really weird because the test site I use with modx only has ucp_fb2011.php in the ucp/info folder.
Image

User avatar
Jamy
Registered User
Posts: 429
Joined: Mon Mar 24, 2003 12:02 pm
Location: Mississippi

Re: [ALPHA] Facebook 2011

Post by Jamy » Fri Apr 01, 2011 10:55 pm

Im getting this error when I try to link my facebook account

Code: Select all

phpbb.FBIDS_TABLE' doesn't exist [1146]

SQL

SELECT fb_id FROM FBIDS_TABLE WHERE user_id = 2

BACKTRACE

FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/ucp/ucp_fbconnect.php
LINE: 66
CALL: dbal_mysql->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: ucp_fbconnect->main()

FILE: ucp.php
LINE: 362
CALL: p_master->load_active()

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy » Sat Apr 02, 2011 12:55 am

Weird. None of that relates to Facebook 2011. Anything Facebook 2011 will have a prefix of fb2011. This was done on purpose to allow other Facebook mods to work simultaneously with Facebook 2011

The file names that similar to what you have posted.

fb2011_connect.php. lives in root/fb2011 folder
their is no ucp_fbconnect for facebook 2011 only ucp_fb2011.php.

any config database entries are all prefixed with like fb2011_appid and the table used to match a user id to the Facebook id is phpbb_fb2011_userdata which its fb2011_fb_id.
Image

Locked

Return to “[3.0.x] Abandoned MODs”