[ADB] Facebook For PhpBB Light

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
TheDean
Registered User
Posts: 53
Joined: Sat Oct 13, 2007 12:45 pm

Re: [ALPHA] Facebook 2011

Post by TheDean »

I have a question, if a registered user wishes to connect his membership with FB is it possible?
and if a facebook user wishes to login with his username and (password) what would the password be?

TY

User avatar
Trekky
Registered User
Posts: 236
Joined: Fri Jul 24, 2009 10:16 am
Location: Wiltshire
Name: Lesley Reed
Contact:

Re: [ALPHA] Facebook 2011

Post by Trekky »

Really gutted as it would seem i can't use this app when it launches do to the fact i have the social network app on my forum. After i looked into the small print on FB it would seem you're not allowed to have anything on your site that can confuse the user into thinking they are on FB or that they are part of its design.

This is sad as i like this MOD but my members like the social network MOD but you never know could be one for the future if i decide to have a change around ;)

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

TheDean wrote:I have a question, if a registered user wishes to connect his membership with FB is it possible?
and if a facebook user wishes to login with his username and (password) what would the password be?

TY
In user control once the mod is installed a panel is shown called Facebook Manger.
You can link your pre existing forum account by clicking the button on the user control panel facebook manager page. The user can still login with the non facebook account also.
Trekky wrote: Really gutted as it would seem i can't use this app when it launches do to the fact i have the social network app on my forum. After i looked into the small print on FB it would seem you're not allowed to have anything on your site that can confuse the user into thinking they are on FB or that they are part of its design.

This is sad as i like this MOD but my members like the social network MOD but you never know could be one for the future if i decide to have a change around ;)
Yeah I have tested that mod and infact thought that I was psoting my status to my facebook page as it copies facebook style very closely. When I checked my profile it was not there. So I checked the code and realised that it has nothing to do with facebook. I do infact plan to implement something very similar to that.
Image

sandman229
Registered User
Posts: 47
Joined: Wed Oct 08, 2003 6:09 pm
Location: Victorville, Ca.
Contact:

Re: [ALPHA] Facebook 2011

Post by sandman229 »

sandman229 wrote:
sandman229 wrote:I created an application and got the app ID and key. Is that all you fill out?? What would be the facebook page then?? where would your web/phpbb forums and likes go to what facebook page???

I get it now.. It posts to my log on facebook page and not in the app. I found my posting on my wall and I commented on it and it showed up on my forums. This thing really works. cool....

Sorry to say, I had to uninstall this mod. I really loved this mod. I was having trouble staying logged on. It kept logging me off. When I deleted it. Everything was fine again. Maybe its a setting or something but I was getting tired logging on I went from admin to form and back again.

sandman229
Registered User
Posts: 47
Joined: Wed Oct 08, 2003 6:09 pm
Location: Victorville, Ca.
Contact:

Re: [ALPHA] Facebook 2011

Post by sandman229 »

I might re-install this mod and do some checking. I also received an error when trying to register a new account on the board but I didn't copy the error to show you. I am using subsilver2 style. I have installed other comment mods which I really do not like.

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Nps. I am work8ing with a joomla site atm so when I have it stable I can give you a hand with yours.

To view my custom facebook page comments system.
http://foros.tecnogaming.com/index.php#comments_top
Image

ata326
Registered User
Posts: 5
Joined: Sun Feb 06, 2011 11:58 pm

Re: [ALPHA] Facebook 2011

Post by ata326 »

Very nice project. Keep goin' ! :)

sandman229
Registered User
Posts: 47
Joined: Wed Oct 08, 2003 6:09 pm
Location: Victorville, Ca.
Contact:

Re: [ALPHA] Facebook 2011

Post by sandman229 »

Have reinstalled this MOD. Had to do some tweeks to get it to work with subsilver2.

That image problem that show phpbb image comes from here:

http://external.ak.fbcdn.net/safe_image ... e_logo.gif

I changed my site_logo.gif but it didn't change. The image comes from safe_image.php. I am assuming that once this is made it can't be changed?? not sure how that works.

So far, this MOD has been working just fine. Also, fixed the registration error for subsilver. I guess I had made an error when I first installed this.

I used automod but there were a few errors on that also. Had to go thru and manually fix those errors.

Probably extra spaces in my files.

Anyway, works great except for that phpbb image that shows up.

murdoc182
Registered User
Posts: 1
Joined: Fri Apr 15, 2011 1:25 am

Re: [ALPHA] Facebook 2011

Post by murdoc182 »

hi ive tried this on my local server and i get this message when i click the connect to facebook button

An error occurred with my applcation. Please try again later.

and then i uploaded this on the live server then the button does not submit.




can you please help me how to deploy this online? and also please help me with the error from facebook.

thnx


and is this for free? :oops:

mitchboy999
Registered User
Posts: 125
Joined: Tue Jan 20, 2009 1:48 pm

Re: [ALPHA] Facebook 2011

Post by mitchboy999 »

keitzy wrote:Can't register at the moment. Web host ftp security is unbelievably tight and blocks me from uploading. So you cant register until I upload the edited files. Which will be in 8 or so hours when these rookies get back to me. Anyone know of a decent web host in Australia?
To show my appriciation of this mod, i can let you share on my dedicated server. PM me if interested.

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Thanx, I sorted out the problems with my web host.

Also Facebook 2011 cannot be run from a local server. Facebook Developer Applications require a domain to work.
Image

anothernovice
Registered User
Posts: 10
Joined: Thu Apr 21, 2011 2:16 pm

Re: [ALPHA] Facebook 2011

Post by anothernovice »

Everything appeared to work great, except I cant login with facebook.

from the error_log in fb2011

Code: Select all

[13-Apr-2011 03:19:54] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 03:21:20] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 03:51:18] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 04:00:01] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 04:01:27] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '.././facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 04:02:12] PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '..//facebook_app/php/facebook.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 42
[13-Apr-2011 04:07:47] PHP Warning:  include(common.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in /home/public_html/fb2011/fb2011_connect.php on line 27
[13-Apr-2011 04:07:47] PHP Warning:  include(common.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in /home/public_html/fb2011/fb2011_connect.php on line 27
[13-Apr-2011 04:07:47] PHP Warning:  include() [<a href='function.include'>function.include</a>]: Failed opening 'common.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 27
[13-Apr-2011 04:07:47] PHP Warning:  include_once(includes/functions_user.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home/public_html/fb2011/fb2011_connect.php on line 28
[13-Apr-2011 04:07:47] PHP Warning:  include_once() [<a href='function.include'>function.include</a>]: Failed opening 'includes/functions_user.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/public_html/fb2011/fb2011_connect.php on line 28
I don't know what is wrong, I have checked and rechecked my edits, they all appear right. :(

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Can you post your board link please. Thanx.
Image

IGCNWizzy
Registered User
Posts: 42
Joined: Mon Apr 11, 2011 7:26 am

Re: [ALPHA] Facebook 2011

Post by IGCNWizzy »

is this mod will be compatible if my forum has separated username [displayed across forums as name] and loginname [used to login only]?? I based on separate username and loginname mod.

IGCNWizzy
Registered User
Posts: 42
Joined: Mon Apr 11, 2011 7:26 am

Re: [ALPHA] Facebook 2011

Post by IGCNWizzy »

Well, I have read whole topic trought, seems to be all in one, perfect fb mod, I am even ready to send a donation when final release will apear, I know you like patient people but I am just curious when rofly I will be able to make my forum "alive" with the mod, would like to help in develop, but I am Cpp, asm, OGL coder wgo has to be administrator as well, as my team is too lazy to php stuff :P hahahaha, best regards ;)

Locked

Return to “[3.0.x] Abandoned MODs”