[ADB] Facebook For PhpBB Light

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

About 70% of the mod now is Javascript and jQuery with a little bit of php. To be able to join the crew you must have extensive knowledge of Facebook applications, FQL, Graph API, FB.ui, FB.api, XFBML.parse, Facebook JS SDK just as a start. I am holding at the moment as I am waiting for Facebook to repair their comments system and making a complete custom Facebook register for phpbb.

So if anyone is competent with any of the above please feel free to pm me and I'll gladly add you to the crew.

On holidays for Easter at the moment. Work shall continue on Tues.

Happy Easter everone. :)
Image

saintforlife
Registered User
Posts: 2
Joined: Sat Apr 23, 2011 8:39 pm

Re: [ALPHA] Facebook 2011

Post by saintforlife »

Can someone tell me where the instructions are to install this mod on my phpBB 3.0.8 subsilver forum?

I have downloaded the mod, but have no idea where to start. I am a newb and any step by step simple instructions are welcome.

TIA!

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

There actually is no subsilver support at the moment. I may include subsilver in the beta release.
Image

hathmak
Registered User
Posts: 3
Joined: Wed Feb 16, 2011 1:26 pm

Re: [ALPHA] Facebook 2011

Post by hathmak »

Problem :-
white page ...... When I click on login Button >>>> and url : http://www.hawks.dr-ho.org/fb2011/fb2011_connect.php

what is the Solution ????????????
Plezzzzzzzzzzz :cry:

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Can you please go into your config.php in the forum root directory and change

Code: Select all

//@define('DEBUG', true);
//@define('DEBUG_EXTRA', true);
to

Code: Select all

@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
Image

hathmak
Registered User
Posts: 3
Joined: Wed Feb 16, 2011 1:26 pm

Re: [ALPHA] Facebook 2011

Post by hathmak »

I Changed But ,
on header page showing message :-
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4401: Undefined index: FACEBOOK_LOGIN
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4408: Undefined index: FACEBOOK_REGISTER
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4612: Undefined index: palet

AND Still white page ,,,,,,,,,,,,,,,,,,, When I click on login Button

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Nice work with the translation. The FACEBOOK_REGISTER and FACEBOOK_LOGIN need to be also translated to you language directory common.php.

The white page is a mystery. Is your web server by chance a windows or mac server. Sometime fillezilla will use on LF line endings which would break on a mac and windows based web server.
Image

anothernovice
Registered User
Posts: 10
Joined: Thu Apr 21, 2011 2:16 pm

Re: [ALPHA] Facebook 2011

Post by anothernovice »

I enabled debug as well to see if their was something I was missing and got this notice,

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4599: Undefined index: fb2011_path
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4520: Undefined index: fb2011_page
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4563: Undefined index: fb2011_page

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

anothernovice wrote:I enabled debug as well to see if their was something I was missing and got this notice,

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4599: Undefined index: fb2011_path
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4520: Undefined index: fb2011_page
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4563: Undefined index: fb2011_page
They are settings that are going to be used in the beta version.
Image

User avatar
firebrad83
Registered User
Posts: 120
Joined: Wed Apr 28, 2010 5:31 pm
Location: UK
Contact:

Re: [ALPHA] Facebook 2011

Post by firebrad83 »

Great work keitzy!!

Watching this closely :mrgreen:
Firefighters - All give some.....some give all
Board Version - 3.0.7PL1
Board Style - Proformell
Board URL - http://www.retainedfirefighter.com

User avatar
heredia21
Registered User
Posts: 942
Joined: Sun Apr 18, 2010 6:14 pm
Contact:

Re: [ALPHA] Facebook 2011

Post by heredia21 »

What if we just want to use the facebook login/register
Best BlackBerry website for all users! BlackBerry News - http://blackberryempire.com

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

You can turn the like and comments plugins off in the admin control panel.
Image

User avatar
heredia21
Registered User
Posts: 942
Joined: Sun Apr 18, 2010 6:14 pm
Contact:

Re: [ALPHA] Facebook 2011

Post by heredia21 »

I am getting this when i go to facebook manager in ucp
SQL ERROR [ mysqli ]

Table 'bbempire_bbe.forumfb2011_userdata' doesn't exist [1146]

SQL

SELECT fb2011_user_settings FROM forumfb2011_userdata WHERE user_id = '2'

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/functions_fb2011.php
LINE: 155
CALL: dbal_mysqli->sql_query()

FILE: includes/ucp/ucp_fb2011.php
LINE: 52
CALL: get_fb2011_user_settings()

FILE: includes/functions_module.php
LINE: 507
CALL: ucp_fb2011->main()

FILE: ucp.php
LINE: 337
CALL: p_master->load_active()


When i do the SQL i get this in phpmyadmin

#1062 - Duplicate entry 'fb2011_admins' for key 'PRIMARY'
Best BlackBerry website for all users! BlackBerry News - http://blackberryempire.com

User avatar
heredia21
Registered User
Posts: 942
Joined: Sun Apr 18, 2010 6:14 pm
Contact:

Re: [ALPHA] Facebook 2011

Post by heredia21 »

I got it to work but when i click on facebook manager i get this.

Enable Facebook login.
If you would like to link and login using your Facebook account then please login with the button opposite and we will link your account.

I dont see any login button
Best BlackBerry website for all users! BlackBerry News - http://blackberryempire.com

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook 2011

Post by keitzy »

Are you using a custom style?

Did you refresh the template in admin panel styles?

Have you purged the cache in admin panel general?

Cheers :D
Image

Locked

Return to “[3.0.x] Abandoned MODs”