[ADB] Facebook For PhpBB Light

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by keitzy » Sun Jun 19, 2011 5:15 pm

OK Jim. To me there is some breakage in your javascript causing the facebook js to not be loaded as that the only possible reason why i cant see it not working.
Image

JiMlondos
Registered User
Posts: 20
Joined: Thu Nov 18, 2010 11:45 pm
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by JiMlondos » Sun Jun 19, 2011 5:21 pm

So there are no solution?
You think that i should remove the fb login button from there?

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by keitzy » Wed Jun 22, 2011 6:46 am

yeah most probably.
Image

seanob43
Registered User
Posts: 50
Joined: Mon Jun 13, 2011 4:02 pm

Re: [ALPHA] Facebook For PhpBB

Post by seanob43 » Wed Jun 22, 2011 3:38 pm

Hey,I love the mod but can't use because I had to delte my .htaccess file to allow my site to work.Anyway around this because of course when I try to install the mod it just says "can't find .htaccess"
Thanks,
Sean

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by keitzy » Wed Jun 22, 2011 3:42 pm

Wow never delete your .htaccess. Your allowing your site to be open to hacking attempts. You should instead talk to your server host and get them to sort out why the htaccess is blocking parts of your site. I suggest copying over the original .htaccess from a phpbb install
Image

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [ALPHA] Facebook For PhpBB

Post by DocSommer » Wed Jun 22, 2011 5:17 pm

Great Mod - I'll bookmark this :D

Q: Is or will it be possible to disable the comment/like features in every post for specific forums via ACP?

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by keitzy » Wed Jun 22, 2011 5:38 pm

Yes it is . And you can change the like button to suit your needs.
Image

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [ALPHA] Facebook For PhpBB

Post by DocSommer » Wed Jun 22, 2011 6:14 pm

thanks for the quick reply - is this mod ready to run on a live forum or would you recommend to wait until beta/final stage?

User avatar
boy_ofpersia
Registered User
Posts: 88
Joined: Sat Sep 13, 2008 5:58 pm
Location: Tehran, Iran
Name: Arman Pasayandeh
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by boy_ofpersia » Wed Jun 22, 2011 8:24 pm

Thank you man! Good job ;)
I will follow it.
"We tie knots & bind up words in double meanings, and then try to untie them"
--Seneca

User avatar
keitzy
Registered User
Posts: 359
Joined: Thu Nov 12, 2009 6:32 am
Location: Esperance, Western Australia
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by keitzy » Thu Jun 23, 2011 1:07 am

DocSommer wrote:thanks for the quick reply - is this mod ready to run on a live forum or would you recommend to wait until beta/final stage?
I would suggest waiting due to facebooks no reply to a recent email reguarding security that they have not released any information. I far as I am aware and my testing results have shown, this mod is fine but until I hear back from facebook I would hold off unless you have really good knowledge of phpbb and are confident you can update the changes without hassles.
Image

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [ALPHA] Facebook For PhpBB

Post by DocSommer » Thu Jun 23, 2011 6:03 am

I'm not a php expert but I install/update every of the MOD's I'm using manually since I have more trust in myself than automod - so there is usually no hassle as long as there are proper instructions in the manual install info files :lol:

To play it safe I'm gonna give it a try on a sencondary test forum first - I hope you get a reply from facebook regarding that security matter (what kind of btw.?).

theycallme.RUFFI
Registered User
Posts: 3
Joined: Thu Jun 23, 2011 6:26 am

Re: [ALPHA] Facebook For PhpBB

Post by theycallme.RUFFI » Thu Jun 23, 2011 6:27 am

I'm getting this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /fb2011/fb2011_connect.php on line 42: require_once(../facebook_app/php/facebook.php) [function.require-once]: failed to open stream: No such file or directory

Fatal error: require_once() [function.require]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/local/php-5.2.14-2/share/pear') in /nfs/c03/h03/mnt/55760/domains/therewillbescience.com/html/forums/fb2011/fb2011_connect.php on line 42

User avatar
kas5986
Registered User
Posts: 227
Joined: Sat Dec 26, 2009 11:16 am
Location: Karachi, Pakistan
Name: syed shafiq
Contact:

Re: [ALPHA] Facebook For PhpBB

Post by kas5986 » Thu Jun 23, 2011 6:28 am

NICE MOD :-)

theycallme.RUFFI
Registered User
Posts: 3
Joined: Thu Jun 23, 2011 6:26 am

Re: [ALPHA] Facebook For PhpBB

Post by theycallme.RUFFI » Thu Jun 23, 2011 6:41 am

NVM For my error, i had to edit line 39:

Code: Select all

$fb2011_path = $phpbb_root_path . $config['fb2011_path'] . '[b]fb2011/[/b]facebook_app/php/facebook.php';
And added what was in the bold. Works great now!

DocSommer
Registered User
Posts: 223
Joined: Mon Aug 24, 2009 10:30 pm
Location: Hamburg

Re: [ALPHA] Facebook For PhpBB

Post by DocSommer » Thu Jun 23, 2011 6:00 pm

I just did a test installation - so far so good, seems to work fine,

But I didn't figured out how to enable the commentbox for specific forums - I only found a global setting :(

Locked

Return to “[3.0.x] Abandoned MODs”