Page 20 of 41

Re: [ALPHA] Facebook For PhpBB

Posted: Sun Jun 19, 2011 5:15 pm
by keitzy
OK Jim. To me there is some breakage in your javascript causing the facebook js to not be loaded as that the only possible reason why i cant see it not working.

Re: [ALPHA] Facebook For PhpBB

Posted: Sun Jun 19, 2011 5:21 pm
by JiMlondos
So there are no solution?
You think that i should remove the fb login button from there?

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 6:46 am
by keitzy
yeah most probably.

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 3:38 pm
by seanob43
Hey,I love the mod but can't use because I had to delte my .htaccess file to allow my site to work.Anyway around this because of course when I try to install the mod it just says "can't find .htaccess"
Thanks,
Sean

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 3:42 pm
by keitzy
Wow never delete your .htaccess. Your allowing your site to be open to hacking attempts. You should instead talk to your server host and get them to sort out why the htaccess is blocking parts of your site. I suggest copying over the original .htaccess from a phpbb install

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 5:17 pm
by DocSommer
Great Mod - I'll bookmark this :D

Q: Is or will it be possible to disable the comment/like features in every post for specific forums via ACP?

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 5:38 pm
by keitzy
Yes it is . And you can change the like button to suit your needs.

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 6:14 pm
by DocSommer
thanks for the quick reply - is this mod ready to run on a live forum or would you recommend to wait until beta/final stage?

Re: [ALPHA] Facebook For PhpBB

Posted: Wed Jun 22, 2011 8:24 pm
by boy_ofpersia
Thank you man! Good job ;)
I will follow it.

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 1:07 am
by keitzy
DocSommer wrote:thanks for the quick reply - is this mod ready to run on a live forum or would you recommend to wait until beta/final stage?
I would suggest waiting due to facebooks no reply to a recent email reguarding security that they have not released any information. I far as I am aware and my testing results have shown, this mod is fine but until I hear back from facebook I would hold off unless you have really good knowledge of phpbb and are confident you can update the changes without hassles.

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 6:03 am
by DocSommer
I'm not a php expert but I install/update every of the MOD's I'm using manually since I have more trust in myself than automod - so there is usually no hassle as long as there are proper instructions in the manual install info files :lol:

To play it safe I'm gonna give it a try on a sencondary test forum first - I hope you get a reply from facebook regarding that security matter (what kind of btw.?).

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 6:27 am
by theycallme.RUFFI
I'm getting this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /fb2011/fb2011_connect.php on line 42: require_once(../facebook_app/php/facebook.php) [function.require-once]: failed to open stream: No such file or directory

Fatal error: require_once() [function.require]: Failed opening required '../facebook_app/php/facebook.php' (include_path='.:/usr/local/php-5.2.14-2/share/pear') in /nfs/c03/h03/mnt/55760/domains/therewillbescience.com/html/forums/fb2011/fb2011_connect.php on line 42

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 6:28 am
by kas5986
NICE MOD :-)

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 6:41 am
by theycallme.RUFFI
NVM For my error, i had to edit line 39:

Code: Select all

$fb2011_path = $phpbb_root_path . $config['fb2011_path'] . '[b]fb2011/[/b]facebook_app/php/facebook.php';
And added what was in the bold. Works great now!

Re: [ALPHA] Facebook For PhpBB

Posted: Thu Jun 23, 2011 6:00 pm
by DocSommer
I just did a test installation - so far so good, seems to work fine,

But I didn't figured out how to enable the commentbox for specific forums - I only found a global setting :(