Page 35 of 41

Re: [RC] Facebook For PhpBB Light

Posted: Mon Sep 24, 2012 8:53 am
by Tigerman75
O yes.i am deleted old and upload new ....but another this problem. :(

Re: [RC] Facebook For PhpBB Light

Posted: Wed Sep 26, 2012 5:57 am
by Eqrepro
We have a mirror copy of our "live" board on a localhost computer, which we like to run new mods on before taking them live for obvious reasons.

We have loaded this mod onto the localhost version (which has internet access), and have applied our "live board" FB App ID and App Secret numbers into the ACP. We've run the configuration panel successfully, Other than it showing one field that was already present (and I cannot remember which one it was, and of course cannot go back and run it again!), all was good. We have activated avatars in the ACP. We have manually cleared the cache as well as purging it multiple times via the ACP. There have been no error messages and the "board" is still operating as one would expect - with the exception that ABSOLUTELY NO FB icons, links, sign-in information or anything related to FB appears on the board anywhere!

Is this an issue related to our having it on a localhost, or is it something else? If it's related to localhost, if we take this "live" in it's current form (i.e. not showing errors) is that a reasonable indication that it shouldn't produce any issues on the live board? I have not made any changes to the DB, presuming that those are automatically done by the MOD? (Or do I need to create some tables?).

Finally, the one aspect that we had concerns about (and which was a primary reason for loading it on localhost first) is, will this interfere in any way with the current permissions of the board, which require an e-mail confirmation (to avoid spam) upon registration. I am (reasonably) happy to go with FB's confirmations, as long as it doesn't open up a hole for spammer access (beyond the obvious slight loss of control).

I'm still using 3.0.10; PHP is 5.2.17; MySQL is 5.0.91; I've used FF and Chrome as browsers.

Many thanks.

JM

Re: [RC] Facebook For PhpBB Light

Posted: Wed Sep 26, 2012 6:38 am
by keitzy
http://stackoverflow.com/questions/4532 ... -localhost

Why not create a dummy copy on your web server to test?
Running anything that requires a domain name callback wont work in general unless you use a tunnel or what is mentioned in the link posted.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 8:01 am
by xinguowei
This MOD works great so far. But we are having one issue regarding avatar - when the users choose to upload their own avatar, the system just shows the url instead of the actual image. For instance, if the user uploads an avatar image, it will display the string "./download/file.php?avatar=xxxxxxx.jpg". Or if the user uses a link from a remote site, it will just display the actual url string instead of the avatar image. It looks like it doesn't know to add the img tag in front the link. When I examed the database, the user_avatar field in php_uses table for facebook has the img tag already. Checked functions_display.php, it looks correct to me. Not sure how to fix this...

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 10:48 am
by keitzy
Ill have a look for you right now.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 11:49 am
by keitzy
Patch download : click here

Just upload it to store/mods and install like a normal mod.

Cheers and sorry for the bugs.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 3:19 pm
by xinguowei
Hi,

Thanks for the patch but it doesn't work. I still see the same problem after I installed it.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 3:53 pm
by keitzy
Can I have a link to your forum please?

Did you also refresh template and purge cache?

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 4:19 pm
by xinguowei
All I did was to purge the template cache in ACP after I installed the MOD with AutoMOD.

It seems it got a little worse now, meaning if I set a remote avatar link first, then changed it to a local upload. The display still shows the original remote avatar url not the local avatar image. In the UCP, I still cannot see the image itself, just the URL string.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 4:29 pm
by keitzy
actually it was a coding error from me. So many things going on, so many poeple to help.
I am really sorry. Please uninstall that patch.
I re upload a new in a couple of minutes.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 4:32 pm
by keitzy
Fixed Patch download : click here

If you installed previous patch then please uninstall then upload this to store/mods and install like a normal mod.

Cheers and sorry for the error.

./facepalm :oops:

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 4:59 pm
by xinguowei
Hmmm, this patch looks like the same as the last one. Still the same issue, and the changes made look the same to me as the last patch.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 5:09 pm
by keitzy
Yeah because the patch was still the old one. Winrar didn't actually update it because it was still asking me if I would like to update the archive.

So I re uploaded the updated archive.

Fixed Patch download : click here

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 5:25 pm
by xinguowei
Sorry, it is still the old patch.

Re: [RC] Facebook For PhpBB Light

Posted: Thu Sep 27, 2012 7:15 pm
by xinguowei
OK, it looks like the patch wasn't putting the code in the right spot. It needs to remove the original return statement in the functions_display.php file instead of just adding another line after the return. I made the change and everything is working now. Thanks for the help! Excellent MOD!