[ABD] spam hammer: ends spam. period.

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
dangerousprototypes
Registered User
Posts: 91
Joined: Fri Feb 11, 2011 5:53 am
Contact:

Re: [RC-1] spam hammer: ends spam. period.

Post by dangerousprototypes » Fri Aug 19, 2011 10:22 am

I cannot update our board to 3.0.9 because the automod tab causes a segfault on the server ever since the v3.0.9 release. I filed a report but got no help. I think it is part of the notification update causing the problem. I'm also waiting on other MODs we use to catch up.

Until I can update to 3.0.9 there will be no more work on the MOD, sorry. They phpBB3 code should be pretty similar, if you install it manually you should be able to hash out the differences.
Please do not PM or mail with questions. Ask in the forum where everyone can share the answer.

Ather
Registered User
Posts: 1032
Joined: Fri May 08, 2009 9:42 am
Location: Kingdom of Bahrain
Name: Ather Akber

Re: [RC-1] spam hammer: ends spam. period.

Post by Ather » Fri Aug 19, 2011 11:16 am

im using the code from the wiki, as i never trust automod...
CPL Syed Ather Akbar
Regional Command Southwest
Camp Leatherneck, Afghanistan

My Mods/Snippets

dangerousprototypes
Registered User
Posts: 91
Joined: Fri Feb 11, 2011 5:53 am
Contact:

Re: [RC-1] spam hammer: ends spam. period.

Post by dangerousprototypes » Fri Aug 19, 2011 11:23 am

There must be some more major changes then... I really have not looked into it at all, I'm sorry.
Please do not PM or mail with questions. Ask in the forum where everyone can share the answer.

azatoth
Registered User
Posts: 3
Joined: Tue Jul 07, 2009 5:17 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by azatoth » Fri Aug 19, 2011 8:11 pm

Actually I'm using Spam hammer with board version 3.0.9 without any issues at all.

Ather
Registered User
Posts: 1032
Joined: Fri May 08, 2009 9:42 am
Location: Kingdom of Bahrain
Name: Ather Akber

Re: [RC-1] spam hammer: ends spam. period.

Post by Ather » Sat Aug 20, 2011 1:26 am

thats weird, what is your "link blacklist" entry?
CPL Syed Ather Akbar
Regional Command Southwest
Camp Leatherneck, Afghanistan

My Mods/Snippets

dangerousprototypes
Registered User
Posts: 91
Joined: Fri Feb 11, 2011 5:53 am
Contact:

Re: [RC-1] spam hammer: ends spam. period.

Post by dangerousprototypes » Sat Aug 20, 2011 8:12 am

Actually I'm using Spam hammer with board version 3.0.9 without any issues at all.
Interesting, thanks for the tip.
Please do not PM or mail with questions. Ask in the forum where everyone can share the answer.

azatoth
Registered User
Posts: 3
Joined: Tue Jul 07, 2009 5:17 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by azatoth » Sun Aug 21, 2011 8:19 am

Ather wrote:thats weird, what is your "link blacklist" entry?
My link search strings are the default "http://,www.,.com,.net,.org,.uk,.ly,.me,.ru,.biz,.info,dot com,dot net,dot org,dotcom,dotnet,dotorg,_com,_org,_co_uk,_ru,dot ru"

User avatar
Hippie459MN
Registered User
Posts: 915
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [RC-1] spam hammer: ends spam. period.

Post by Hippie459MN » Sun Aug 28, 2011 3:39 am

Manual install here (Never use Automod. Peace of mind thing) on phpBB 3.0.9 and everything seems to be working perfect. I ran it through is paces and registration emails are working, notification emails are working, post limits working perfect.

Major thank you of this. Almost 2 years nothing with my anti spam question and in the last 2 months I have had about 8 users show up (Humans as I know a bot has yet to pass my anti spam question on the reg page) and they make 1 or 2 posts with links to some dumb sites for shoes or what not and leave. Hopefully this gets rid of them. :D

power44
Registered User
Posts: 2
Joined: Sat Oct 08, 2011 10:47 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by power44 » Sat Oct 08, 2011 10:54 pm

Thanks for this great MOD . but each time i try to install i keep getting this error. when i go to general->post settings after all the files has been upoloaded.
[phpBB Debug] PHP Warning: in file /adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
and i do not know how to fix it.

Philthy
Registered User
Posts: 210
Joined: Tue Dec 27, 2005 10:05 am
Location: Dawlish, Devon
Contact:

Re: [RC-1] spam hammer: ends spam. period.

Post by Philthy » Sun Oct 09, 2011 12:42 pm

power44 wrote:Thanks for this great MOD . but each time i try to install i keep getting this error. when i go to general->post settings after all the files has been upoloaded.
[phpBB Debug] PHP Warning: in file /adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
[phpBB Debug] PHP Warning: in file /adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at /language/en/acp/board.php:1)
and i do not know how to fix it.
Try checking the edits you have made to these files.
Go on ! it's not as steep as it looks.....

power44
Registered User
Posts: 2
Joined: Sat Oct 08, 2011 10:47 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by power44 » Sun Oct 09, 2011 7:21 pm

i have checked but still getting the error message. there is only one edit in the /language/en/acp/board.php

And i am using phpbb3.0.9 still getting the error of header already sent

Ather
Registered User
Posts: 1032
Joined: Fri May 08, 2009 9:42 am
Location: Kingdom of Bahrain
Name: Ather Akber

Re: [RC-1] spam hammer: ends spam. period.

Post by Ather » Sun Oct 09, 2011 7:52 pm

1) there is an empty space before the opening php tag
2) use a good editor like notepad++ and save the file as UTF-8 w/o BOM ( dont ever use notepad/dreamweaver )
CPL Syed Ather Akbar
Regional Command Southwest
Camp Leatherneck, Afghanistan

My Mods/Snippets

Nonstopdrivel
Registered User
Posts: 19
Joined: Thu Jan 13, 2011 8:28 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by Nonstopdrivel » Fri Oct 21, 2011 11:02 pm

I must be an utter dunderhead. I performed the SQL queries, I edited the files, I purged the cache, and I see absolutely no effect: no changes to my ACL, no blocking of profiles or signatures to new members, and no screening of "bad words." What could I possibly have done so glaringly wrong? I could imagine that I might have pasted the edits in the wrong spots, but I doubt it, since no errors, syntactical or otherwise, have been triggered. Any hints to help me over this hump?

EDIT: Wow, please disregard this post. I was an idiot and didn't think to look under Post Settings. It might be helpful if the documentation made this clearer. The Wiki makes it sound like the settings are simply under the General tab. Anyway, I did find the menu and the MOD seems to work perfectly. Thank you so much!

Nonstopdrivel
Registered User
Posts: 19
Joined: Thu Jan 13, 2011 8:28 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by Nonstopdrivel » Fri Oct 21, 2011 11:41 pm

I did, however, take the liberty of editing the error message in /includes/functions_link_filter.php to correct the typo and improve punctuation. I figure if we are going to scold users for not using English, we should probably express the error messages in standard English. ;)

The new error messages read as follows:

Your post looks too spammy for a new user. Please remove bad words or non-English text.

Your post looks too spammy for a new user. Please remove off-site URLs.

Your post looks too spammy for a new user. Please remove bad words or non-English text.

Your message looks too spammy for a new user. Please remove bad words or non-English text.


Hope this helps.

Nonstopdrivel
Registered User
Posts: 19
Joined: Thu Jan 13, 2011 8:28 pm

Re: [RC-1] spam hammer: ends spam. period.

Post by Nonstopdrivel » Sat Oct 22, 2011 12:48 am

The only niggling problem I am having with the Spam Hammer is that the minimum character per post filter is not working. I have it set to 73 per suggestion, but posts of any length can be submitted. This is true of both guests and new members on their first post. I have checked both the ACP and the PHP file, and they both say 73 characters. I'm not sure why the filter isn't working.

Locked

Return to “[3.0.x] Abandoned MODs”