Page 3 of 9

Re: [BETA] User Reputation MOD 0.3.3

Posted: Wed Aug 10, 2011 8:06 am
by victory1
Adrian1 wrote:To all that was having the problem with the reputation not added - it was caused by a setting to hight and in some circustance (if you set to 0 it will not calculate the right rep power).

Note: You will have to lower minimum posts required before having reputation power as per your requirements.

Download to the new version: http://www.phpbbmods.org/viewtopic.php? ... p=102#p102
I just finish updating my live board. So can I just re-upload the files without having to run the db_install.php? I don't want to uninstall since that might delete the points on the board. So how do I update? Thanks

Re: [BETA] User Reputation MOD 0.3.3

Posted: Wed Aug 10, 2011 8:09 am
by Adrian1
victory1, yes it is enought just to replace the files.
It is not required to run the db_install.php but you can run it and select the update option (it will just change the version in the database nothing more).

Re: [BETA] User Reputation MOD 0.3.3

Posted: Wed Aug 10, 2011 4:18 pm
by _Vinny_
Thanks for the update, I will test soon and post the result. ;)

Re: [BETA] User Reputation MOD 0.3.3

Posted: Wed Aug 10, 2011 5:02 pm
by Fonefixer
Working fine now since V3.3, thanks.

I do have a question though...

How easy would it be to put "Reputation" above the bars (if only using bars not text)?

Re: [BETA] User Reputation MOD 0.3.3

Posted: Wed Aug 10, 2011 8:02 pm
by Andaho
I've installed V0.3.2 on my live board here: http://www.die2nite.net

I've made a lot of custom changes to it to fit my board, but I've set up a test account so you can test the points system if you like:

username: testuser
password: testd2n

Re: [BETA] User Reputation MOD 0.3.3

Posted: Thu Aug 11, 2011 12:13 pm
by Adrian1

Re: [BETA] User Reputation MOD 0.3.3

Posted: Fri Aug 12, 2011 5:31 pm
by Fonefixer
As I said before, its working great now.

I would like to change one thing if I can though. I would like to centre the +/- buttons in the mini profile beside each post and dont really understand HTML that well. I know I have to use <div align=center somewhere in this line in viewtopic_body but im not sure how to.

Code: Select all

<!-- IF postrow.S_GIVE_REPUTATION --><dd><a href="{postrow.U_ADD_POS}"><img src="{T_IMAGES_PATH}reputation/add.png" title="{L_RP_ADD_POINTS} {postrow.POST_AUTHOR}" alt="{L_RP_ADD_POINTS} {postrow.POST_AUTHOR}" /></a><!-- IF postrow.S_GIVE_NEGATIVE--><a href="{postrow.U_ADD_NEG}"><img src="{T_IMAGES_PATH}reputation/subtract.png" title="{L_RP_SUBTRACT_POINTS} {postrow.POST_AUTHOR}" alt="{L_RP_SUBTRACT_POINTS} {postrow.POST_AUTHOR}" /></a><!-- ENDIF --></dd><!-- ENDIF -->
EDIT: Found it :D

Re: [BETA] User Reputation MOD 0.3.3

Posted: Sat Aug 13, 2011 9:51 pm
by Adrian1
A new plugin added:
Integration with Thanks MOD 0.2.0(by Mahoney)

Download:
http://www.phpbbmods.org/viewtopic.php?f=11&t=27

Re: [BETA] User Reputation MOD 0.3.3

Posted: Sun Aug 14, 2011 6:42 pm
by Mihkel
Anyone have experiences with this mod and phpBB 3.0.7_pl1 ?

Does it work with subsilver2 based styles? I have custom made style: http://board.koffer.ee

Re: [BETA] User Reputation MOD 0.3.3

Posted: Mon Aug 15, 2011 6:59 am
by Asef
I Use this MOD phpBB 3.0.9
When I try to give PositiveReputation,the mod works fine,but when I try to give Negative Reputation,The following error occurs,but when I refresh the page and back to the topic, the Negative Reputation point,is given!

The error is:
General Error

SQL ERROR [ mysql4 ]

Unknown column 'Array' in 'where clause' [1054]

SQL

SELECT username_clean, user_reputation FROM phpbb_users WHERE user_id = Array

BACKTRACE

FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_reputation.php
LINE: 498
CALL: dbal_mysql->sql_query()

FILE: includes/functions_reputation.php
LINE: 302
CALL: reputation->ban_user()

FILE: includes/functions_reputation.php
LINE: 365
CALL: reputation->subtract_point()

FILE: reputation.php
LINE: 180
CALL: reputation->give_point()

Re: [BETA] User Reputation MOD 0.3.3

Posted: Mon Aug 15, 2011 9:02 am
by Adrian1

Re: [BETA] User Reputation MOD 0.3.4

Posted: Mon Aug 15, 2011 9:03 am
by Adrian1
MOD Updated to version 0.3.4, some more bugs fixed.
Check here for more info:
http://www.phpbbmods.org/viewtopic.php?f=11&t=16#p125

Re: [BETA] User Reputation MOD 0.3.4

Posted: Mon Aug 15, 2011 12:52 pm
by maxwell2
Hello,
I installed the modification User Reputation MOD 0.3.4 and I have a problem, when I click on the rank of reputation (eg http://www.myforum.com/viewreputation.php?id=2 ) is a bug:

Code: Select all

Fatal error: Call to a member function reputation_end() on a non-object in /home/public_html/phpbb/includes/functions.php on line 4628
I installed AutoMOD

Re: [BETA] User Reputation MOD 0.3.4

Posted: Mon Aug 15, 2011 1:12 pm
by Adrian1
In includes/functions.php find:

Code: Select all

	global $reputation;
		$reputation->reputation_end();
Replace with:

Code: Select all

	global $reputation;
	$reputation = new reputation();

if(!empty($reputation)) {
		$reputation->reputation_end(); }

Re: [BETA] User Reputation MOD 0.3.4

Posted: Mon Aug 15, 2011 1:17 pm
by maxwell2
OK, now works fine
Thanks :)